Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Error Installing IIS Application Server

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error Installing IIS Application Server

    I just moved to a new Windows 2012 server. When I install IIS application server I get the attached error. I can't get my site to run, it just throws a 404 page. Some of my html files open fine but nothing with .a5w extension. Any thoughts?error.jpg

  • #2
    Re: Error Installing IIS Application Server

    It says the required service isn't installed so I would check services and see if the one it is complaining about is just not running.

    I'm running IIS Server on Windows Server 2012 without any problems, so I can take a look tomorrow and see if there is a HandleQueryConfig or similar service.

    Another thought is perhaps the service doesn't have the proper administrator permissions?
    Last edited by iRadiate; 07-17-2016, 09:44 AM.
    Alpha Anywhere v12.4.6.3.0 Build 7582-5569 IIS v10.0 on Windows Server 2019 Std in Hyper-V

    Comment


    • #3
      Re: Error Installing IIS Application Server

      I got pass that error. However, I am getting this error when trying to publish my files from alpha:

      There was an error attempting to create the web site or application pool in IIS. Unexpected exception Native error code: -1 Native error text: Native error text: Using ID for connections to the remote server. Pre-authenticating to remote agent URL 'http://www.site.com/MSDEPLOYAGENTSERVICE' as 'Administrator'. Connected to 'www.site.com' using the Web Deployment Agent Service, but could not authorize. Make sure you are an administrator on 'www.site.com'. Learn more at: http://go.microsoft.com/fwlink/?Link...USER_NOT_ADMIN. Code: 4100

      Comment


      • #4
        Re: Error Installing IIS Application Server

        Originally posted by swest View Post
        I got pass that error. However, I am getting this error when trying to publish my files from alpha:

        There was an error attempting to create the web site or application pool in IIS. Unexpected exception Native error code: -1 Native error text: Native error text: Using ID for connections to the remote server. Pre-authenticating to remote agent URL 'http://www.site.com/MSDEPLOYAGENTSERVICE' as 'Administrator'. Connected to 'www.site.com' using the Web Deployment Agent Service, but could not authorize. Make sure you are an administrator on 'www.site.com'. Learn more at: http://go.microsoft.com/fwlink/?Link...USER_NOT_ADMIN. Code: 4100
        If you have a resolution to a posted question please post the solution. In case others have the same problem in the future.

        As for your new problem, I ran into that one as well. In my case, installing Web Deploy 3.5 via Add Roles and Features did not install Management Service.
        Go to Control Panel | Programs & Features to change Web Deploy 3.5.
        Install missing component Management Service

        2016-07-17_13-43-54.png
        Alpha Anywhere v12.4.6.3.0 Build 7582-5569 IIS v10.0 on Windows Server 2019 Std in Hyper-V

        Comment


        • #5
          Re: Error Installing IIS Application Server

          Ok, I went in and changed Web Deploy 3.5 and installed them but am still getting the error.

          Comment


          • #6
            Re: Error Installing IIS Application Server

            Double-check your administrator credentials are correct.
            Alpha Anywhere v12.4.6.3.0 Build 7582-5569 IIS v10.0 on Windows Server 2019 Std in Hyper-V

            Comment


            • #7
              Re: Error Installing IIS Application Server

              Which part do I check in, I assume somewhere inn IIS?

              Comment


              • #8
                Re: Error Installing IIS Application Server

                I'm not sure Steven, it will be on the IIS Server, the error message is referring to the Remote Agent Service, but I can't check my own settings until tomorrow when I'm at work.

                Check the services:

                RAS.png
                Alpha Anywhere v12.4.6.3.0 Build 7582-5569 IIS v10.0 on Windows Server 2019 Std in Hyper-V

                Comment


                • #9
                  Re: Error Installing IIS Application Server

                  Thanks, if you will check tomorrow I would appreciate it. I running out of things to check

                  Comment


                  • #10
                    Re: Error Installing IIS Application Server

                    I am getting this error too when I try to configure the publishing, when I test the database connection it saids it is successful. Not sure if it is related.error 1.jpg

                    Comment


                    • #11
                      Re: Error Installing IIS Application Server

                      Could it be something with the alpha licensing server not renewing lease? I kept my old server going on AWS that was working fine, I just deactivated the IIS license on the old server and put it on the new one. Since I couldn't get the new server working, I deactivated the IIS license on the new server and put it back on the old server. Now, I cant get the old server working, it saids HTTP Error 503. Any ideas?

                      Comment


                      • #12
                        Re: Error Installing IIS Application Server

                        Have you tried recycling the application pool and refreshing your web application? It is my understanding that IIS is quite aggressive in caching data.
                        Alpha Anywhere v12.4.6.3.0 Build 7582-5569 IIS v10.0 on Windows Server 2019 Std in Hyper-V

                        Comment


                        • #13
                          Re: Error Installing IIS Application Server

                          Yep, now trying with the new server again.

                          Comment


                          • #14
                            Re: Error Installing IIS Application Server

                            When I manually place html files in the IIS directory I can access them from the web, but nothing that is a5w extension. The problem is so weird, and my site is down!

                            Comment


                            • #15
                              Re: Error Installing IIS Application Server

                              Got it, think I fixed it when I right click the site and chose deploy and configure deployment and chose the deployment account that was set up.

                              Comment

                              Working...
                              X