Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Images in Reports

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Images in Reports

    I have a free-form report with images in pulled from a MS-SQL database. I'm using the latest build of Alpha. I have modified the field definitions to make them JPEG. They are taken from the camera of a android tablet using Phone Gap and I want each image to be approx. 1 page on the report. Providing the database contains data and I leave the objects on the report alone all is well and I get a nice looking report.

    The problem is that not all of the image fields always contain data. So let's say image 3 is empty on some occasions; no matter what I try either I cannot see the image when there is data there or I get a blank page when there is not.

    If I set "Shrinkable" on the report object, when there is no data everything behaves correctly (pulling image 4 up to beneath image 2) but when there is data it just doesn't display the image. I can only think this a bug - I turn shrinkable off - the image appears - I turn it on the image disappears. If leave things alone when there is no data I get a blank page between image 2 and 4.

    I've tried every dynamic setting I can think of but nothing works. I've tried prototyping it in a free-form report with nothing but three images in and can reproduce the above exactly but am no closer to salvation

    PLEASE HELP - its driving me mad

  • #2
    Re: Images in Reports

    I have an image I call "blank.jpg" which is just blank and sized to fit. So, if I have a missing image, like a client logo, I just replace it with that. Works great.
    Pat Bremkamp
    MindKicks Consulting

    Comment


    • #3
      Re: Images in Reports

      Edit the datasource of the report. Select Advanced Options. Check 'Override field definitions of selected fields'. Override your image to JPEG image. That should do it I think.
      Mike Brown - Contact Me
      Programmatic Technologies, LLC
      Programmatic-Technologies.com
      Independent Developer & Consultant

      Comment


      • #4
        Re: Images in Reports

        Pat: thanks for the lateral thinking, that would potentially work but its not really an acceptable solution
        Mike: I've already done that as I said in my post, they don't appear at all if you don't do that

        I **THINK** I've solved it myself - surround a given picture with a conditional object, set the conditional object to be shrinkable and set the condition to be
        .not. isblank('pic_name')
        this seems to work correctly both when there is a picture and when there isn't

        I've done it for two pictures and so far so good. I'll do it to the whole thing and see if it works in practice rather than just in test.

        Comment


        • #5
          Re: Images in Reports

          AAAArrrrrrgggghhhh

          So that works perfectly in the Preview from the report designer and it works perfectly using a Javascript Action to open the report when in Working Preview but it doesn't work from either Live Preview or in the real world!!!!

          The images that are in conditional objects don't show. Anyone anywhere got any idea what I can do about it?

          Comment


          • #6
            Re: Images in Reports

            I'm reading through your post but I keep getting confused...

            You're working with a Free-Form Report and an MSSQL source. Your SQL table contains an Image field... a blob. Valid images are stored.

            You're working with the latest build of Alpha, but that could mean 2 different things... which build/version are you using?

            You want your report to display 1 record per page... so 1 image per page. Is there any other data on the report?

            In the data coming from the table, if each row contains an image, the report is ok. What do you want to happen if, for example, your report has 4 rows... normally 4 pages... but row 3 has no image.
            Do you want a page 3 with an empty image... or do you want page 3 to be ignored?

            If you want to ignore page 3 because it has no image, why not select rows from the table that only contain an image?

            Comment


            • #7
              Re: Images in Reports

              Originally posted by Transpeed View Post
              AAAArrrrrrgggghhhh


              The images that are in conditional objects don't show. Anyone anywhere got any idea what I can do about it?
              Did you put the conditional object on, set the conditions, then open the proper tab of the conditional object and add the image object?

              Or did you put the image down and "surround" the image with a conditional object? What does that mean?
              Al Buchholz
              Bookwood Systems, LTD
              Weekly QReportBuilder Webinars Thursday 1 pm CST

              Occam's Razor - KISS
              Normalize till it hurts - De-normalize till it works.
              Advice offered and questions asked in the spirit of learning how to fish is better than someone giving you a fish.
              When we triage a problem it is much easier to read sample systems than to read a mind.
              "Make it as simple as possible, but not simpler."
              Albert Einstein

              http://www.iadn.com/images/media/iadn_member.png

              Comment


              • #8
                Re: Images in Reports

                Thanks for the comments; I have been working on this and I find the following

                If I set a picture / image to "shrinkable" - it shrinks to nothing even it has data
                If I set the condition of a conditional object to be .not. isblank('imagename') it works in preview but not in the real world

                I can only assume these are bugs in Alpha but I note from T&Cs that if I pay for support they consider it resolved if, and I quote, "Confirmation that the issue is caused by an unresolved issue in an Alpha Software product" so they can stick that where the sun don't shine.

                I can work round the above MOSTLY by using a logical field in my data i.e. setting the condition of the conditional object to be a logical field which the users set (e.g. "thing is present which I want to take a picture of") which shows that my methodology, my data selection & report construction etc etc works

                Comment

                Working...
                X