Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook



The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic

Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.

If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.

Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.

Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Installed latest build and js errors

  • Filter
  • Time
  • Show
Clear All
new posts

  • Installed latest build and js errors

    I just installed the latest build (4346_4889) and I'm receiving the following javascript error on several on click, on change, and on focus events throughout my UX:

    Unhandled Javascript Error - _restoreListLow: "Uncaught ReferenceError: onChange_97931801690f4de3bae167aa2d93606a is not defined"

    I should add that the javascript was working fine before updating for the latest build.

    Any ideas?

  • #2
    Re: Installed latest build and js errors

    I started getting the same errors. There was a fix for the onchange event. Maybe the fix broke it even more.


    • #3
      Re: Installed latest build and js errors

      Thanks Lee. Do you know what build the fix was in?


      • #4
        Re: Installed latest build and js errors

        One cause of these errors is including bad Javascript syntax in your code. If your Javascript breaks, then required libraries may not get loaded and Alpha Javascript may not have what it needs to run. Older versions of Alpha Anywhere were more lenient when you excluded ending semi-colons in your code. The current release is less tolerant... as it should be. A clean-up of project code may do the trick.


        • #5
          Re: Installed latest build and js errors

          Thanks David - is there a quick way to clean up project code?


          • #6
            Re: Installed latest build and js errors

            Nope... you just have to slug through the events and functions and actions you've got.


            • #7
              Re: Installed latest build and js errors

              Important! Pre-rendered UX Components containing a List with updatable Detail View need to be recalculated in Alpha Anywhere 4.4.4. From the release notes:
              Alpha Anywhere V4.4.4 - Build 4346-4889 18-May-2017

              NOTICE: Alpha Anywhere is now being being built with Visual Studio 2015. Previously Alpha Anywhere was built using Visual Studio 2013.

              IMPORTANT: If you have UX components with Lists that have updatable Detail Views and these UX components were defined as pre-rendered then you will need to edit these components and resave them so that the pre-rendered code can be re-generated. You can use the Edit, Bulk Operations, Recalculate UX Components menu item to do a bulk update of your UX components.
              Try recalculating your UX Component first.
              Sarah Mitchell
              Documentation | Alpha Software Corporation
              Get in the know! Join us for our Weekly Webinars: TransForm Tuesday and Wednesday's Alpha Anywhere Demo and Q&A
              Connect with us: Instagram | Twitter | Facebook | LinkedIn | YouTube


              • #8
                Re: Installed latest build and js errors

                I upgraded the build on my server this AM from 4269-4867 to 4346-4889 and got an error when trying to save a file to my Customers Table. The error was telling me an argument was missing in my SQL. I rolled the release back and everything work fine.

                I reread the notes and followed the procedure to re-generate my lists. Published my files and everything worked fine.

                So I updated the server to the latest build (4346-4889) and the error happened again. I rolled it back to 4269_4867 and all is good again.

                Any ideas how to fix? I did not think I had the pre-rendered code on and I did the bulk edit as described in the notes.


                • #9
                  Re: Installed latest build and js errors

                  This is something different than Scott had. Scott, literally, had Javascript errors... missing semi-colons in his code which caused the errors he reported. Adding the semi-colons cleared the errors.


                  • #10
                    Re: Installed latest build and js errors

                    Like everybody else on V12, I'm getting an invite on startup to download build 4346. I did this and then couldn't start Alpha: missing VCRUNTIME140.dll so I had to uninstall and revert back to the earlier build. Having read this thread, I'm not sure I want the new patch yet...

                    Meanwhile, I'm having a problem with tables, which is why I tried to install the patch. If I amend any cell properties in a table, on save, that cell inserts in own background and border colours. I am then forced to amend them to white - leave them blank and they change colour. Does anybody if this been reported elsewhere? And does this patch fix it?


                    • #11
                      Re: Installed latest build and js errors

                      I keep getting this error when I open a particular UX in a tabbed UI:

                      Unhandled Javascript Error "Uncaught TypeError: Cannot set property of 'userSelect' of undefined"

                      I have not been able to find the cause.