Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Emailing A Report Won't work

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Emailing A Report Won't work

    Hi All

    I am running Alpha Anywhere Developer Version 12.4.3.2 Build 4077.

    I recently upgraded our 2 computer network to new computers. Both the older and newer computers are running Windows 10 and both use Outlook 365 for email.

    Since the upgrade, I cannot send a PDF report by email. I tells me "Either there is no default mail client or the current mail client cannot fulfill the messaging request." and suggests I open Outlook and set it as the default mail client.

    I have checked and Alpha Anywhere is set to use the default client and Outlook is set as the default mail client. I also checked our older computers. We are running the same version of Alpha Anywhere on the newer and older computers and the newer computers have the email settings set the same way as the older computers do. It worked fine on the older computers.

    Does anyone have a suggestion?

    Thanks

    Steve

  • #2
    Re: Emailing A Report Won't work

    check to be sure the pop3 settings have not changed, and check that you have permissions, in your security settings in windows
    Cole Custom Programming - Terrell, Texas
    972 524 8714
    martin_w_cole@msn.com

    ____________________
    "A young man who is not liberal has no heart, but an old man who is not conservative has no mind." GB Shaw

    Comment


    • #3
      Re: Emailing A Report Won't work

      Thanks for the suggestions Martin. Both are good ideas.

      I checked that the Outlook settings are the same for both the older and newer computers and they are. I also checked permissions in my firewall and then temporarily turned off the firewall and it still won't work.

      Does anyone have another suggestion?

      Comment


      • #4
        Re: Emailing A Report Won't work

        any chance you can run your desktop application in windows 8 compatibility mode? I doubt it will make any difference but that's my go to when windows 10 is involved, you'll either get the same exact msg OR it will work. Of course there is always the next rabbit hole microsoft will send you down in search of things that used to work...while both PC's were running 10 perhaps there is an update on one that is not present on the other
        NWCOPRO: Nuisance Wildlife Control Software My Application: http://www.nwcopro.com "Without forgetting, we would have no memory at all...now what was I saying?"

        Comment


        • #5
          Re: Emailing A Report Won't work

          What Folder is Alpha in?
          Ted Giles
          Example Consulting - UK
          .

          sigpichttp://ec12.example-software.com//
          See our site for Alpha Support, Conversion and Upgrade.

          Comment


          • #6
            Re: Emailing A Report Won't work

            along with the message I just responded to, at a quick glance, this looks like some sort of incompatibility between Alpha and outlook 365.

            Is anyone else running outlook 365 as a default e-mail client and alpha v12?

            As I said in my post to the other e-mail problem, we have transitioned to SMTP e-mail which we can control a bit more closely.


            Tom

            Comment


            • #7
              Re: Emailing A Report Won't work

              I am with Tom. Having been through the entire emailing process ad nauseum, smtp methods are the only way to go. It takes some setup but is the only truly reliable method. I am sure I have posted code for rock solid smtp email methods before.
              Mike W
              __________________________
              "I rebel in at least small things to express to the world that I have not completely surrendered"

              Comment


              • #8
                Re: Emailing A Report Won't work

                Mike,

                If not,

                here is one I keep as a code snippet:

                Code:
                DIM pm as P
                msg_text = 'body of the message goes here
                pm.from = mail_from  'who is sending the e-mail
                pm.from_alias = 'if you want an alias name in the "From"
                pm.to = mail_to  'a valid e-mail address
                pm.subject = 'what you want your subject to be
                pm.cc = ""				'mail_cc
                pm.bcc = ""
                pm.message = msg_text
                if email_smtp_open(ps,your e-mail server address,25,"a valid e-mail account","that e-mail's password")
                	email_smtp_send(pm,ps)
                	email_smtp_close(ps)
                  else
                                'Header text is what you want to the message box header to be
                  	ui_msg_box(Header text,"Problem! - There is a Problem with the SMTP Email"+crlf()+"No e-mail was sent to "+mail_to)
                end if
                Hope this helps...


                be sure your antivirus understands that Alpha program is sending e-mails, or else it will prevent it.

                We had an issue with McAfee

                Tom
                Last edited by Tom Henkel; 09-10-2019, 08:40 AM.

                Comment


                • #9
                  Re: Emailing A Report Won't work

                  I had this error message happening on one user's SurfacePro in a networked Alpha Five v12 application re the Alpha Send dropdown, but it was working for other computers on the same network. My research concluded that the issue in this case was that the version of Outlook on the SurfacePro was installed as a 64bit version, which no longer accepts the MAPI SendDocument request used by the Alpha Send dropdown. The Alpha 'Email_Client_External' function uses a different more advanced MAPI request that is still supported by 64bit Outlook, and so I have had to provide a button that uses the 'Email_Client_External' function for this user to now successfully be able to send emails via Outlook 64bit. I am in the process of updating my whole application to only use this function and remove the Send dropdown from the front end!

                  Comment

                  Working...
                  X