Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Report Disappeared

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Report Disappeared

    I am new to AA12 (former v8 user - 5 years). I am using v3.5 developer.
    In our network environment, I have all dbf's and related files on a WinServer 2008. Being used by small network of 10 users.
    Users are mixed of mostly V8 and AA12 runtime's.

    I opened a report to make a small edit. Report is based on "currently selected records"
    I needed to change that to: "prompt for additional criteria at runtime"
    When I make the change to the report and hit SAVE I get this Alpha Anywhere error:
    System cannot find the path specified (then shows the path in the error ending in .....report name.a5bak
    When I 'x' out of the error window, I get another error: Read past end of file occurred while trying to start application.
    When I try to access the report, I get this error: Error - Report not found.
    If I restart my developer and re-open the database, the report is no longer visible in the control panel.
    If I try to "COPY TO" the report from a good copy of the database I get another error saying the report already exists.

    HELP!



    Initially i made this change to the report I am working strictly on my local pc

  • #2
    Re: Report Disappeared

    I may have determined the issue. Am still trying to prove it.
    It looks like you cannot use the "/" character in naming reports in AA12. Several A5v8 reports had the slash in the title, including the one I was trying to change. Never was a problem before. We just started using AA12 (a few weeks now) - wonder what other surprises I'll find the hard way?

    Comment


    • #3
      Re: Report Disappeared

      One place that helps with the basic concepts.

      I follow the naming convention for table, field and paths for all objects.

      http://wiki.alphasoftware.com/~alpha...nd+Terminology
      Al Buchholz
      Bookwood Systems, LTD
      Weekly QReportBuilder Webinars Thursday 1 pm CST

      Occam's Razor - KISS
      Normalize till it hurts - De-normalize till it works.
      Advice offered and questions asked in the spirit of learning how to fish is better than someone giving you a fish.
      When we triage a problem it is much easier to read sample systems than to read a mind.
      "Make it as simple as possible, but not simpler."
      Albert Einstein

      Comment


      • #4
        Re: Report Disappeared

        So indeed, that was the issue. Our a5v8 had a few report names that used the "/" character. I 'renamed' those reports to avoid this issue in the future.
        BUT I STILL HAVE A CONCERN. I suspect that since the error occurred, Alpha Anywhere may have some corrupted code or just completely damaged the report. The report is no longer visible and I did not DELETE it. I think there should be a ticket issued at Alpha to have a look at this issue. The software should not be able to self-destruct reports. I can duplicate the problem every time with backup copies.

        Comment


        • #5
          Re: Report Disappeared

          John,

          The recommended approach is to use the same runtime version on all workstations, and use the same runtime version / build as the "full" or "developer" version that was used to create or update the design. It sounds like you're mixing versions.

          I'd be interested in seeing an example of self-destructing reports. Contact me off line if you want. Or, if you prefer, attach a small sample here with instructions for us to follow.

          -- tom

          Comment


          • #6
            Re: Report Disappeared

            John:

            I tested the "/" in a report name in version 12, and it does cause the issues you state. I agree, Alpha should not allow the character in the name to begin with.

            You can submit a bug report to Alpha, and they will probably prevent illegal characters from being saved in a name by warning the user. In general, I do not use and do not recommend using Windows illegal naming characters when naming within Alpha, including:

            < > : " / \ | * ?

            Keep in mind you will have other issues than that. As Tom points out, using two different runtime versions is a risky move to begin with, and being that the versions are 7 (by my count) versions and years apart can have an even greater negative impact at some point when either deprecated code or post-version 8 enhancements are used in your application.

            To be frank, I'm surprised you aren't having more issues than you seem to be... Perhaps all the development was done in version 8???

            Comment


            • #7
              Re: Report Disappeared

              Tom / Craig,
              Thanks for the input. You do get an illegal naming error in v12. But I only received it when I went to open a version 8 report that used the slash in the name. I have since gone thru the reports, browses, and other objects for illegal characters and renamed them. To respond about mixed run times, I did have a conversation with a sales person at Alpha, who told me that multiple accounts have mixed runtime versions, so I wasn't too concerned. My goal was to change over all users within a month or so anyway. My gut feeling was like yours initially, until I had the Alpha conversation. I will speedup my conversion schedule. When I initially decided that it was time for the switch from A5V8, there was little information (that I could find) at Alpha regarding any tricks or hints from 8 to 12. We are in the transportation industry, and there is NOTHING exotic about this application: just a simple order tracking system, some flat tables and a few joins. So maybe that is why we have not encountered anything serious (yet).

              Comment


              • #8
                Re: Report Disappeared

                I did have a conversation with a sales person at Alpha, who told me that multiple accounts have mixed runtime versions, so I wasn't too concerned.
                Get concerned about this. Regardless of what a "sales" person says, you can have issues. Especially where using v10 back and v10.5 forward there was a lot that changed.

                I am just finishing a v8 to v12 move for a client now. It was a nightmare.
                Seems to me, when you open v8 code in v12, it can quit working after a save. Then has to be rewritten to v12 specs.
                Dave Mason
                dave@aldadesktop.com
                Skype is dave.mason46

                Comment


                • #9
                  Re: Report Disappeared

                  Hi Dave, thanks for the reply. I fully understand and really share your concern with my v8 to v12 upgrade. The saving grace, for us, may be that almost no code or script was ever used to design my system. Other than whatever code Alpha uses in the background, my tables, browses, forms and reports were created as pure drag and drop fields. Maybe the most complex objects was a report that contained a sub-report, or a browse with a calculated column. I do have a question that I can't seem to get answered; what sort of 'things' in your reply, had to be re-written to v12 specs?

                  Comment


                  • #10
                    Re: Report Disappeared

                    Pardon me for jumping in Dave.

                    John:

                    Here's a link to new features in version 10:

                    http://wiki.alphasoftware.com/~alpha...+in+Version+10

                    Now, opening that, click on "browse v10" as an example.

                    Any browse designed in version 12 will be under the "Completely rewritten" version. I don't know for sure, but there may be issues opening that browse in version 8. The probabilty seems high there would be some issues.

                    After hitting the back button, click on "Form Level Field Rules v10".

                    If you were to use this feature in version 12 on a variable, anyone opening that form in version 8 will either a) Get an error message or b) Be able to bypass rules you set at the form level, or c) Both of the above.

                    I remember a while back, upgrading from version 4.5 to version 9. There were so many changes. Arrays were framed with brackets, not parenthesis, dialog boxes opened differently, etc. I forgot to upgrade the runtime on one machine, and the forms all looked strange because there were no gradients available in 4.5. Oh, yes, and between version 4.5 and 9, they completely rewrote the custom toolbars, so all those needed to be redesigned.

                    Of course, now, there aren't too many changes (sadly) on the desktop side, so the jump from 12.1 to 12.3 may not have any issues at all, but the jump to 8 from 12 is a large one.

                    On the flipside, a few functions in version 8 have been deprecated in version 12, meaning they were replaced by better functions. Yes, I think most will still work on version 12 as is, but who would take a chance if the data is important?

                    I just moved a pretty basic application from 9 to 12. A tabbed form with 5 tabs had the fields disappearing when opened in 12 new record mode. It required I open the form in design mode of version 12, and save it. Problem solved, but whatever it was that caused it, I'll never know.

                    I'll give you that a very basic app like yours may pay well under version 12, but I always open everything in design mode, and save it in the new developer program. Even the field rules. It's arguably not necessary to do that, but as long as I hit everything, it only takes a few minutes to do all the rules, structure, reports, forms, etc. I'm pretty sure it pays off in the long run...

                    In closing, I say this... The sales people at Alpha must be doing drugs...
                    Last edited by CraigSchumacker; 11-05-2015, 08:39 PM.

                    Comment


                    • #11
                      Re: Report Disappeared

                      Hi Craig,
                      Thanks for all the great advise and the time you took to reply. I will hasten my effort to get all users on v12 runtimes. As I mentioned, my saving grace may be how simple we have been able to keep the database over the last 10 years. Most of the tables have nothing but regular fields (num, char, & date). Only 1 set. Four tables have only "one-to-many" type linking fields, and there are very few field rules. The ones that do, are simple lookups, and 1 auto number field (order#). The only issue we've seen on a pretty constant nature was index issues. I frequently have to re-index all the tables (version 8). I am hoping that will go away with the upgrade to v12.

                      Comment


                      • #12
                        Re: Report Disappeared

                        You will find connecting tables in sets a bit more touchy.
                        Mismatched fields like different lengths do make a difference in v12
                        Dave Mason
                        dave@aldadesktop.com
                        Skype is dave.mason46

                        Comment

                        Working...
                        X