Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook



The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic

Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.

If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.

Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.

Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

xbasic enter new record not working in transition from 10.5 to 12

  • Filter
  • Time
  • Show
Clear All
new posts

  • xbasic enter new record not working in transition from 10.5 to 12

    Today I purchased Version 12 and while checking functionality in my application created with earlier versions I noted an issue. When I use push a button to create a new record in another table with an xbasic script that functioned previously I get errors. When I use action scripting in the new version and look at the code it is the same as generated by earlier versions and still does not function as it does in version 10.5 . Is this action scripting method no longer functional, and why?

    field types don't match.......and subproperty cannot be assigned.........are the key words from the truncated error message.

    Here is the script that functions in 10.5 but not in the version 12 I just paid for. Buyers remorse in 5 minutes ? I hope not!

    'This action has been commented out.
    ' 'Open the table that you want to update...
    ' dim tbl as p
    ' tbl ="islhcfa",FILE_RW_SHARED)
    ' tbl.enter_begin()
    ' tbl.PAT_ID = ""
    ' tbl.FIRST = a5_eval_expression("=First",local_variables())
    ' tbl.DOB = a5_eval_expression("=Dob",local_variables())
    ' tbl.DT_SERV = a5_eval_expression("=Dt_Serv",local_variables())
    ' tbl.TOS_1 = a5_eval_expression("=Tos_1",local_variables())
    ' tbl.PLCSERV = a5_eval_expression("=Plcserv",local_variables())
    ' tbl.TRANSNO = a5_eval_expression("=Transno",local_variables())
    ' tbl.enter_end(.t.)
    ' tbl.close()

    Thanks for any help with this


  • #2
    Re: xbasic enter new record not working in transition from 10.5 to 12

    try changing the variable named "first" to something else, frst or something like that.
    then populate it with the data and see if it works
    tbl.FIRST = a5_eval_expression("=Frst",local_variables())


    • #3
      Re: xbasic enter new record not working in transition from 10.5 to 12

      If that's the code for the action script which is not working, the action script shouldn't work. Not sure where the errors arise but the action seems to be commented out. Perhaps later actions are relying on something which should happen in this action?
      Last edited by Stan Mathews; 12-28-2015, 09:10 PM.
      There can be only one.


      • #4
        Re: xbasic enter new record not working in transition from 10.5 to 12

        try going to an earlier version - if that fixes it - report as bug
        if not, report as bug
        Cole Custom Programming - Terrell, Texas
        972 524 8714
        [email protected]

        "A young man who is not liberal has no heart, but an old man who is not conservative has no mind." GB Shaw


        • #5
          Re: xbasic enter new record not working in transition from 10.5 to 12

          I sent in the bug report and tried to create this error in a new workspace. (I am impatient and I needed a quicker answer than to wait for a reply)

          The bug persisted in the new workspace.
          Then with Gary's advice (thank you) I went back and tried a different way to get my fields "First" and "Last" into the script. I added variables to grab them from the form and used those variables to supply the script. It worked.

          Apparently (I am assuming) the words "First" and "Last" when used with version 12 are reserved (interpreted) differently when used in this kind of script. Since I use these as field names extensively I will have to rewrite a few scripts.


          • #6
            Re: xbasic enter new record not working in transition from 10.5 to 12

            I don't use A5_Eval_Expression(), so looked it up in the helps. The documentation indicates that this function returns a CHARACTER value in its OUTPUT. If you were assigning character values to non-character data typed table fields this might account for what you saw.


            • #7
              Re: xbasic enter new record not working in transition from 10.5 to 12

              there is a difference between the versions.
              in the interactive window of v11:
              dim first as c
              first = "gary"
              ? a5_eval_expression("=First",local_variables())
              = "gary"

              in v12:
              dim first as c
              first = "gary"
              ? a5_eval_expression("=First",local_variables())
              = A first(A subexpr[,G over[,G each]) 'Get the first of subexpression over group 'over' sampled each group 'each'

              so, it's actually using the first() function. it was probably a bug in previous versions, using an invalid keyword, that they fixed in v12.

              I typically would use something like this:

              dim fname as c
              fname = "Gary"
              tbl.firstname = fname
              you could use your field name, too.
              tbl.frst = fname