Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Unable to create or edit pages

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to create or edit pages

    When I try to create or edit an A5W or HTML page from the Web Control Panel, I get the following error:

    Script:UI_DLG_BOX:@=HTMLEditorDlgTitle line:37
    f =
    ole.create("DEGetBlockFmtNamesParam.DEGetBlockFmtNamesParam")
    Could not open OLE object
    'DEGetBlockFmtNamesParam.DEGetBlockFmtNamesParam'

    I get similar but different errors if I try to save any changes to those pages or create a Component.

    I am running Windows Vista Business with all the latest updates installed, as well as the latest version of Alpha 5: v10, build 2649, System Addins Build 3513. I have already tried uninstalling and reinstalling Alpha 5v10, but nothing changes.

    Does anyone have any clue what's going on? I would really appreciate any help.

  • #2
    Re: Unable to create or edit pages.

    I think it is related to the WYSIWYG editor. Search your system for dhtmled.ocx.

    Googling "DEGetBlockFmtNamesParam.DEGetBlockFmtNamesParam" lead me to http://msdn.microsoft.com/en-us/library/aa663363.aspx. Which lead me to the previous mentioned Activex component. Evidently this is no longer included with Vista but I have not seen anyone mention this issue before. Therefore I doubt that it not being shipped with Vista is the issue. Unfortunately I do not have a Vista machine to test on.

    In Windows XP I found the above file referenced at C:\Program Files\Common Files\Microsoft Shared\Triedit
    Andrew

    Comment


    • #3
      Re: Unable to create or edit pages.

      aws, thanks for the help.

      So a little more history: When I had first tried to install Alpha Five, it had gone through the whole process, and then right at the end given me an error: "A required resource could not be located." Vista had suggested Compatibility mode, so I installed it again in Compatibility mode, and didn't get the message.

      Anyhow, aws, the Microsoft article you linked to has a link to a DHTMLEditor installer for Vista. But when I tried to run it, it gave me the "A required resource could not be located." error again. Aha! So Alpha Five tries to install it for Vista, but the install wasn't working on my system for some reason.

      I searched Google and found someone who was getting the same error when trying to open .msi files. They said the problem had been the extractor. So I changed the DHTMLEd.msi file to be opened by Windows Installer instead of Win32 Cabinet Self-Extractor, and the install worked.

      Now I don't get the error message anymore. Thanks for your help!

      Comment


      • #4
        Re: Unable to create or edit pages.

        I am having the same error, I am on a new Windows 7 Professional machine with 4Gb RAM, 32-bit version

        I click on New, A5W page, Blank Page, then I get this error

        Script:UI_DLG_BOX:@=HTMLEditorDLGTitle line:37
        f=
        ole.create("DEGetBlockFmtNamesParam.DEGetBlockFmtNamesParam")
        Could not open OLD object
        'degetblockfmtnamesparam.degetblockfmtnamesparam'


        A blank html window comes up, and I can't type in the WYSIWYG part, there's only
        </body></html>
        in the Source tab, no control menu on the menubar, and I can't save the
        file.

        I've tried this again with V10.5, and get the same result.

        Meanwhile, I'm running OK in a virtual XP machine window, but I would like to get the thing going on Windows 7, I've sent in 2 support requests (some time ago) and the only reply I've received is "it works on Win 7"

        I've looked into the DHTML editor, this only seems to apply to Vista.

        Any insight/solution would be much appreciated!

        Comment


        • #5
          Re: Unable to create or edit pages.

          Have you tried out my solution, above?

          Comment


          • #6
            Re: Unable to create or edit pages.

            yes, I downloaded from
            http://www.microsoft.com/downloads/d...displaylang=en
            and installed the DHTML editor
            When i reinstalled Alpha 5, after it was almost done, I get the choice to
            repair or remove the DHTML Editing Component

            I've tried both.
            With Repair, I get the same error
            with Remove, I get a blank screen with no error when I try to make a new HTML page

            Since I'm on Windows 7, I'm not sure if the Vista fix is relevant, but I'm willing to try anything at this point!

            Thanks for your input :)

            Comment


            • #7
              Re: Unable to create or edit pages.

              From the release notes July, 1th 2010

              Batch Files to Re-register OCX and DLL Files - Occasionally, (typically after installing a patch) you might encounter an error when Alpha Five tries to render some HTML content. Or the error might occur in a dialog that has a Property Grid control. These errors are the result of one of the DLL files that Alpha Five uses becoming 'unregistered'. Generally, reinstalling Alpha Five will fix the problem, but now two special batch files (one for Vista/Windows 7 user, and one for XP users) are included to make re-registering all necessary files very easy. The batch files are in the Alpha Five program folder and are:
              RegisterFiles.bat RegisterFilesVistaWin7.bat If you are using Vista or Windows 7 you must run the appropriate batch file using Administrator privileges.
              To run the batch file:
              Open Windows Explorer. Navigate to the folder where Alpha Five is installed and then right click on the appropriate batch file. Select the 'Run as administrator' command. Note: The RegisterFilesVistaWin7.bat file will register .dll and .ocx files and then run the dhtmled.msi installer to repair the Internet Explorer ActiveX control. Alpha Five uses this control to render HTML in many places (such as the Grid builder, HTML editor, etc.)

              Comment


              • #8
                Re: Unable to create or edit pages.

                Hi, thanks for the ipo, I ran
                RegisterFilesVistaWin7.bat
                got all the registration messages and it ran the dhtmled.msi installer

                Opened Alpha, tried to crate an HTML file, I get a blank window with OK in the lower right corner, when I click OK, the window goes away.
                When I try to create a new A5W page, I get the same error as originally:
                Script:UI_DLG_BOX:@=HTMLEditorDLGTitle line:37
                f=
                ole.create("DEGetBlockFmtNamesParam.DEGetBlockFmtNamesParam")
                Could not open OLD object
                'degetblockfmtnamesparam.degetblockfmtnamesparam'

                A blank html window comes up, and I can't type in the WYSIWYG part, there's only
                </body></html>
                in the Source tab, no control menu on the menubar, and I can't save the
                file.

                back to the same place.....

                Comment


                • #9
                  Re: Unable to create or edit pages.

                  should be "tip" ont he first line, not "ipo"..... horrible typing.....

                  Comment


                  • #10
                    Re: Unable to create or edit pages.

                    Did you do the install <bat> run as administrator?

                    Comment


                    • #11
                      Re: Unable to create or edit pages.

                      Yes, I was admin when I ran the bat(ches)

                      Comment


                      • #12
                        Re: Unable to create or edit pages.

                        BTW, this (original error) happened right away, after a new, clean install of A5V10 on a new, uncluttered Win7 Pro machine (dell, yeah, sue me for being stupid, but it's not a bad little box) Nothing real odd, using Mozy Pro for backup, Panda for A/V, not a whole lot else.

                        Thanks to all with suggestions, I will try anything!!! (within reason ;)

                        Comment


                        • #13
                          Re: Unable to create or edit pages.

                          I am having the same problem... did you find a solution?

                          Comment


                          • #14
                            Re: Unable to create or edit pages.

                            I had a similar problem and fixed it by:
                            Posting a bug report...
                            Selwyn emailed a suggestion re: unregistered A5 components and suggested running registervistawin7.bat (located in the A5V11 program files directory) as administrator...

                            I tried running registervistawin7.bat as administrator but it didn't seem to do anything... it failed, even though I did run by right-clicking on the file in the A5V11 directory and ran as administrator.

                            BUT when I did the following, all worked well:
                            Start->[Search Programs and Files]-> enter CMD-> right-Click on cmd -> run as administrator -> find the RegisterFilesVistaWin7.bat or RegisterFiles.bat (if you are using XP)... you should get a series of confirmation dialogs.

                            So... I misunderstood and ran the batch file as administrator... what I should have done is run the CMD program as administrator!

                            David Boomer
                            Rebus-Creative Software Solutions

                            Comment


                            • #15
                              Re: Unable to create or edit pages.

                              Fyi I still had problem after running RegisterFilesVistaWin7.bat as admin in the a5V11 folder so I also ran it in the a5V11 Runtime folder and that fixed it!

                              Comment

                              Working...
                              X