I created a grid, that worked great for years. I then tried to add a radius search to this search area for the grid.
After testing the grid it seemed that the grid search wouldn't combine a radius search with other search criteria (very odd), so I removed the proximity search, and re-published.

The error message i now get, when trying to open a detail view from the grid is
XHTTPRequest Error: 500 internal server error Script ErrorError:Scripta5GridHelper_execute_query_sql() line: 225
property not found trc.radiusSearchIsActive subelement not found.

The detail view will not open (modal)

I've been banging my head for hours over this. In order to get rid of this error message I've tried the following:
1) Added and removed the proximity search, again
2) Restarted WAS
3) Re-created the grid (with a different name, and without radius/map/proximity search--and still get the error)
4) Last version of WAS/Alpha
5) Restored to the original grid version (from 2013)
6) Cursed quite a lot at the computer!

The error occurs with anything that uses the same table as this grid... very odd.

How do I get rid of this error...?

Thanks in advance