Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Problem Printing PDF reports after new installation of V11

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • subroto
    replied
    Re: Problem Printing PDF reports after new installation of V11

    Originally posted by Selwyn Rabins View Post
    Steve

    Are you using the new feature in V11 to store your scripts in an external filesystem rather than a data dictionary? I suspect that you are and that's why you don't have .alb and .alm files - your reports are all stored in files in the filesystem.

    You will need to convert back from a filesystem library to a dictionary (see menu choice under the Code menu, or right click on white space in the Code tab of the control panel).
    You will then be able to publish your sql reports.
    Once you have published, you can go back to using a filesystem library.
    Hi Selywn, I am having the same problem as Steve Workings before

    SQL 6 Data Source Record for Layout not found.
    ReportDictionary : F:\A5Webroot\billingcopy\billingcopy.alb
    ReportName : billreport
    Type : REP
    Note : You mush republish the report dictionary files every time you edit your reports.

    I've tried the converting and it changed my previous all lowercase billingcopy.alb to uppercase BILLINGCOPY.alb and makes duplicates of the old alb,alx and alm. But still not luck republishing to the server...

    Can you give a hand thanks

    PS: I'm using DBF
    data resides in F:\Data
    Last edited by subroto; 05-03-2015, 06:29 PM.

    Leave a comment:


  • Progytech
    replied
    Re: Problem Printing PDF reports after new installation of V11

    Hi Camilo,

    Originally posted by xido View Post
    My DEV pc is windows 7 and my VPS is Windows server 2003 Xeon. Im not running either AlwaysUp or firewall on host. I guess I am going to ask for an upgrade on VPS server or change hosting services. Apparently the problems of printing are quickly resolved on newer versions of server OS. Thnaks
    Before changing your OS, I would suggest you get all Windows Update available, then do the following:
    1. Copy all your configuration settings for AWS
    2. Uninstall AWS
    3. Go to the Printer applet and make sure the AlphaFivePrinter has been removed.
    4. Also in the Printer applet, make sure no printer is selected and do the following: Click File and choose Print Server Properties, then in the Drivers tab, delete any Amyuni drivers you may have, then close the property sheet.
    5. Reboot your server
    6. Reinstall Alpha AWS and try printing your report and see if the problem has been fixed.
    Attached Files

    Leave a comment:


  • Progytech
    replied
    Re: Problem Printing PDF reports after new installation of V11

    Hi Camilo,

    Originally posted by xido View Post
    Selwyn:
    Do you think that by upgrading my VPS from windows 2003 to windows 2008 x64 and based on all comments/suggestions in regards to printing issues Alpha5 V11 web hosting will operate better ?
    If I may, in my experience, upgrading to the latest OS will always give you better results, right now Windows Server 2012 has been released for couple of months and if you have the opportunity to upgrade your server I would suggest you use Windows Server 2012 because it has a lot more improvements with memory footprint and specially the new IIS that even though you may not needed now but when Alpha release the support for IIS, you will be more ready. Of course if you cannot go with 2012, then 2008 64bits would be the next best choice.

    Leave a comment:


  • xido
    replied
    Re: Problem Printing PDF reports after new installation of V11

    Selwyn:

    Do you think that by upgrading my VPS from windows 2003 to windows 2008 x64 and based on all comments/suggestions in regards to printing issues Alpha5 V11 web hosting will operate better ?

    Leave a comment:


  • xido
    replied
    Re: Problem Printing PDF reports after new installation of V11

    Hi Progytech:

    My DEV pc is windows 7 and my VPS is Windows server 2003 Xeon. Im not running either AlwaysUp or firewall on host. I guess I am going to ask for an upgrade on VPS server or change hosting services. Apparently the problems of printing are quickly resolved on newer versions of server OS. Thnaks

    Leave a comment:


  • Lance Gurd
    replied
    Re: Problem Printing PDF reports after new installation of V11

    I had a similar problem a couple of days ago, I could print from development machine but all my reports would not print on the server. So I did what I always do in these circumstances, restart the server, problem solved. It was not a nice return to work after the Christmas break, but got it sorted.

    Leave a comment:


  • Progytech
    replied
    Re: Problem Printing PDF reports after new installation of V11

    Hi Camilo,

    You need to provide more information to clear out your configuration, ex:
    1. Are you using AlwaysUp?
    2. What is the OS of your Server, also is it x86 or x64?
    3. Are you running any type of Firewall that may be blocking some actions?

    Leave a comment:


  • xido
    replied
    Re: Problem Printing PDF reports after new installation of V11

    I did what you asked me...so far I was able to preview at the HOST by I was unable to save PDF::

    Layoutt name:Customer [email protected]:\documents and settings\admin\mydocuments\alphafive\alphasports\customer.dddLayouttype:reportError comunicating with printer

    In my Home PC (DEV) I am able to preview and to save in pdf.
    Last edited by xido; 01-04-2013, 02:18 AM.

    Leave a comment:


  • Progytech
    replied
    Re: Problem Printing PDF reports after new installation of V11

    Originally posted by xido View Post
    Message # 2--"Report did not print. Error reported was:*
    'Alpha Five Printer' (for creating PDF, RTF and HTML output) is not installed. Re-install Alpha Five Application Server"
    Hi Camilo, I had the same error yesterday and it was related to using the AlwaysUp application to load AWS as a service and AlwaysUp requires the use of the Administrator user credentials to work properly with the Amyuni drivers.
    Here is the link to my message and in the message from Luke who found and posted the solution:
    http://msgboard.alphasoftware.com/al...-Printer-error

    Leave a comment:


  • Selwyn Rabins
    replied
    Re: Problem Printing PDF reports after new installation of V11

    The error message you are getting is telling you exactly what the problem is - for whatever reason - and there could be many - the Amyuni printer driver is not installing on your computer.
    The amyuni printer driver is a 3rd party pdf printer that is bundled with alpha five.

    If you search the message board you will find a number of different threads in which users discuss this issue.

    I presume you can remote desktop into the machine where your app is hosted.
    You might start by connecting to your app server machine and see if you can install the full version of a5.
    then open alphasport, go to the control panel and preview a report. then try to save the report as PDF by clicking on the pdf icon on the toolbar. does that work?

    Leave a comment:


  • xido
    replied
    Re: Problem Printing PDF reports after new installation of V11

    Has anyone has found how to solve this issue? After many hours in production and testing your application on DEV Mode and not experiencing any problems during testing and at the end when you finally published your app just to find out the PRINTING IS NOT WORKING. It is frustrating and sicking to find out this issues. My client can not wait any longer.....printing features is the heart of this application. PLEASE HELP...

    I have tried all of the recommendations with no luck.....

    Running A5V11 3044_4041


    Message: # 1--- Report did not print. Error reported was:

    Layout name: [email protected]:/A5Webroot/d.acp2\supervisors.ddd
    Layout type: report

    Message # 2--"Report did not print. Error reported was:*
    'Alpha Five Printer' (for creating PDF, RTF and HTML output) is not installed. Re-install Alpha Five Application Server"

    Leave a comment:


  • Selwyn Rabins
    replied
    Re: Problem Printing PDF reports after new installation of V11

    currently you would have to switch back and forth - clearly not a great situation.

    i don't think many people are using external file system dictionaries yet, but clearly, this is something we need to make smoother.

    it is on our list of items that we need to address - don't, however, has a timetable on it yet.

    Leave a comment:


  • Steve Workings
    replied
    Re: Problem Printing PDF reports after new installation of V11

    Yup! That was it Selwyn. Good call, and thanks.

    Now I'm wondering, if I choose to store scripts in an external filesystem, if there's a way I can still publish reports? Would I have to switch back and forth to have both? Or can I stick with the external filesystem and also make the report available in some other manner? This is probably mostly academic because I'm OK without the external filesystem, but I sure do like the long function names I can have with that.

    Leave a comment:


  • Selwyn Rabins
    replied
    Re: Problem Printing PDF reports after new installation of V11

    Steve

    Are you using the new feature in V11 to store your scripts in an external filesystem rather than a data dictionary? I suspect that you are and that's why you don't have .alb and .alm files - your reports are all stored in files in the filesystem.

    You will need to convert back from a filesystem library to a dictionary (see menu choice under the Code menu, or right click on white space in the Code tab of the control panel).
    You will then be able to publish your sql reports.
    Once you have published, you can go back to using a filesystem library.

    Leave a comment:


  • frankbicknell
    replied
    Re: Problem Printing PDF reports after new installation of V11

    I have an ALB, ALM, and ALX file in the root of my project and webroot directories.

    Leave a comment:

Working...
X