Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Web Security not working - maybe something simple?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Web Security not working - maybe something simple?

    I am pretty new to Alpha 5 and am trying to set up security. I followed the steps: Security framework activated on the server, activated settings in the Web Security Configuration, created a login component and page, set up users and groups, set up page security and published security files.

    However, when I test the login screen I get an error displayed in red above the login box: "WebSecurity: Security is not active"

    It seems like I have done everything necessary - did I just miss a step somewhere? Any suggestions are appreciated.

    Thanks.

    Glenn Knott
    Attached Files

  • #2
    Re: Web Security not working - maybe something simple?

    You are testing your login in LivePreview, where security is not active. You need to publish to localhost or a server to test security.
    Steve Wood
    Join the ALPHA DEVELOPERS NETWORK
    There is no Cloud. It's just someone else's computer.
    Web - Mobile - Hosting - Products - Frameworks - Developer Resources
    AlphaToGo | IADN (100% Alpha Anywhere Websites)

    Comment


    • #3
      Re: Web Security not working - maybe something simple?

      And - when you do publish to your localhost or server, don't forget that you have to check the box "Publish Security Data Tables" the first time you publish. It's not checked automatically (because you only have to do it the first time) and it's easy to miss or forget.

      It will give you a different error message (will say "missing" instead of "not active") - but if you're new enough to be feeling your way through Preview etc - I figured it wouldn't hurt to mention it.

      And - on Tuesday, IADN is having a 1 hour class "Web Applications Basics - Getting Started" for a whopping $18 that might help you. It's by Steve Workings, same guy who did the Getting Started Videos. But, this one is live, so I imagine you can ask a few questions, time permitting of course. http://www.alphadevnet.com/webinars.a5w. I already have an app up and running, but I'm going to do it anyway, because it's $18 and because it's Steve W, who knows where all the land mines are a newbie can step on.
      Last edited by WendyWelton; 10-29-2011, 09:46 AM. Reason: facts were wrong!!!
      Wendy Welton
      Architect
      past & future Alphaholic - deliberately falling off the wagon!

      http://www.artformhomeplans.com/

      Comment


      • #4
        Re: Web Security not working - maybe something simple?

        And - on Monday, IADN is having a 1 hour class "Web Applications Basics - Getting Started" for a whopping $11 that might help you. It's by Steve Workings, same guy who did the Getting Started Videos. But, this one is live, so I imagine you can ask a few questions, time permitting of course. http://www.alphadevnet.com/webinars.a5w. I already have an app up and running, but I'm going to do it anyway, because it's $11 and because it's Steve W, who knows where all the land mines are a newbie can step on.
        Thanks Wendy - The class is on Tuesday Nov 1st. and we bumped the price to $18 to ensure we cover basic costs.
        Steve Wood
        Join the ALPHA DEVELOPERS NETWORK
        There is no Cloud. It's just someone else's computer.
        Web - Mobile - Hosting - Products - Frameworks - Developer Resources
        AlphaToGo | IADN (100% Alpha Anywhere Websites)

        Comment


        • #5
          Re: Web Security not working - maybe something simple?

          Oops - I guess I better adjust my calendar also! Thanks. I edited my post. So I'll eat one less McD's thingy to cover the difference. Hmmmm - learn stuff and lose weight too! ;-)
          Wendy Welton
          Architect
          past & future Alphaholic - deliberately falling off the wagon!

          http://www.artformhomeplans.com/

          Comment


          • #6
            Re: Web Security not working - maybe something simple?

            Thanks for all the help and suggestions. I have the security working now. Figuring out all of this can be a bit confusing at first. I've done a lot of application development in the past but nothing web related - so all that is new as well.

            Thanks again.

            Comment

            Working...
            X