Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Issues Since Dec 6 Update

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Issues Since Dec 6 Update

    Hi All,

    I would have put this in the my other Nov 9 thread but it seems to have disappeared or my eyes are tired.

    I still havent got to the bottom of the of why my app keeps conking out.

    What I do know is that I have 2 App Servers - 1 with the latestr patch and one with the one before.

    I am having nothing but trouble with the latest patched VMWare Server.

    The Error logs show the following -

    Dec 18 22:31:16 2011] [error] Fatal server error: [Member property does not exist] at line 932 in addins build 2291
    [Sun Dec 18 22:31:16 2011] [Fatal Server Error] Fatal server error: [Member property does not exist] at line 932 in addins build 2291


    I also get this in the log.

    Dec 18 23:32:26 2011] [Bad Request] (C:\A5Webroot\rspp\&__fn=re._a5_ajax) Request object couldn't read the body.<br/>Socket timeout reading data. No data was available to read within the timeout interval.
    [Sun Dec 18 23:32:57 2011] [Bad Request] (C:\A5Webroot\rspp\&__fn=re._a5_ajax) Request object couldn't read the body.<br/>Socket timeout reading data. No data was available to read within the timeout interval.
    [Sun Dec 18 23:33:12 2011] [Startup Failed] The server cannot be started. Port 443 is already in use.

    Data extraction is slow and frequently hangs. I also keep getting the xttp 500 error.

    I think I am going to miss my go live date tomorrow so any help would be greatfully received (this is public facing).

    Thanks

    Chris
    Attached Files
    Last edited by Turnbullca; 12-18-2011, 07:35 PM.

  • #2
    Re: Issues Since Nov 9 Update

    Originally posted by Turnbullca View Post
    The Error logs show the following -

    Dec 18 22:31:16 2011] [error] Fatal server error: [Member property does not exist] at line 932 in addins build 2291
    [Sun Dec 18 22:31:16 2011] [Fatal Server Error] Fatal server error: [Member property does not exist] at line 932 in addins build 2291
    Under what conditions does this happen? Is there an accompanying Xbasic error stack log entry/entries? If we can duplicate your error, we can debug it.


    Originally posted by Turnbullca View Post

    I also get this in the log.

    Dec 18 23:32:26 2011] [Bad Request] (C:\A5Webroot\rspp\&__fn=re._a5_ajax) Request object couldn't read the body.<br/>Socket timeout reading data. No data was available to read within the timeout interval.
    [Sun Dec 18 23:32:57 2011] [Bad Request] (C:\A5Webroot\rspp\&__fn=re._a5_ajax) Request object couldn't read the body.<br/>Socket timeout reading data. No data was available to read within the timeout interval.
    This is a read timeout which is typically caused by a known bug in IE that has existed in all versions at least as far back as IE6. (IE sends the headers of the request, but never sends the body that is supposed to be included, so the server waits until it times out.) Are you getting this using IE as the browser? If so, the work-around is to turn off Keep-Alive on the server.

    Originally posted by Turnbullca View Post
    [Sun Dec 18 23:33:12 2011] [Startup Failed] The server cannot be started. Port 443 is already in use.
    Something else must be using the port. Is there a another copy of Alpha running? Search here or in the wiki for detailed step-by-step instructions on how to identify exactly what else is using the port.


    Originally posted by Turnbullca View Post
    Data extraction is slow and frequently hangs. I also keep getting the xttp 500 error.
    What data extraction?

    What xhttp 500 error? IE will typically display this when there is the read timeout caused by its bug, but without more details (specifically, the exact error message), I can only guess at what the error may be.

    Lenny Forziati
    Vice President, Internet Products and Technical Services
    Alpha Software Corporation

    Comment


    • #3
      Re: Issues Since Nov 9 Update

      Lenny


      Thanks for the reply

      I cannot even access mysite at the moment as I keep getting a 500 error. This is the eror message.

      I am using Alphatogo Security through SQL 2008.

      The Error logs show the following -

      Dec 19 17:16:25 2011] [Fatal Server Error] Fatal server error: [Error loading C:\A5Webroot\rspp\websecurity_members.dbf: The filename, directory name, or volume label syntax is incorrect.: <NUL>.DDD] at line 123 in addins build 2291
      [Mon Dec 19 17:16:25 2011] [error] Fatal server error: [Error loading C:\A5Webroot\rspp\websecurity_members.dbf: The filename, directory name, or volume label syntax is incorrect.: <NUL>.DDD] at line 123 in addins build 2291
      [Mon Dec 19 17:16:25 2011] [Internal Server Error] (C:\A5Webroot\rspp\login.a5w) The server encountered a fatal error processing this request and could not continue.

      Comment


      • #4
        Re: Issues Since Nov 9 Update

        I do apologise at the title - it should be Dec 6th

        Comment


        • #5
          Re: Issues Since Nov 9 Update

          Chris, can you email me directly for the fastest communication? I'd like to get this addressed for you ASAP, but it's going to take some back and forth to troubleshoot and I think email will be more efficient.

          Lenny Forziati
          Vice President, Internet Products and Technical Services
          Alpha Software Corporation

          Comment


          • #6
            Re: Issues Since Dec 6 Update

            Lenny, if needed I have been working with Chris on this and can assist.
            Steve Wood
            Join the ALPHA DEVELOPERS NETWORK
            There is no Cloud. It's just someone else's computer.
            Web - Mobile - Hosting - Products - Frameworks - Developer Resources
            AlphaToGo | IADN (100% Alpha Anywhere Websites)

            Comment


            • #7
              Re: Issues Since Dec 6 Update

              My Issue has now been sorted and I owe Alpha an apology for causing a bit of a fraca.

              After a day and half of pulling my hair out I (and this is very embarrassing) I republished and my app is back to what it was without an error in sght. A very good lesson to learn!!!!

              A big thanks to Lenny for getting in touch and especially Steve Wood who has helped me so much to hit me deadline complete with 1800 users import with his security system.

              Thanks Guys

              Comment


              • #8
                Re: Issues Since Dec 6 Update

                Chris, did the "Socket timeout reading data" error ever return after you republished? I have the same issue on an SSL application and looking for repair strategy.
                Steve Wood
                Join the ALPHA DEVELOPERS NETWORK
                There is no Cloud. It's just someone else's computer.
                Web - Mobile - Hosting - Products - Frameworks - Developer Resources
                AlphaToGo | IADN (100% Alpha Anywhere Websites)

                Comment


                • #9
                  Re: Issues Since Dec 6 Update

                  Hi Steve,

                  I haven't seen that issue since and none of the parents have reported the error so all seems well.

                  Once I republished the whole going live was pretty uneventful, I just still have the recover password issue that I cannot solve.

                  The ATG User management is working beautifully.

                  Chris

                  Comment

                  Working...
                  X