Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Extract_String Issue on WAS

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Extract_String Issue on WAS

    I hope somebody can help me out. I am trying to insert some HTML in the OnGridPartRender event. The code is:
    Code:
    html1 = extract_string(e.html,"","<tbody id=\"GRID1.R1")  
    html2 = extract_string(e.html,"</tbody>","</div>")+"</div>"
    summary = <<%html%
    <tr>
    	<td class="GrBlueLink" colspan="7" align="right">Totals</td>
    	<td class="GrBlueLink" align="right">{e.rtc.amttotal}</td>
    	<td class="GrBlueLink" align="right">{e.rtc.truckcost}</td>
    	<td class="GrBlueLink" align="right">{e.rtc.trailercost}</td>
    	<td class="GrBlueLink" align="right">{e.rtc.driver_cost}</td>
    	<td class="GrBlueLink" align="right">{e.rtc.oo_cost}</td>
    	<td class="GrBlueLink" align="right">{e.rtc.profit}</td>
    </tr>
    %html%
    summary = evaluate_string(summary)
    e.html = html1+summary+html2
    I am extracting two pieces of html and then inserting my HTML in the middle. Everything works fine on my development machine but I get the following error on the WAS:

    Error executing OnGridPartRender event handler: command: html1 = extract_string(e.html,"","

    Obviously, it does not like the < character but I am not sure what to do. Any help would be appreciate.

    Thanks,

    Rod

  • #2
    Re: Extract_String Issue on WAS

    Try using this reference and convert the symbols to "entity name": http://www.w3schools.com/html/html_entities.asp
    Steve Wood
    Join the ALPHA DEVELOPERS NETWORK
    There is no Cloud. It's just someone else's computer.
    Web - Mobile - Hosting - Products - Frameworks - Developer Resources
    AlphaToGo | IADN (100% Alpha Anywhere Websites)

    Comment


    • #3
      Re: Extract_String Issue on WAS

      Steve,

      You are up way too late! That did the trick, the WAS now recognizes the string but I now get a message with "An unhandled exception (e06d7363) was generated." I will take it up with Selwyn unless you know what generates the error.

      Thanks!

      Rod

      Comment


      • #4
        Re: Extract_String Issue on WAS

        I too am getting this error message: "An unhandled exception (e06d7363) was generated."

        All I am doing is typing text into a cell in a table on a web page. I can get several lines of text in, and it saves OK. Then add a few more lines and on saving again, the error message appears. Did you resolve your issue?

        Kind regards,

        Larry

        Comment


        • #5
          Re: Extract_String Issue on WAS

          Larry,

          What I have been able to ascertain is that this is an inelegant way of letting you know that it could not find the start or stop string. It does not happen in every case but there are some in which it does. In my case, it was because GRID1 is a placeholder and gets changed on the WAS. Once I knew what was causing the error, I was able to fix the problem. I originally sent it in as a bug report but Jerry let me know that is was not. I have included a script that I included with the bug report that will cause the error at will in case you are interested.

          Rod

          1. Copy attached html.txt file to a location (Contains e.html variable from OnGridPartRender)
          2. Open attached script error e06d7363 file.
          3. Change file variable in script to saved location of html.txt file
          4. Run script html1 will work correctly.
          5. Comment out first html1 and run other variations. The other variations will produce the error see comments.


          error_e06d7363 - 01-05-2012 -1.txt
          html.txt

          Comment

          Working...
          X