Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

USPS function working?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Re: USPS function working?

    Originally posted by lemandras View Post
    Has anyone come up with a solution for v10?
    See Lenny Forziati's post. It is post #10.
    Last edited by Al Buchholz; 02-10-2012, 10:41 PM. Reason: link to Lenny's solution.
    Andrew

    Comment


    • #17
      Re: USPS function working?

      That does not seem to work for v10 until you get the pre-release files.

      Comment


      • #18
        Re: USPS function working?

        Works for me in v10.5 Build 4369.
        Andrew

        Comment


        • #19
          Re: USPS function working?

          I would love to see the code and how you got ito work. I have mine as an ajax callback

          Comment


          • #20
            Re: USPS function working?

            Originally posted by lemandras View Post
            I would love to see the code and how you got ito work. I have mine as an ajax callback
            I do not know anything about ajax callbacks and using a UDF. All I did was copy/paste Lenny's code and run it.
            Andrew

            Comment


            • #21
              Re: USPS function working?

              The USPS lookup from address function is only returning 5 digits when 9 digit is requested in Pre-release build 2418-3872

              I posted bug report

              Brad

              Comment


              • #22
                Re: USPS function working?

                The function in post 10 is only for getting city and state when giving the zip code. Instead of being called "USPS_Zipcode_Lookup2" this function should be called "usps_citystate_from_zip2()" When you put in the zip it comes out with the city and state. After looking at how this function is written I thing I can figure out how to do a "USPS_Zipcode_Lookup2"

                Comment


                • #23
                  Re: USPS function working?

                  OK, it looks like the web site that is being used does not have a option for getting the zip from the address. I will play with the USPS web site to see if I can get one to work latter. Have to get another job done first.

                  Comment


                  • #24
                    Re: USPS function working?

                    Almost have it working. Just having trouble getting the following 77041 to be extracted for part of the web page source

                    <span class="city range">HOUSTON </span> <span class="state range">TX</span> <span class="zip" style="">77041</span><span class="hyphen">&#45;</span><span class="zip4">1277</span><br />

                    Comment


                    • #25
                      Re: USPS function working?

                      Got it working. Here is code

                      function USPS_Zipcode_Lookup2 AS C (address AS C, city AS C, state AS C )
                      dim Response as c = ""
                      dim ResponseTimeout as n = 30000 '30 seconds
                      dim WebURI as c
                      WebURI= "https://tools.usps.com/go/ZipLookupResultsAction!input.action?resultMode=0&address1="
                      WebURI = WebURI+alltrim(address)+"&city="+alltrim(city)+"&state="+alltrim(state)

                      Response = http_post_page2(WebURI,"",.f.,ResponseTimeout)

                      dim vczip as c
                      dim vplus4 as c
                      vczip = extract_string(Response,"<span class=\"zip\" style=\"\">","</span>")
                      vplus4 = extract_string(Response,"<span class=\"zip4\">","</span>")

                      if vczip = ""
                      USPS_Zipcode_Lookup2= ""
                      else
                      if vplus4 = ""
                      USPS_Zipcode_Lookup2= vczip
                      else
                      USPS_Zipcode_Lookup2= vczip+"-"+vplus4
                      end if
                      end if
                      END FUNCTION
                      Last edited by turbojack; 02-15-2012, 07:39 PM.

                      Comment


                      • #26
                        Re: USPS function working?

                        I have v9 and I did not try the patch yet because I am afraid..
                        Does any one try this patch?

                        Comment


                        • #27
                          Re: USPS function working?

                          I think it has been at least 2 years since a patch for version 9 was released.
                          Gregg
                          https://paiza.io is a great site to test and share sql code

                          Comment


                          • #28
                            Re: USPS function working?

                            and it's even longer for version 8 users, oh...well nothing lasts for ever

                            Comment


                            • #29
                              Re: USPS function working?

                              Thanks turbojack for the code for the zipcode lookup. It does work!!!!!!

                              Comment


                              • #30
                                Re: USPS function working?

                                I tested it and it seems to be working now. Not sure if it was the last update, or USPS fixed their web page.

                                Comment

                                Working...
                                X