Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Image and/or File uploads never complete

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Image and/or File uploads never complete

    Here's another one from the "It used to work" category.

    On 2 of my sites the UPLOAD IMAGE - or UPLOAD DOCUMENT widget seems to have stopped functioning. I have the latest V11 and Server updates installed.

    The pop-up will appear (sometimes it displays an error505) and will allow me to find the file on the local machine. Press upload, and the wheel turns endlessly. The destination folders are still on the WAS and there have been no changes to security.

    If I cancel out, under the it's there but don't know it theory, there is no evidence of action.

    Any hints?



    I might just go back to FTP and forget these add-ins :(
    David Shaw
    Manager of Media Services and User Support
    Cleveland Museum of Art
    Cleveland, Ohio

  • #2
    Re: Image and/or File uploads never complete

    This sounds like there is a character in the filename the server is rejecting like ' , * e.g. pete will work but pete's won't, either will "won't" but "will not" will. I can't recall this being an issue earlier but it is now.
    Insanity: doing the same thing over and over again and expecting different results.
    Albert Einstein, (attributed)
    US (German-born) physicist (1879 - 1955)

    Comment


    • #3
      Re: Image and/or File uploads never complete

      Actually it was the one fix busted something else scenario.

      Most of my DB activity is within IFrames attached to named sites.
      Works as long as they are for READ only.
      In a WRITE mode, or upload pop-up, 3rd party cookies must be enabled. EXCEPT! IE automatically blocks 3rd party cookies. - Then it works in FireFox but not IE.
      SO - turn the "track cookies" off on the WAS - and it works fine - except the sites run like snails.

      The solution - unless you all have a better one:
      track cookies = ON
      Make all data entry pages direct to the WAS by having the named site re-direct to that secured A5W.

      The pages need some reformatting for header images and the like - but no everything works.
      David Shaw
      Manager of Media Services and User Support
      Cleveland Museum of Art
      Cleveland, Ohio

      Comment


      • #4
        Re: Image and/or File uploads never complete

        That's great.
        Insanity: doing the same thing over and over again and expecting different results.
        Albert Einstein, (attributed)
        US (German-born) physicist (1879 - 1955)

        Comment


        • #5
          Re: Image and/or File uploads never complete

          Turning off cookies in the server is almost never a good idea. As you noticed, it very significantly slows things down, and it is not 100% reliable.

          The option exists for certain customers which have a legal requirement to not use cookies as part of their applications, but for 99.9% of customers, you should always leave the cookies enabled.

          Lenny Forziati
          Vice President, Internet Products and Technical Services
          Alpha Software Corporation

          Comment


          • #6
            Re: Image and/or File uploads never complete

            It looks like the image upload feature is now broken for me as well in build 2639_3914.
            I have not done anything with this particular feature in over a year and it's just stopped working.

            Rather than the endless wheel turning however, I'm getting a blank image where the placeholder {uploadedImage} used to/should be.
            Select_Image.png

            If I click Okay, it still uploads the selected image to the destination folder, but as a s a zero byte file!

            Is this a bug then?

            Stephen
            Alpha Anywhere v12.4.6.4.0 Build 8000-5628 IIS v10.0 on Windows Server 2019 Std in Hyper-V

            Comment


            • #7
              Re: Image and/or File uploads never complete

              Yep.
              Insanity: doing the same thing over and over again and expecting different results.
              Albert Einstein, (attributed)
              US (German-born) physicist (1879 - 1955)

              Comment


              • #8
                Re: Image and/or File uploads never complete

                I reverted back to build 2528_3899 and it is working fine.
                Alpha Anywhere v12.4.6.4.0 Build 8000-5628 IIS v10.0 on Windows Server 2019 Std in Hyper-V

                Comment


                • #9
                  Re: Image and/or File uploads never complete

                  We have tested file upload and image upload from a number of different components in the latest pre-release build without any errors.

                  If you have a problem in the latest pre-release build, send a bug report with an example that shows the problem. We would need the component, any data files needed to run the component, and the file "ProjectProperties.projectProperties" from the project folder. It would be helpful to know what browser was being used for testing.

                  Comment


                  • #10
                    Re: Image and/or File uploads never complete

                    Hi Jerry,

                    In my case I had tried both IE8 and Firefox 11.0. Because it's working again now, I'm hesitant to go back.
                    Since it is working for you, it is most likely something I did somewhere, though I didn't do any work on the component in question.
                    When we get to the next release build, I'll try again and if it fails I will submit the data you need.

                    Stephen
                    Alpha Anywhere v12.4.6.4.0 Build 8000-5628 IIS v10.0 on Windows Server 2019 Std in Hyper-V

                    Comment


                    • #11
                      Re: Image and/or File uploads never complete

                      Hi Jerry,
                      i use rel 2656-3917 and i have ths same problem (0 bytes file) to image upload with ie 9 and firefox 11 (windows 7) ...
                      with chrome has problem ...
                      i I have sent a reference to Selwyn ..

                      Thanks
                      George

                      Comment


                      • #12
                        Re: Image and/or File uploads never complete

                        There is any new for it ????
                        The problem is solved to you ????

                        Thanks
                        George

                        Comment


                        • #13
                          Re: Image and/or File uploads never complete

                          For me, since 265x-3916 some dialogs stop working with error in __a5RunGrid.a5w

                          Comment

                          Working...
                          X