Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Weird search problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Weird search problem

    Hey all, I've got a grid with a seach that isn't finding my record

    For brevity's sake, here's the partial record.

    || *id* || *business_name* || *business_address_line_1* || *business_address_line_2* || *business_address_zip_code*
    || 3380 || Bayer Properties (Cresent Building) || Highland Ave. South || || 35205 ||


    I have tried searching for this record in my search part by id, business name, address, everything, and for some reason it never shows up. I'm at a loss. Does anyone have any ideas on how I would go about troubleshooting this?

    searching for 3381 works fine.

  • #2
    Re: Weird search problem

    SQL? DBF? Is the record in your grid to start?
    Alpha Anywhere latest pre-release

    Comment


    • #3
      Re: Weird search problem

      MySQL backend, the record is clearly in the database. (The partial record above was actually an export from HeidiSQL). Grid is hidden to start. Every other search seems to go through just fine, but for some reason that one isn't being displayed.

      Comment


      • #4
        Re: Weird search problem

        The record is in the database, but is it in your query results for the grid?

        I had some issues with MySQL queries where I was filtering on fields for x is not equal to "some value" and it would return everything except those records that were "some value" or NULL. Had to change my logic a bit to include or x is null.
        Alpha Anywhere latest pre-release

        Comment


        • #5
          Re: Weird search problem

          Or maybe set the fields to allow empty strings and not allow nulls.

          Comment


          • #6
            Re: Weird search problem

            Originally posted by agillbb View Post
            Or maybe set the fields to allow empty strings and not allow nulls.
            Also a valid solution. The exciting things you find when you port from one database type to another.
            Alpha Anywhere latest pre-release

            Comment


            • #7
              Re: Weird search problem

              This is not the issue. I search for 3379 it works, I search for 3380 it does not work. It is something in the actual record that is preventing it from being displayed. I changed the key to 3381 and the record still does not show up. I wanted to see if there was a way I could look at the debug for a search. It seems like somehow it's escaping out somewhere and I can't find it. I'm not at my dev box right now, but when I get to it, I'll see if I can post a full sql insert of the row.

              Comment


              • #8
                Re: Weird search problem

                try writing the query from inside the db environment and see what happens.

                Comment


                • #9
                  Re: Weird search problem

                  Originally posted by agillbb View Post
                  try writing the query from inside the db environment and see what happens.
                  One trick I've used is to set the filter such that it should return the problem record. You could add "ID is equal to 3380" in your SQL Query builder's filter. Then test the query. If you get zero results, then there's something going wrong with your original query. (Assuming that you're not just pulling all records from a single table.)
                  Alpha Anywhere latest pre-release

                  Comment


                  • #10
                    Re: Weird search problem

                    The problem has to be that the query is excluding the record with either a 'where' or 'having' clause, or maybe select distinct.
                    Win 10 64 Development, Win 7 64 WAS 11-1, 2, Win 10 64 AA-1,2, MySql, dbForge Studio The Best MySQL GUI Tool IMHO. http://www.devart.com/dbforge/mysql/studio/

                    Comment


                    • #11
                      Re: Weird search problem

                      OK, I put the sql in the db and the row didn't come up. Its the sql, I was using a 'Where table1.primarykey = table2.foreignkey' instead of a join and it looks like this row didn't have a corresponding row in table 2, thus preventing the row from being displayed. The reason I wasn't using a join in the first places was because of performance.

                      Code:
                      SELECT gen_customers.*, gen_customer_contacts.*, 'a' AS Fran_name, 'b' AS last_pp, 'c' AS last_inspection, 'd' AS last_invoice, 'e' AS citystate, 'f' AS citystate2 
                      FROM gen_customers gen_customers
                      	 LEFT OUTER JOIN gen_customer_contacts gen_customer_contacts
                      		 ON  gen_customers.id = gen_customer_contacts.customer_fk
                      This works now, but look at the performance of the statement "/* 0 rows affected, 7,508 rows found. Duration for 1 query: 0.203 sec. (+ 49.640 sec. network) */" and that is on localhost. Something is screwy...

                      Comment


                      • #12
                        Re: Weird search problem

                        0.2 sec is o.k., but what are you saying about the 50 sec? Is that horrific 50 sec lag across your network?

                        Comment


                        • #13
                          Re: Weird search problem

                          It's local. The database is on my computer.
                          ScreenShot023.png

                          Comment


                          • #14
                            Re: Weird search problem

                            How is that possible.
                            Try using the A5 Database Explorer to view the data returned from the DB - and see if the lag is reduced.
                            Check the data returned to make sure it looks right.
                            You could try getting rid of the .* in your query - only choose the rows you need.

                            Comment


                            • #15
                              Re: Weird search problem

                              A5 is the same way.

                              I did fix the problem. I don't know why this would have mattered but it fixed it. My key on gen_customer_contacts was a compound primary key consisting of auto increment id, and customer_fk. I just dropped it to be a normal primary key with an index on customer_fk and now it's speeding along at .15 seconds.

                              Thanks for the help :)

                              Comment

                              Working...
                              X