Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

***FRUSTRATED***** Application Server Stops working Daily

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #46
    Re: ***FRUSTRATED***** Application Server Stops working Daily

    Thanks Gregg but I guess what I'm missing is how I would fix/change that here:
    Client Side formating.png
    Never take a ride to the edge of your mind unless you've got a ticket back - Jon Oliva - Savatage.

    Comment


    • #47
      Re: ***FRUSTRATED***** Application Server Stops working Daily

      Hi Joe,

      Which grid is giving that error ?
      Is it the same grid as you posted in the zip file the other day, or was that grid "cleansed" for public viewing ?

      Comment


      • #48
        Re: ***FRUSTRATED***** Application Server Stops working Daily

        Limits6 is the Grid. No data is included. The grid may or may not have changed since I posted it. I've removed the Display Format under Display settings, added it back, removed client side...just testing difference scenarios to see if it fixes the issue. So...I don't remember which version I posted. Thank you for looking at it...

        Joe
        Never take a ride to the edge of your mind unless you've got a ticket back - Jon Oliva - Savatage.

        Comment


        • #49
          Re: ***FRUSTRATED***** Application Server Stops working Daily

          Joe,

          I'm working with the files you posted on 7/27 at 12:23pm.

          I'm trying to solve the "Fatal error running a5_ajax_grid(): convert_number(rtc.vtbl.data("ELDER_LAW")): Argument is incorrect data type on line 15 in 1001026:pl" error.
          I did not find "ELDER_LAW" in the Limits6 grid, but did find it in the limit_profile grid.
          The attached image shows the display format is correct.

          As you have made changes, are the errors the same ?
          If not, please post the new error message(s).

          Comment


          • #50
            Re: ***FRUSTRATED***** Application Server Stops working Daily

            I'm sorry...I get it on CYB_Limit too. That was the grid I had in mind. Elder_Law is on the Limit Profile Grid.

            Yes, the error is the same through out the changes. I've just migrated my WAS server to a different node in my cluster.

            Joe
            Never take a ride to the edge of your mind unless you've got a ticket back - Jon Oliva - Savatage.

            Comment


            • #51
              Re: ***FRUSTRATED***** Application Server Stops working Daily

              ok...lets tackle one at a time.

              Can you post the most current version of the limit_profile.a5wcmp file ?

              Comment


              • #52
                Re: ***FRUSTRATED***** Application Server Stops working Daily

                Default-20120730113300185.zip

                Please see attached...
                Never take a ride to the edge of your mind unless you've got a ticket back - Jon Oliva - Savatage.

                Comment


                • #53
                  Re: ***FRUSTRATED***** Application Server Stops working Daily

                  What is the error you are getting involving ELDER_LAW ?

                  What do you want the column to look like ?

                  Comment


                  • #54
                    Re: ***FRUSTRATED***** Application Server Stops working Daily

                    The error I get is:

                    Fatal error running a5_ajax_grid(): convert_number(rtc.vtbl.data("ELDER_LAW")): Argument is incorrect data type on line 15 in 1001026:pl

                    It is a percentage so 1%, 10%, etc.

                    The odd part is sometimes it works sometimes it doesn't. I don't think it is an error in the grid itself. As restarting the Application Server makes the problem go away for a few hours.

                    I was just asked to install the Alpha Application server on my local machine instead of my W2K3 server.
                    Never take a ride to the edge of your mind unless you've got a ticket back - Jon Oliva - Savatage.

                    Comment


                    • #55
                      Re: ***FRUSTRATED***** Application Server Stops working Daily

                      Just wanted to update this. As requested I put together a Win7 box to run the WAS on. In our case we are still getting all sorts of random errors:

                      Field config is:
                      - Display Format is alltrim(str( convert_type(<value>,"N") ,250,0,"$("))
                      - Client Side Properties – Number, Format Definition is USD and Thousand Separator.

                      After removing the above formatting I get this error:

                      Error expanding Grid Part template: Result stack underflow

                      PS...if I run the grid in Working Preview it loads. If I open the Grid in a Browser from the Developer it loads. From WAS...no go.
                      Never take a ride to the edge of your mind unless you've got a ticket back - Jon Oliva - Savatage.

                      Comment


                      • #56
                        Re: ***FRUSTRATED***** Application Server Stops working Daily

                        - Display Format is alltrim(str( convert_type(<value>,"N") ,250,0,"$("))

                        In the above line, you use ( 4 times, and ) 3 times.
                        I don't know how it worked at all, or if it's just a typo.
                        It looks like the ( between the $ and the " is the extra one.

                        Comment


                        • #57
                          Re: ***FRUSTRATED***** Application Server Stops working Daily

                          I will try removing the ( but what I'm wondering is why do I get a Stack under flow when I clear out all of the formatting leaving the field completely UN-formatted.

                          If this does work then the extra ( is a bug as it came from choosing a pre-defined format option.
                          Never take a ride to the edge of your mind unless you've got a ticket back - Jon Oliva - Savatage.

                          Comment


                          • #58
                            Re: ***FRUSTRATED***** Application Server Stops working Daily

                            Just an FYI - I have started using linked reports and have discovered that they are causing a MAJOR memory leakage that does not clear itself out. When there is a parent report with a linked report for each detail line, the server memory usage climbs and climbs, AND even after the report has been prepared, and I log off (only user on), the server memory does not go back down. I watched the memory usage go from 153MB to 1,113 MB while preparing one report. And it remained at 1,113 MB even after closing report and logging off. This, of course, caused us to get 'server resources exceeded' message and we had to restart the server. I have reported this to Alpha. This is on build 2835-3985 (pre-release).
                            Carol King
                            Developer of Custom Homebuilders' Solutions (CHS)
                            http://www.CHSBuilderSoftware.com

                            Comment


                            • #59
                              Re: ***FRUSTRATED***** Application Server Stops working Daily

                              Carol please let us know what they said. I've been having memory leak problems for a while now but never thought about linked reports. My App server uses way over 1,113 MB and then just stops. the memory never goes back down.
                              Reed Brown
                              ITOT Solutions, Inc.
                              Alpha v12

                              Comment


                              • #60
                                Re: ***FRUSTRATED***** Application Server Stops working Daily

                                Reed, They said they found the issue and that it will be resolved in the next pre-release. I checked for the pre-release this morning, but a new one is not there yet. I'll give it a try when they release it.
                                Carol King
                                Developer of Custom Homebuilders' Solutions (CHS)
                                http://www.CHSBuilderSoftware.com

                                Comment

                                Working...
                                X