Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Linked Grids Error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Linked Grids Error

    I am attempting to add linked grids to a grid component but am not having any luck. I have included a screen shot. I tried placing it in the Row Expander and in the Below Grid freeform region, but keep receiving the same error message. What am I doing wrong?

    A5 - Grid Link Error 1.png

    Also, both grid components work perfectly fine on their own. I have no issues other than when I try to link them together.

  • #2
    Re: Linked Grids Error

    Nobody knows? I have deleting and remaking the grids and continue to get the same error. I have tried on different computers, and get this same error. PLEASE someone HELP!! I really need this to work.

    Thanks, HOlly

    Comment


    • #3
      Re: Linked Grids Error

      Holly - Can you make sure you turn off the "Has linked content" checkbox and see if you get the same result with the grid in the row expander?

      Comment


      • #4
        Re: Linked Grids Error

        Hey Dave,

        I swear I had done that yesterday, but I did it again and it worked. I would really rather have it just on the page and not as a row expander. I need to build a couple others and having it directly on the page rather than in the row is going to be necessary. But I am still having the same issue when I have it directly on the page under the "Has Linked Content". Do you know why this is doing this? Any other suggestions?

        Comment


        • #5
          Re: Linked Grids Error

          Holly,

          I don't know if this will make you feel better or not, but I'm getting the same exact error when I define a linked grid. I wanted to make sure you were not also getting this error with the row expander grid as well because it works for me. There may be a bug with Linked Grids. If so, I'm surprised no one else has reported it on the message board yet. Have you used a linked grid before? I haven't.

          Now that I know the row expander works for you too, I will see if I can get the linked grid to work for me or find out where the error is coming from.

          Comment


          • #6
            Re: Linked Grids Error

            Dave,

            First off - you rock! Mostly just for always replying and assisting me with this. I was starting to think this might be a bug issue, as I just have no clue as to what would be causing this. But I am glad it is just not me. I even uninstalled Alpha and re-installed to see if that would work and it did not. I tried all sorts of things. I can place it in the actual grid itself and I can place it in the row expander, but not on the page as a linked grid. It seems like a highly used feature so one would think others having this issue would be saying something as well.

            Is there a way to ask Alpha directly?? Do you know?

            Thanks again for all your help!! Holly

            Comment


            • #7
              Re: Linked Grids Error

              I just them a message on their "Contact Us" form. I don't know how else to contact them about this. So, we shall see.

              Comment


              • #8
                Re: Linked Grids Error

                Inside of the Alpha Five Development application, go to the Help menu and select "Send a Bug Report".

                What did you name your linked content section? Are there any spaces? I had a space in mine, so I removed it and now it's launching the child grid but I'm getting a different error now.

                Comment


                • #9
                  Re: Linked Grids Error

                  Dave - it is working now. I can't understand it. I didn't do anything differently. I just tried it again, and now it is fully functional. I did not have any spaces in my linked content section. I don't know but I am happy to say that it is working for me. Again thank you for all your help and suggestions. Who knows what was wrong.

                  Comment


                  • #10
                    Re: Linked Grids Error

                    That's great! I just got mine to work too. I tried so many things that I'm not sure I can pinpoint exactly what the problem was, but I know it had to do with the name of my child grid and/or the name of the linked content section. Did you change either of these? My linked content section initially had a space and was over 10 characters long. The maximum section name length is 10 characters. A5 does not warn you when you exceed 10 characters or enter spaces. They are normally very good about validating input and warning you when you enter something invalid.

                    Comment


                    • #11
                      Re: Linked Grids Error

                      I honestly did not do a thing! It literally just started working. Really weird. But I am glad to know about the charcters, I did not know there was a max number on that. But now I can keep that in mind from here on out. Strange! Well, thanks for working this puzzle out with me, and I am thrilled yours is working correctly now too. I'm sure we will chat again soon :D Have a great day!

                      Comment


                      • #12
                        Re: Linked Grids Error

                        I sent a bug report to Alpha this morning about adding validation logic to the Linked Content Name in the Linked Content Builder. I received an email from Selwyn Rabins this afternoon that it has been completed. How is that for service?

                        Comment


                        • #13
                          Re: Linked Grids Error

                          I just received the same type of error when running working preview on a component with a linked-grid. The row expander worked just fine, but the linked grid gives me an error every time.1-24-2013 3-06-24 PM.jpg
                          Attached Files

                          Comment


                          • #14
                            Re: Linked Grids Error

                            I just figured out what seems to be my error. Alpha will let you save a grid component as a name with spaces under some circumstances. If I use the linked grid with that name, such as "Invoice Header Linked Grid" the error occurs. If I "save as" the same grid to another name, such as "invoiceHLGrid" everything works fine. I figured this out by noticing that Steve Workings in his videos always saves his components with underlines instead of spaces between the words of the name.

                            I noticed also that sometimes Alpha5 changes the spaces to underlines; other times it does not depending on the context.

                            This is probably all newbie error stuff; This is probably the third time in the last 4 years I've been a newbie.

                            Comment


                            • #15
                              Re: Linked Grids Error

                              That would do it. See my post above about using a name with spaces or more than 10 characters. This should have been fixed already and included in the current release candidate.

                              Comment

                              Working...
                              X