Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Multiple Applications Problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Multiple Applications Problem

    Just for test purposes I am self hosting my web site. I am using Alpha Five Standard Edition version 9 and Alpha Five Application Server Enterprise v9, unlimited sessions. This is a genealogy research site with several web applications. Just for testing i started with three small databases and made web applications for each database. A home page was made with a link for each application. All went well as far as developing and displaying the applications. I published the first application and it displayed. I published the second application and it displayed. I published the third application and it displayed. The problem is, only the last application i publish can be displayed. When I go back and try to display the first two applications. I get an error. If I go back and publish one of the first two applications then that works but the other applications do not work. Below is an error for two of the applications. The third site I published has a path of D:\Data\Alpha Five\~GBM Web Applications\BiographyBooks\BiographyBooks.dbf. If you look at at the path of the other two apps they are lookin in the "BiographyBooks" folder for the dbf file.

    Error 3 - Error loading [PathAlias.ADB_Path]\Stockdal.dbf: The system cannot find the file specified. D:\Data\Alpha Five\~GBM Web Applications\BiographyBooks\Stockdal.dbf

    This path should be Stockdale instead of BiographyBooks

    Error 3 - Error loading [PathAlias.ADB_Path]\cemeterybooks.dbf: The system cannot find the file specified. D:\Data\Alpha Five\~GBM Web Applications\BiographyBooks\cemeterybooks.dbf

    This path should be CemeteryBooks instead of BiographyBooks

    All applications paths get changed to the last application I publish.

    How do I correct this?

  • #2
    Re: Multiple Applications Problem

    Adjust the Alias in each project's publishing Profile. They are all pointing to BiographyBooks. You probably started with that project and made copies to start the other two.
    Steve Wood
    Join the ALPHA DEVELOPERS NETWORK
    There is no Cloud. It's just someone else's computer.
    Web - Mobile - Hosting - Products - Frameworks - Developer Resources
    AlphaToGo | IADN (100% Alpha Anywhere Websites)

    Comment


    • #3
      Re: Multiple Applications Problem

      How do I do this? I don't see where to do that.

      Comment


      • #4
        Re: Multiple Applications Problem

        I did not copy the application from the first one. I did each application from scratch. I found the Alias variable and it is
        [PathAlias.ADB_Path] = =a5.get_path()
        Shouldn't this set the path by the location of the database?

        Comment


        • #5
          Re: Multiple Applications Problem

          If you don't know where Profiles are, and did not adjust them, then you are likely using the default setting, which is called Local Webroot, and publishing the applications to the same computer that the projects are on.

          Profiles is in the upper left of the web projects control panel. Probably, if you are publishing to Local Webroot, all you need to do is ensure each project has a unique Target Folder and the Alias looks like in my attached example.

          If you have additional profiles, then someone has been here and set things up differently and my advice above is not going to be accurate.
          Steve Wood
          Join the ALPHA DEVELOPERS NETWORK
          There is no Cloud. It's just someone else's computer.
          Web - Mobile - Hosting - Products - Frameworks - Developer Resources
          AlphaToGo | IADN (100% Alpha Anywhere Websites)

          Comment


          • #6
            Re: Multiple Applications Problem

            Originally posted by EWyatt View Post
            I did not copy the application from the first one. I did each application from scratch. I found the Alias variable and it is
            [PathAlias.ADB_Path] = =a5.get_path()
            Shouldn't this set the path by the location of the database?
            Then set the Target Folder for each, republish, and you are set.
            Steve Wood
            Join the ALPHA DEVELOPERS NETWORK
            There is no Cloud. It's just someone else's computer.
            Web - Mobile - Hosting - Products - Frameworks - Developer Resources
            AlphaToGo | IADN (100% Alpha Anywhere Websites)

            Comment

            Working...
            X