Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Multilingual fonts embeding not working in web app

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Multilingual fonts embeding not working in web app

    Hi all there,
    i am using print code embending (peteconv solution in this forum) in a dialog's after validate events, in order to print a greek font web report in pdf. I am still getting garbage fonts. The strange issue is that i have built 4 more reports with the same method that print fine in web. Up to now no difference between the reports designs i have found. I list here the report code for someone to help
    (This forum is excellent. I have found many solutions although i am a newbie in developing A5 apps.)
    Thanks to all people here...

    AFTER VALIDATE CODE IN WEB DIALOG COMPONENT
    delete PrintOptions
    DIM PrintOptions as P
    With PrintOptions
    .Concatenate = .f.
    .HasWatermark = .t.
    .MultilingualSupport = .t.
    .EmbedFonts = .t.
    .LinearizeForWeb = .f.
    .Colors2GrayScale = .f.
    .ConvertHyperlinks = .f.
    .WatermarkType = "Text"
    .WatermarkText = "Ε Α Π Α.Ε."
    .WatermarkFontName = "Times New Roman"
    .WatermarkFontSize = 200
    .WatermarkRotation = 400
    .WatermarkColorHex = "E8FED2"
    .WatermarkHorizPos = 300
    .WatermarkVertPos = +40
    .WatermarkOnTop = .f.
    .WatermarkPDF = ""
    .Encrypt = .f.
    .OwnerPassword = ""
    .UserPassword = ""
    .CanPrint = .t.
    .CanModifyDocument = .t.
    .CanCopy = .t.
    .CanAddNotes = .t.
    .Use128BitKey = .f.
    .JpegQuality = "Low"

    End with


    IF eval_valid("hmrdv") = .f. Then
    goto skipreport
    end if
    dim filter as c
    dim order as c
    Filter = "(Tb_Rdv->Hm_rdv = ctod(\""+convert_type(hmrdv,"C")+"\") ) .and. (Tb_Rdv->Rdv = .t. ) .and. isnotblank(\"Tb_Rdv->Tilephonitria\")"
    Order = "Tb_Rdv->Politis"
    Dim filename as c
    filename = session.session_folder + "tempreport.pdf"
    filename = report.saveas("[email protected][PathAlias.ADB_Path]\ktirio_rdv.set","pdf",filter,order,filename,.f.)
    if file.exists(filename)
    currentform.RedirectTarget = session.session_url + "tempreport.pdf?" + time("hms3")
    end if
    skipreport:
    Larrybrk
    EAP

  • #2
    Re: Multilingual fonts embeding not working in web app

    You have to make sure that the fonts you are using are installed on the web server.

    Comment


    • #3
      Re: Multilingual fonts embeding not working in web app

      Originally posted by NoeticCC View Post
      You have to make sure that the fonts you are using are installed on the web server.
      in fact they are... I have reports running with the same layout correctly within the same server.
      Last edited by larrybrk; 03-18-2009, 11:59 AM.
      Larrybrk
      EAP

      Comment


      • #4
        Re: Multilingual fonts embeding not working in web app

        Originally posted by larrybrk View Post
        in fact they are... I have reports running with the same layout correctly within the same server.
        Hm... so is it just the watermark text that is different?

        You may have to add something like Response.charset = "UTF-8" or similar to make sure the page itself interprets the characters correctly.

        Comment


        • #5
          Re: Multilingual fonts embeding not working in web app

          NoeticCC thanks for the reply,

          you mean i have to add .Response.charset = "UTF-8" in code above in dialog?

          furthermore...i have tried to print the same report in "html" and "txt" format and greek characters are printed correctly. The problem is that page elements are not displayed in correctly using anything else than pdf format so i have to stay in pdf ...

          Any further help would be much appreciated...
          Larrybrk
          EAP

          Comment


          • #6
            Re: Multilingual fonts embeding not working in web app

            Originally posted by larrybrk View Post
            you mean i have to add .Response.charset = "UTF-8" in code above in dialog?
            Only if the watermark is the only thing that is different between this report and the others you mentioned as working OK on the same server.

            furthermore...i have tried to print the same report in "html" and "txt" format and greek characters are printed correctly. The problem is that page elements are not displayed in correctly using anything else than pdf format so i have to stay in pdf ...

            Any further help would be much appreciated...
            The difference is that in these 2 formats (html and txt), the fonts do not need to be on the server but must be on end user's PC o display correctly, whereas if you embed a font in a PDF file the fonts only have to be on the server.

            Comment


            • #7
              Re: Multilingual fonts embeding not working in web app

              Originally posted by NoeticCC View Post
              Only if the watermark is the only thing that is different between this report and the others you mentioned as working OK on the same server.
              NoeticCC,
              indeed everything i can look for is identical in reports design format. Even watermarks are the same. The thing is that watermark is not printed in the faulty report pdf also. Fonts embedding is not working for some reason in this report. Right clicking the properties of both pdfs (normal report - faulty report) see that different font groups are used in reports printing finally although i have exact the same fonts used to design both reports. So i believe that embedding is not working for the faulty report for some reason...
              I wonder how can anyone debug or trace this process.
              Larrybrk
              EAP

              Comment


              • #8
                Re: Multilingual fonts embeding not working in web app

                The difference is that in these 2 formats (html and txt), the fonts do not need to be on the server but must be on end user's PC o display correctly, whereas if you embed a font in a PDF file the fonts only have to be on the server.
                i understand and agree with you. But i have exactly the same font used when designed the reports. So fonts i' ve used should not be the reason. Is there any property in report design time (desktop report builder) i have to consider (except font types) related with fonts embedding in web reports?
                Larrybrk
                EAP

                Comment


                • #9
                  Re: Multilingual fonts embeding not working in web app

                  hello,
                  I had various problems with Greek character support in Alpha Five so I tried several times to contact the support service, the programmers from forums memeber list and any other email I could find.

                  The answer I receive was:
                  "Hello George. Right now Alpha only supports English language sets. Thank you for your patience."

                  so you can assume that there is no support for international character sets, Alpha Five works only with English.
                  "Give every man more in use value
                  than you take from him in cash value;
                  then you are adding to the life of the
                  world
                  by every business transaction"
                  Wallace D. Wattles

                  Comment


                  • #10
                    Re: Multilingual fonts embeding not working in web app

                    George,

                    i got it finally work fine. On the contrary greek charset are ok with Alpha Five. Sorry i didn't post a solution. Maybe you can tell me what your problem is so i can have a look at..
                    I have an up and running web app with greek fonts for about a year now.

                    Thanks for the post
                    Larrybrk
                    EAP

                    Comment


                    • #11
                      Re: Multilingual fonts embeding not working in web app

                      Hi Larry,
                      it's great news that you managed to solve your problem.

                      My problem is about the creation of desktop databases rather than web ones (for now).

                      You can read all the story about my problem in the thread:
                      http://msgboard.alphasoftware.com/al...ad.php?t=81826

                      As you can see, I can't enter Greek characters in the field rules dialog of Alpha five, although they seem to work fine in the forms and browses.

                      I bought version 9 and have download v.8 and v.10 beta. At the v.8 I can enter Greek characters in the field rules. But in the 9 and 10 they dont appear correct.

                      I thing that Alpha Five can correct the problem by altering the Font's script from Englisth to the System Default script, but their answer was that they support no other language than English.

                      Having receive the above response, although I realy liked what I saw in Alpha Five, makes me feel insecure about the development of software for the Greek market in Alpha Five.

                      My main concern is what will happen if, after developing some software in Alpha Five and have invest many hours of development time, a new problem with Greek characters appear, this time on the data storage or presentations that I will not be able to solve it.

                      If from Alpha Five have told me that they support international characters, or that they will look and try to solve the problem with the international characters I would take the chances and start the development of an in-house software in Alpha Five.

                      But when they said to me that they only support English characters, I heared them saying behind their words: "If you start developing an application in Alpha Five for the Greek market, YOU AR ON YOUR OWN."

                      It's pitty beacause I really enjoy the approach Alpha Five takes on database development. But as I can see things now, the only thing I can do is to ask a refund of our purchase.

                      Larry, thank you for your response. I would really like to hear your oppinion about my problem.

                      Best Regards,
                      George Stathis
                      http://www.access-databses.gr
                      "Give every man more in use value
                      than you take from him in cash value;
                      then you are adding to the life of the
                      world
                      by every business transaction"
                      Wallace D. Wattles

                      Comment

                      Working...
                      X