Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

"Object Required" Error in Grid Detail - troubleshooting

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • "Object Required" Error in Grid Detail - troubleshooting

    I've got a pretty basic grid component configured, with detail showing in-grid, set into an a5w page with a few other things.

    Publish all to WAS. The grid displays all N rows perfectly. Clicking on row 1 through row (N-1) works beautifully, popping the detail open directly underneath the selected row.

    HOWEVER, upon clicking the final row, row N, the detail opens ABOVE the selected row N and I see an "Error on page." in IE's status bar.

    When running the individual component in A5 Live Preview I get a popup "An error has occurred in the script on this page.", Line 3681, Char 4, Error Object Required.

    Any clues on how to troubleshoot this? Having looked at the xbasic generated for the component, I see there are nowhere near 3000 lines. I was hoping to view the offending line, thinking it might shed some light.

    Even after changing the display order of the rows (so what was previously displayed as row N now appears earlier, say at N-5, the behavior remains as before... Rows 1 through N-1: OK; Row N: Error. So it certainly appears data-independent.

    The a5w_error.log file doesn't seem to provide any clues, either. I do see a "[Not Found] The requested URL /xx.EditRecord.Icon was not found on this server." But what does it mean? It doesn't seem to trigger often.

    When switching to pop-up for detail view, there are no errors whatsoever.
    Last edited by fsi; 08-26-2009, 09:24 AM.

  • #2
    Re: "Object Required" Error in Grid Detail - troubleshooting

    And the Version you are using is?
    Insanity: doing the same thing over and over again and expecting different results.
    Albert Einstein, (attributed)
    US (German-born) physicist (1879 - 1955)

    Comment


    • #3
      Re: "Object Required" Error in Grid Detail - troubleshooting

      Oops. v10 beta

      Comment


      • #4
        Re: "Object Required" Error in Grid Detail - troubleshooting

        Just try inserting a dynamic static text field at the end of the selected column, you may also want to outside a container or frame is you are using them. - Give it a go and see, might work.
        Insanity: doing the same thing over and over again and expecting different results.
        Albert Einstein, (attributed)
        US (German-born) physicist (1879 - 1955)

        Comment


        • #5
          Re: "Object Required" Error in Grid Detail - troubleshooting

          I have now trimmed the grid down to one field (the linking field) and trimmed the detail view down to one field (the linking field). Doesn't get much simpler than that. The problem persists. I was somewhat surprised to see the line number for the error, as reported, has not changed. Despite trimming out much code-creating config, the error line remains 3681.

          I'd love to find that line 3681, wherever it's hiding, just to see what it offers.

          About ready to delete the grid component and start from fresh.

          Comment


          • #6
            Re: "Object Required" Error in Grid Detail - troubleshooting

            Ended up building new (replacement) Grid web component. Same query, same fields, same display conditions, formats, etc. Same data. Now it works. Go figure.

            Comment


            • #7
              Re: "Object Required" Error in Grid Detail - troubleshooting

              Because you in the beta that can happen.
              For myself there some minor problems with the page layout builder
              Any way A5 team is very quick with repair:)
              Advise: follow the beta messages and download regular.

              Comment

              Working...
              X