Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

need help: to have loopback within LAN

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • need help: to have loopback within LAN

    I recently purchased and installed a Netgear FVG318 router. My system is:
    Win2k Server
    Compac Proliant Server
    AlphaV5 v9

    I had a Linksys router and it recently broke. So I replaced it with the above mentioned Netgear router. Now I'm having a problem with not being able to access my webpages from within my LAN. I know they work because I can see them outside of my LAN.

    FYI, I did realize that I can access my page within my LAN at: http://localhost/ but when I type my domain in the browser, the netgear router login shows up.

    I have researched the web and also this forum and found a comment at http://msgboard.alphasoftware.com/al...light=loopback

    He mentioned a loopback problem. I contacted Netgear and they mentioned that my router doesn't have loopback built into it.

    I read that I can modify my "host" file located at:
    c:\WINNT\System32\drivers\etc

    This is what is in this file:

    # Copyright (c) 1993-1999 Microsoft Corp.
    #
    # This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
    #
    # This file contains the mappings of IP addresses to host names. Each
    # entry should be kept on an individual line. The IP address should
    # be placed in the first column followed by the corresponding host name.
    # The IP address and the host name should be separated by at least one
    # space.
    #
    # Additionally, comments (such as these) may be inserted on individual
    # lines or following the machine name denoted by a '#' symbol.
    # J:\alpha5\local\A5webroot
    #
    # For example:
    #
    # 102.54.94.97 rhino.acme.com # source server
    # 38.25.63.10 x.acme.com # x client host
    127.0.0.1 localhost
    What would I modify in this file?

    I read an article at: http://www.dyndns.com/support/kb/loo...nnections.html

    Within my Netgear Router program, I know that my Lan IP is 192.168.1.1

    I searched on my server for the "hosts" file and found a recently updated "hosts.tmp" file located at:
    C:\Program Files\DNSexit IP Updater

    All that is in this file is my domain that points to this server ex: pickles.com

    any suggestions? Thanks in advance.

  • #2
    Re: need help: to have loopback within LAN

    Your router has an ip address for the outside world (like 74.72.161.107) and each of your computers on the lan has an inside address (like 192.168.x.x) which the router uses to find a computer. You can find the outside address from whatismyipaddress.com. If you want to access another computer on your own lan you can not use the outside ip address of you router but must use the inside address. This is true even if you use port forwarding on the router. I have a web-cam server on my network and a public address (http://rrwsnowcam.homeip.net). But if I want to use the camera from inside my home I have to use the actual local ip address (like 192.168.x.x). So find out what the ip address of the computer you want to access is. You can use ipconfig on a win system to find this. As you discovered if you use the public ip address of your router from inside you get to the router configuration server not to any computer on your network.
    Irwin

    Comment


    • #3
      Re: need help: to have loopback within LAN

      Irwin, thanks, yes I found that machines IP within my LAN by Start/run/cmd
      then typed: ipconfig/all

      yes, now I can login to that machine from another machine from within my LAN. I remember that, but guess I forgot

      Thanks for the help.

      Comment


      • #4
        Re: need help: to have loopback within LAN

        One thing you might consider. The machine that has the Web App Server should probably have a static IP assigned to it. Why, because the router (assuming you DHCP running on it) will assign dynamic IP addresses to the machines on your local network. That means that if you reboot the router and/or any of the computers you may not get the same IP address assigned to it. So what may work today may not work next week or next month.

        The computer that runs my Web App Server has a static IP assigned to it, 10.10.10.10 . I have the router setup for port forwarding so that web requests on port 80 (web pages) are all directed to that ip address. So if the router gets restarted, the server or any work stations, the server will always be the same.
        Note: I had the router change the assigned ip address range from the usual 192.168.xxx.xxx to assign everything in the 10.10.10.xxx range. If you add other peripherals, there are sometimes conflicts. This helps to resolve that.

        Mike
        Mike Reed
        Phoenix, AZ

        Comment

        Working...
        X