Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Grid Lookup Problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Grid Lookup Problem

    I cannot get a grid lookup to work. When the lookup grid displays I get the error "Done, But with errors on page" When I click on the selection nothing happens. I have done the following and nothing has helped:

    1. Created a new lookup component
    2. Deleted the fillins
    3. Republished all the necessary files
    4. Deleted the grid on the a5w page and reinstalled
    5. Deleted the Javascript folder and recreated

    Where do I go from here?

  • #2
    Re: Grid Lookup Problem

    there is something amiss here. I created a very simple 3 control dialog grid with one control with a lookup. It does not work local as well. That did not work. It still came back with the "error on page" HELP!!!!

    Comment


    • #3
      Re: Grid Lookup Problem

      Phil,

      THis is no comfort to you, but I have a lot of lookups that work just fine. So, I have some questions to help identify the problem:

      Do you have any lookups that work successfully, or is this your first try?

      If you have old lookups that worked, do they still work?

      Is there anything unusual about your lookup grid? I have lookup grids with quick searches and filters, and they all seem to work OK. Usually, I make the fields in my lookup grids all labels, it helps with speed and compactness.

      Where does this "Done with errors..." message appear on the screen?

      Did you get any errors when you did the field mapping?

      Pat
      Pat Bremkamp
      MindKicks Consulting

      Comment


      • #4
        Re: Grid Lookup Problem

        Pat,
        Some interesting findings. Currently I have the V7 WAS on my computer and the lookup does NOT work when published there. However, I published the files to an alpha hosting services that I have access. The lookups work fine there. This is the first time I ever tried the lookups on my WAS. Any ideas of what might be going on? As an extra check, using remote desktop I tried doing the lookup from there to my WAS and still no go.

        The error message momentarily appears in the lower left corner of the lookup window.

        Thanks
        Phil

        Comment


        • #5
          Re: Grid Lookup Problem

          What is wrong with V7? I opened the forms with V8 and had no problems? I reloaded V7 and still have the problems.....

          Comment


          • #6
            Re: Grid Lookup Problem

            I believe there were some bugs fixed in V8 that were not fixed in V7, but none that I know of that would cause your problem.

            One problem that was fixed was data that contained apostrophes. Those would not copy...clicking on Select did nothing.

            I've also had issues with copying formatted data. So, in all my lookup grids, the data (such as phone numbers) is not formatted. So, my next suggestion is to look at your data.

            Perhaps if you could attach a screen shot of your lookup grid, it would trigger some other ideas.

            Pat
            Pat Bremkamp
            MindKicks Consulting

            Comment


            • #7
              Re: Grid Lookup Problem

              Originally posted by Pat Bremkamp View Post
              I believe there were some bugs fixed in V8 that were not fixed in V7, but none that I know of that would cause your problem.

              One problem that was fixed was data that contained apostrophes. Those would not copy...clicking on Select did nothing.

              I've also had issues with copying formatted data. So, in all my lookup grids, the data (such as phone numbers) is not formatted. So, my next suggestion is to look at your data.

              Perhaps if you could attach a screen shot of your lookup grid, it would trigger some other ideas.

              Pat
              I am still using version 9 and I find that if the data has a double quote (") in it, you will get a javascript error.
              Michael Bertrand
              Genmar-Tennessee:)

              Comment

              Working...
              X