Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Printing to PDF

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Re: Printing to PDF

    Bruce, in investigating this error myself, I think there are various problems that cause this issue so I won't just look at a single solution.

    To solve the problem in my location on Alpha v10.5 runtime, I had to go into the Windows(XP)Settings->Printers and Faxes and delete the PDF print driver that was created during installation. Then run a report preview in Alpha; in preview select the PDF button. Alpha will then ask you whether to install the print driver. When you do, the new driver worked.

    Whether this method will work in Win 7, I don't know.

    Comment


    • #17
      Re: Printing to PDF

      I am running A5V10 on Windows 7, and cannot print or save my reports. When I try to save to a file I get the Error 30 message, and when I try to save to a file I get the Error communicating with Printer message.

      I did go into the A5V10 dfolder, find installAmyuni Printers and run it twice. This has not helped.

      I'm using an HP All in One Printer, and have recently reinstalled it (new computer) using the updated installation files from HP.

      Where do I go next?
      Thank you,
      Karen Bedeau

      Comment


      • #18
        Re: Printing to PDF

        Do you find a printer named

        alpha5v4 printer

        in the Windows Printers and Faxes control panel directory?
        There can be only one.

        Comment


        • #19
          Re: Printing to PDF

          Run the InstallAmyuniPrinters by right clicking on the file and choosing "Troubleshoot Compatibility" then select "Recommended Settings." It really grinds my gears that Alpha has not only NOT fixed this issue for V9 but looks like it's an issue in V10 as well.

          Comment


          • #20
            Re: Printing to PDF

            Might be clutching at straws here but;

            Is the Printer selected in the Report Properties set to Default?
            Have you tried printing to File from Report Properties?
            What happens when you Preview and then try to send as a different type of document in an e-mail?

            I ported a V9 app to V10.5 (not latest build) and so far it all works on an array of printers in test.
            Ted Giles
            Example Consulting - UK
            .

            sigpichttp://ec12.example-software.com//
            See our site for Alpha Support, Conversion and Upgrade.

            Comment


            • #21
              Re: Printing to PDF

              Originally posted by Stan Mathews View Post
              Do you find a printer named

              alpha5v4 printer

              in the Windows Printers and Faxes control panel directory?
              No.

              Comment


              • #22
                Re: Printing to PDF

                No I don't find it there.
                Karen

                Comment


                • #23
                  Re: Printing to PDF

                  Then it didn't install correctly. See post #19 in this thread.
                  There can be only one.

                  Comment


                  • #24
                    Re: Printing to PDF

                    OK,I did that, and now AlphaFiveV4 appears in my Printers accessed via the Control Panel. I went into AlphaFive, generated another report, and, although I can print it, I can't archive or save it as a .pdf file.
                    I still get the Printer Communcation error.
                    What next?
                    Karen

                    Comment


                    • #25
                      Re: Printing to PDF

                      Originally posted by Ted Giles View Post
                      Might be clutching at straws here but;

                      Is the Printer selected in the Report Properties set to Default?
                      Have you tried printing to File from Report Properties?
                      What happens when you Preview and then try to send as a different type of document in an e-mail?

                      I ported a V9 app to V10.5 (not latest build) and so far it all works on an array of printers in test.
                      It wasn't set to "default," so I changed it, and still could not "Save as..." (any format) or "Archive"

                      I had the same result when I tried printing to file from Report Properties.

                      However, I am able to send it to myself as an email attachment (.pdf and .rtf) from Report Properties.

                      Karen

                      Comment


                      • #26
                        Re: Printing to PDF

                        Originally posted by KarenABedeau View Post
                        It wasn't set to "default," so I changed it, and still could not "Save as..." (any format) or "Archive"

                        I had the same result when I tried printing to file from Report Properties.

                        However, I am able to send it to myself as an email attachment (.pdf and .rtf) from Report Properties.

                        Karen
                        from Report Properties.
                        I meant from the Report Preview....
                        Karen

                        Comment


                        • #27
                          Re: Printing to PDF

                          Just for informational purposes...

                          If you get to the Reports tab of the control panel, right click on a report name, choose Save As. Does the Print Genie appear?
                          There can be only one.

                          Comment


                          • #28
                            Re: Printing to PDF

                            Originally posted by Stan Mathews View Post
                            Just for informational purposes...

                            If you get to the Reports tab of the control panel, right click on a report name, choose Save As. Does the Print Genie appear?
                            Yes, it does.

                            Comment


                            • #29
                              Re: Printing to PDF

                              Originally posted by KarenABedeau View Post
                              from Report Properties.
                              I meant from the Report Preview....
                              Karen
                              Is there something else I should try to resolve this?

                              Comment


                              • #30
                                Re: Printing to PDF

                                This is just one of sevaral issues I'm having with changing A5V10 to my new computer and Windows 7. I'm not sure whether they are all interrelated, or are separate issues.

                                See "Compacting Database Issue" for one.

                                The other is that my filters (using the Genie) are not working correctly on one of the fields in my parent database. "class" has the following possible entries: NA, NB, OA, OB, UA, UB, RNA, RNB, RAA, RAB, REA, REB, BNA, BNB, GO, GN, VER, TD, TDX, AND VST.
                                I can filter on "begins with R," run my report, and get the correct records.
                                When I filter on "begins with R" and check "exclude records that satisfy this criteria", I do not get the records with BNA, BNB, GO, GN, or VER.
                                When I filter on class = BNA or class = BNB, I get NO records in my report. BUT, when I query on BNA and BNB from the set default browse, I get 16 records.
                                So, I marked those 16 records, and ran the report on Marked Records...NO records in the Report.
                                Am I losing my mind?

                                Comment

                                Working...
                                X