Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Disappearing HTML memo fields

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Disappearing HTML memo fields

    Can someone tell me if I am doing anything wrong here?

    I have created 1 table with 2 fields, 1 of which is an HTML memo. I copied some help from an Alpha help page into the HTML memo field.

    I created 1 form that has a list box and the HTML memo field in a tab control.

    At first the HTML memo field doesn't display. If I click on 1 of the choices in the list box, the HTML memo field suddenly appears. The tab control is irrelevant to the example. It's the combination of the list box + the HTML memo field. Why?

  • #2
    Re: Disappearing HTML memo fields

    Hi Bill,

    This seems to be an issue that has been addressed in the next release, see the notes here.
    Regards
    Keith Hubert
    Alpha Guild Member
    London.
    KHDB Management Systems
    Skype = keith.hubert


    For your day-to-day Needs, you Need an Alpha Database!

    Comment


    • #3
      Re: Disappearing HTML memo fields

      Bill,

      I am not having an issue on build 2736/3523. I also tried it on the Beta release and had no problem.

      Keith,

      Release notes say:

      Report Layouts - HTML Memo Fields - In certain cases HTML Memo fields that had been placed on a Report Layout would not print.

      Unless I am not seeing what you are
      Bill Griffin
      Parkell, Inc

      Comment


      • #4
        Re: Disappearing HTML memo fields

        Thanks for the feedback, Bill & Keith.

        Let me add this bit of clarification: if I double click on the form from control panel, it displays the HTML memo field. Maybe that's why you saw it working.

        However, if I first open the form in Design mode, then click Form->Form View, the HTML memo field is not displayed. I'm on "Choice 1" in my list, and if I click to any other choice, the HTML memo displays. The record pointer is positioned at the first and only record, but if click the icon to go to the first record in the table, the HTML appears as well.

        I'm using v10 2755-3525, which included the fix for HTML memos on reports. I've also tried this on -3523, but I'm not sure I understood the precise steps to recreate this, so I have to go back and double-check. Before I created this test db, I was having a problem in my real db, but I think that problem was bad code on my part in the OnInit event. Now I can't reproduce the problem in my real db, but can consistently produce it in this test db.

        Keith, the "HTML memo on a report" problem is fixed in -3525. Although it might be related to this, it's not a direct fix.

        Comment


        • #5
          Re: Disappearing HTML memo fields

          Bill,

          Ok I see the problem. I don't think it is anything that you are doing wrong. Hitting F5 to refresh the screen brings back the memo. I guess you can report it as a bug. I did not see it happen immediatly, though, it tooka couple of times closing and opening the form before the problem manifested itself. Hopefully Alpha will be able to reproduce it. (this is happening on the Beta build)
          Bill Griffin
          Parkell, Inc

          Comment


          • #6
            Re: Disappearing HTML memo fields

            Originally posted by Bill Griffin View Post
            Bill,

            Ok I see the problem. I don't think it is anything that you are doing wrong. Hitting F5 to refresh the screen brings back the memo. I guess you can report it as a bug. I did not see it happen immediatly, though, it tooka couple of times closing and opening the form before the problem manifested itself. Hopefully Alpha will be able to reproduce it. (this is happening on the Beta build)
            is this happening in the release candidate build?

            Comment


            • #7
              Re: Disappearing HTML memo fields

              Yes sir, sorry should have used your terminology (RC) to avoid confusion. Like I said it did not happen immediattly for me, I had to open and close the form several times, but once it started happening, it continued.
              Bill Griffin
              Parkell, Inc

              Comment


              • #8
                Re: Disappearing HTML memo fields

                For me, Build 3531 (the RC) seems to have fixed the problem I described.

                I did as Bill suggested and opened the form a number of times (10+) in design mode, then went to view it, but couldn't recreate the problem. Maybe 10+ wasn't enough?

                Comment


                • #9
                  Re: Disappearing HTML memo fields

                  Bill,

                  try this click on a tab, close the form and open in deign mode, switch to form view
                  Bill Griffin
                  Parkell, Inc

                  Comment


                  • #10
                    Re: Disappearing HTML memo fields

                    Tried that, and can't get it to break.

                    I took "click on a tab" to mean click on one of the tabs on the form, such as Page 2.

                    I double-clicked on the form in control panel, clicked on the "Page 2" tab of the form, closed the form, opened the form in design mode, then switched to form view. And it still worked. I also tried switching tabs of control panel, clicking on the form tabs multiple times (Page 2 to 3, back to 2, etc), and repeating this a number of times (but in the realm of < 10), and it still worked.

                    Comment


                    • #11
                      Re: Disappearing HTML memo fields

                      Trivial bug anyway. but glad it's working for you
                      Bill Griffin
                      Parkell, Inc

                      Comment


                      • #12
                        Re: Disappearing HTML memo fields

                        Originally posted by Bill Murray View Post
                        Can someone tell me if I am doing anything wrong here?

                        I have created 1 table with 2 fields, 1 of which is an HTML memo. I copied some help from an Alpha help page into the HTML memo field.

                        I created 1 form that has a list box and the HTML memo field in a tab control.

                        At first the HTML memo field doesn't display. If I click on 1 of the choices in the list box, the HTML memo field suddenly appears. The tab control is irrelevant to the example. It's the combination of the list box + the HTML memo field. Why?
                        this is fixed. it will be in the next update. it is NOT yet in the release candidate.

                        Comment


                        • #13
                          Re: Disappearing HTML memo fields

                          Excellent response time as usual....

                          Thanks
                          Bill Griffin
                          Parkell, Inc

                          Comment


                          • #14
                            Re: Disappearing HTML memo fields

                            Yes, excellent response indeed.

                            All bugs are trivial unless they affect what you are trying to do.

                            Comment


                            • #15
                              Re: Disappearing HTML memo fields

                              Originally posted by Bill Murray View Post
                              All bugs are trivial unless they affect what you are trying to do.
                              If only that were true

                              :)
                              Bill Griffin
                              Parkell, Inc

                              Comment

                              Working...
                              X