Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Problem with a report

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with a report

    Here is a screenshot of what I want to achieve, a very simple task but it is not showing the result. I already tried putting the field in every footer of the report, but it not doing the calculation, except for the report footer, in any other group footer it doesn't show up.

  • #2
    Re: Problem with a report

    Is the report showing the Label for the total or does the name of the calculated field show? Alpha displays the field name instead of the calculated value when the calculation can't be resolved.
    There can be only one.

    Comment


    • #3
      Re: Problem with a report

      It only shows the label, the field name is blank, except in the REPORT FOOTER, there it displays the correct amount (the total for all clients) I want the total per year per client.

      Comment


      • #4
        Re: Problem with a report

        Doesn't sound right. Any way you can zip and attach a sample set/table upon which the report is based?
        There can be only one.

        Comment


        • #5
          Re: Problem with a report

          Here it is.
          Last edited by mastermind315; 03-18-2010, 12:17 PM.

          Comment


          • #6
            Re: Problem with a report

            Alpha is choking on your group labels in Spanish with non English characters. Changing them to Client and Year makes the total calculations appear correctly.
            There can be only one.

            Comment


            • #7
              Re: Problem with a report

              Thank You!

              Comment


              • #8
                Re: Problem with a report

                When I looked at the calculated fields generated by Alpha I got

                Code:
                tot_calc_TotalContribucion_for_ = total(calc->TotalContribucion,grp->,grp->Grand)
                run_tot_tblfecha_Contribucion_for_ = run_total(tblfecha->Contribucion,grp->,grp->Grand)
                tot_tblfecha_Contribucion_for_ = total(tblfecha->Contribucion,grp->,grp->Grand)
                tot_tblfecha_Contribucion_for_Grand = total(tblfecha->Contribucion,grp->Grand,grp->detail)
                tot2_calc_TotalContribucion_for_ = total(calc->TotalContribucion,grp->,grp->Grand)
                Note that the defined group designations were missing...


                calc->TotalContribucion,grp->-------,grp->Grand
                There can be only one.

                Comment


                • #9
                  Re: Problem with a report

                  Yes, I deleted them because I thought they were not working, but they still appear in the calculated field section, I don't know why. I'm still having problem aligning the Client information on top of the page. The address stays in the left when I select CENTER. The exit button doesn't work in the preview screen. I don't know if all this issues had to do with the Spanish words. I changed all of them, but still having all this problems.

                  Comment


                  • #10
                    Re: Problem with a report

                    Those calculated fields can not be deleted, nor they disappeared if I remove them from the report. Why? I restarted Alpha but that didn't make it either.

                    Comment


                    • #11
                      Re: Problem with a report

                      Open the report in design mode, use the Report menu, Calculated Fields. Delete them there then delete them from the report layout.
                      There can be only one.

                      Comment


                      • #12
                        Re: Problem with a report

                        Thank you, again... the aligning and the EXIT button problems, what could them be?
                        I'm using Windows 7 Ultimate 64bits... any known issues related with the operating system?

                        Comment


                        • #13
                          Re: Problem with a report

                          The address field has the same non English character problem, I think.

                          Create a new calculated field

                          add = Direccion_Postal

                          Change the field in the report group header to reference the calculated field. It will align center.

                          I don't see a problem with the exit button but I'm using V8 on xp pro 32 bit.
                          There can be only one.

                          Comment

                          Working...
                          X