Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

HELP...Working Function not Working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • HELP...Working Function not Working

    I have been stuck back on Version 9 build 1634 because that is about the last version that still worked without a hitch. I use this everyday and don't even know how to begin to get these bugs out so that I can move forward to Version 10 as the program is used everyday and I can't just stop life to change versions. Well I thought I'd try to see if I could get it to run under V10 and brought home an archive of my data and set out to see if I could make a go of it. Lots of problems with browses and now a function that works fine in version nine doesn't work at all in V10. Can someone look at this and tell me what is wrong with this. Why does it work good in V9 but refuses to Work in V10?

    It is a simple function that returns a mark-up multiplier based on the department and cost of an item. What gives?

    Also with the new browses, does deleting the browse and then recreating it in V10 fix the issues. Does version 10 have its own format for the browses that V9's will not work properly in them? I searched the forum to see if anyone spelled out the differences between the two version browses but could not find any info. My data files are large and alpha has always been backward compatible since version 2 or 3 and I have just been updating every time without a hitch. But now I got problems that were introduced with the upgrades starting halfway through V9 and now into V10.

    If anyone can see a syntax error in this function or has had long running browses that just are now riddled with wierdness that information would be very helpful.

    Finally, if I can get this archive copy to work, How do I update all the forms, browses, reports, functions etc. without overwriting my DBF data that is rapidly changing while I am mucking around with the upgrade?? Can someone point to a post or help file for that??

    Thanks - Here is the function that only works in V9 and earlier

    'Date Created: 06-May-2006 05:40:11 PM
    'Last Updated: 06-May-2006 06:19:48 PM
    'Created By :
    'Updated By :
    FUNCTION MU AS N (dept AS C, cost AS N )
    dim t as P
    dim qry as p
    dim x as n
    t=table.open("mu_matrix",FILE_RO_SHARED)
    query.filter="MU_Chart=dept.and.cost>=lower.and.cost<=upper"
    query.order=""
    query.options=""
    qry=t.query_create()
    mu=t.mult
    t.close()
    END FUNCTION

  • #2
    Re: HELP...Working Function not Working

    A likely cause is the omission of required quote marks. I would expect the filter expression to look like this:

    Code:
    query.filter="trim(MU_Chart) = " + quote(dept) + ".and. cost >= lower .and. cost <= upper"
    Trimming the Mu_Chart field value would not be necessary if the width of the dept var is always going to match the width of the mu_chart field in your table structure.

    It's a mistake to omit the query.options. In this case I recommend

    query.options = "T"

    If these ideas don't get you going post sample data.

    Comment


    • #3
      Re: HELP...Working Function not Working

      Thanks Tom,
      I'll try that tonight when I am back at the other box. How come it was acceptable in 9 but not in 10?

      Also where is a good article on writing over program changes without changing data. I've always made changes to the program when it wasn't in use so that I could just over write the entire data directory when I was done (after a good back-up of course).

      But this time I am going to be weeks out B4 I can go put the cleaned up program changes into my data files at work. It's a scary thought. I am sure its been covered somewhere but not sure what to search on...

      Comment


      • #4
        Re: HELP...Working Function not Working

        Alpha Five File Types
        There can be only one.

        Comment


        • #5
          Re: HELP...Working Function not Working

          How come it was acceptable in 9 but not in 10?
          I'm surprised v9 did not bark. If the data types are in fact what you've shown us here it should have.

          Comment


          • #6
            Re: HELP...Working Function not Working

            Well Tom,

            That works fine now. I see what the changes are and when I made them it works right. It has worked in previous versions the other way. I am always a little confused as to when to enclose in quotes and when to just state the variables...

            Comment


            • #7
              Re: HELP...Working Function not Working

              Dan, check the help file topic "Writing Expressions". The section on "Character Filter Expressions" will give you some guidance.

              Comment

              Working...
              X