Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

calculated field expression builder not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • calculated field expression builder not working

    I just upgrade my V9 to V10, now using the latest patch 2814_3539,
    however the calculated field builder in the table field rule not working and cause the alpha to hangs. Need to get the task manager to shut it down.
    I open same file in same environment (mine is WindowsXP service pack 2 version 2002)using V8, can edit the calculated field with pop-up builder appear as expected.

    I have reinstall / repair V10, re-patch and run using the alphasport files. Same results.

    Does anyone have same problem as this? What should I do and how to fix this?

    Thanks
    Regards

    Razali

  • #2
    Re: calculated field expression builder not working

    Razali,
    No problems here. What is the calculated field rule you are trying to create?
    Are you certain the fields the calculation is trying to pull values from are in the table with the calculated field? Are you including varaiable values in the calculation (neither advisable nor available for the calculation) ?
    Mike W
    __________________________
    "I rebel in at least small things to express to the world that I have not completely surrendered"

    Comment


    • #3
      Re: calculated field expression builder not working

      Hi Mike,

      Thanks for the prompt assist.
      I tried to create calculate field to total up certain numeric field ( qty*day*freq ).

      click the calculate options fines. But to define the calculation I need to click the expression builder at the bottom. This cause the alpha to hang.

      I just create a new simple table with 2 fields in new database. After changing the extended field type to calculated in the options, clicking the builder produce same problem. I could type in the space provided. Means the pop up builder can not appear.

      I could not figure out what may cause it since the V8 alpha run with no error.

      Regards
      Razali

      Comment


      • #4
        Re: calculated field expression builder not working

        Sounds like the expression builder is opening, but is positioned off of your screen.

        Can you press alt-f4 and close the dialog and is Alpha OK then?

        Is so, then you need to adjust the registry entries for Alpha to display the expression builder in a different place.

        Or do what I do. Save the license number(so you can reenter it), remove all the registry entries (HKEY_CURRENT_USER) for that version of Alpha and restart Alpha. All registry entries are recreated with the default values.
        Al Buchholz
        Bookwood Systems, LTD
        Weekly QReportBuilder Webinars Thursday 1 pm CST

        Occam's Razor - KISS
        Normalize till it hurts - De-normalize till it works.
        Advice offered and questions asked in the spirit of learning how to fish is better than someone giving you a fish.
        When we triage a problem it is much easier to read sample systems than to read a mind.
        "Make it as simple as possible, but not simpler."
        Albert Einstein

        http://www.iadn.com/images/media/iadn_member.png

        Comment


        • #5
          Re: calculated field expression builder not working

          yes, you are absolutely 100% right.

          You save me from removing many of my other program (which I though may be the cause). In fact I have free up more memory now just in case.

          Some how, recently I use 2 displays (screen/ monitor) to work with. This morning I didn't switch on the other screen and was disconnected.

          After your advice, i reconnect the display, and there is the expression builder in the center which had been waiting there for so long.

          Sorry for troubling you and Mike and thanks for the help.
          With you guys around, I feel more confidence in working with alpha products.

          Comment


          • #6
            Re: calculated field expression builder not working

            Nice one Al,
            I use 2 displays (screen/ monitor) to work with. This morning I didn't switch on the other screen and was disconnected.
            Funny how these small details can make all the difference.
            Regards
            Keith Hubert
            Alpha Guild Member
            London.
            KHDB Management Systems
            Skype = keith.hubert


            For your day-to-day Needs, you Need an Alpha Database!

            Comment


            • #7
              Re: calculated field expression builder not working

              Originally posted by Keith Hubert View Post
              Nice one Al,Funny how these small details can make all the difference.
              We are in a detail based industry...

              I usually ask someone if they have 2 (or more) monitors, but didn't think of that initially with this issue..

              The 2 monitors issue also comes up with remote support..

              Client: See this on my screen?
              Me: Is it on your primary screen or secondary screen?
              Client: Oh, let me move it there..

              So easy to forget that one..

              Cheers..
              Al Buchholz
              Bookwood Systems, LTD
              Weekly QReportBuilder Webinars Thursday 1 pm CST

              Occam's Razor - KISS
              Normalize till it hurts - De-normalize till it works.
              Advice offered and questions asked in the spirit of learning how to fish is better than someone giving you a fish.
              When we triage a problem it is much easier to read sample systems than to read a mind.
              "Make it as simple as possible, but not simpler."
              Albert Einstein

              http://www.iadn.com/images/media/iadn_member.png

              Comment


              • #8
                Re: calculated field expression builder not working

                Al,

                That is a lot like the client who phones up the support desk demanding why their computer does not work. Eventually the support asks, is the plug for the computer plugged in and is the plug in the wall switched on!!!!

                Cleaners were in last night and used the socket for the floor cleaner.
                Regards
                Keith Hubert
                Alpha Guild Member
                London.
                KHDB Management Systems
                Skype = keith.hubert


                For your day-to-day Needs, you Need an Alpha Database!

                Comment


                • #9
                  Re: calculated field expression builder not working

                  This little problem do give me some learning experience:
                  1 use alt-F4 to close the dialog
                  2 adjust the registry keys if needed
                  3 never forget to switch on the 2nd display.
                  4 restart, reinstall, alt-F4 etc would not make the 'gadget'(exp builder) to appear in screen one.
                  5 need to move the alpha windows back to the 1st screen
                  6 need to move that gadget back to the first screen too.
                  7 lastly it is now safe to switch display back to single screen.

                  Perhaps alpha could add or adjust the default location of this exp builder when it appear. Well, this is just my idea and problem occurred to me. May be others not.

                  Thanks.

                  Comment

                  Working...
                  X