Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Question on Error running addin Startup 100 Register Controls

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Question on Error running addin Startup 100 Register Controls

    Good morning,

    Recently I was able to create a Setup.exe file using the InstallMaker and it completed it fine. I had then try to install the newly, created Setup.exe to another machine that has Windows 7 with plenty of memory.

    The installition went well, but when I try to activate the installed application the splash screen starts to show (so far so good) and then in the middle of when it's loading up I get an error message, (see attached JPG image file for error message).

    How do I fix this error message or is this a bug?

    Also, I went into the Open folder of the Runtime to load the dbf file after I clicked on the OK button from the error message and the application is working fine. But still I need to resolve the error message.

    I hope somebody could help me out with this.

    Thank you.

    Regards,

    Pat

  • #2
    Re: Question on Error running addin Startup 100 Register Controls

    This may be it.

    Vista and Windows 7 are preventing stuff from getting registered.

    Have a look here...

    http://msgboard.alphasoftware.com/al...ister+controls

    Comment


    • #3
      Re: Question on Error running addin Startup 100 Register Controls

      I have this problem with XP machines.
      Mike W
      __________________________
      "I rebel in at least small things to express to the world that I have not completely surrendered"

      Comment


      • #4
        Re: Question on Error running addin Startup 100 Register Controls

        Hi David,

        I thank you for your help, and I will try it out for the Windows 7 version. I have recently try to install my application on a XP Pro version before your kind suggestion and it works great without any problems. My client uses XP Pro. I had made sure that I got all of the latest updates from Microsoft before installing the application. Again, thank you.

        Regards,

        Pat



        Originally posted by Davidk View Post
        This may be it.

        Vista and Windows 7 are preventing stuff from getting registered.

        Have a look here...

        http://msgboard.alphasoftware.com/al...ister+controls

        Comment


        • #5
          Re: Question on Error running addin Startup 100 Register Controls

          When I had this problem on xp I resolved it by deleting the runtime folder and reinstalling.

          Comment


          • #6
            Re: Question on Error running addin Startup 100 Register Controls

            Thanks John, I give that a go.
            Mike W
            __________________________
            "I rebel in at least small things to express to the world that I have not completely surrendered"

            Comment


            • #7
              Re: Question on Error running addin Startup 100 Register Controls

              I, like many others use the install program Astrum Install Wizard. This lets you create rock solid installs of your application and registers the .DLL's in all versions of Windows including 7 without any problems. This is a great tool that takes the headache out of distributing applications.

              Comment


              • #8
                Re: Question on Error running addin Startup 100 Register Controls

                Which version is required to solve this problem? Does using the Standard version work against this problem?

                http://www.thraexsoftware.com/aiw/porder.html
                Mike W
                __________________________
                "I rebel in at least small things to express to the world that I have not completely surrendered"

                Comment


                • #9
                  Re: Question on Error running addin Startup 100 Register Controls

                  Yes,

                  I've used this program for years now and so do many other Alpha users. It is by far the best I've worked with an lets you build a customer install that can place files in many folders, place icons on desktop, start menu and more. The standard is all I use.

                  Comment


                  • #10
                    Re: Question on Error running addin Startup 100 Register Controls

                    I call this script ddefix: I call it from a button on the main menu(actually a dropdown button)

                    Code:
                    exe_path = a5.get_exe_path()
                    sys_shell("regsvr32.exe " + exe_path + "\a5controls.dll/s")
                    sys_shell("regsvr32.exe " + exe_path + "\A5ContextEval.dll/s")
                    sys_shell("regsvr32.exe " + exe_path + "\SimpleChart4Lite.dll/s")
                    sys_shell("regsvr32.exe " + exe_path + "\Codejock.PropertyGrid.v11.1.3.ocx/s")
                    sys_shell("regsvr32.exe " + exe_path + "\Codejock.ReportControl.v11.1.3.ocx/s")
                    sys_shell("regsvr32.exe " + exe_path + "\Codejock.SuiteCtrls.v11.1.3.ocx/s")
                    sys_shell("regsvr32.exe " + exe_path + "\Codejock.TaskPanel.v11.1.3.ocx/s")
                    Try it and it will work. Any newer codejocks's may need to be added.


                    .
                    Dave Mason
                    [email protected]
                    Skype is dave.mason46

                    Comment


                    • #11
                      Re: Question on Error running addin Startup 100 Register Controls

                      Dave,

                      Thta looks great! does it work the same on 64bit systems like Windows 7?

                      I have a new Windows 7 laptop and it is the 64bit OS

                      Comment


                      • #12
                        Re: Question on Error running addin Startup 100 Register Controls

                        I can tell you it doesn't work with thin clients on a large Novell network.
                        Mike W
                        __________________________
                        "I rebel in at least small things to express to the world that I have not completely surrendered"

                        Comment


                        • #13
                          Re: Question on Error running addin Startup 100 Register Controls

                          Thta looks great! does it work the same on 64bit systems like Windows 7?
                          I can't tell you. I have not tried it on 64 bit yet.

                          Mike,
                          never used a Novel system except as storage container. Same with many other systems.

                          I specify windows(work stations) systems and so far users on 64 bit windows have not called because of a problem. But, My program is a simple put it in and print it out. Nothing fancy. No Pdf's, etc.









                          .
                          Dave Mason
                          [email protected]
                          Skype is dave.mason46

                          Comment


                          • #14
                            Re: Question on Error running addin Startup 100 Register Controls

                            Working with Astrum now. Haven't got it to work completely with v10 Run Time + application. The Astrum Genie asks for folders and files to integrate into a setup file, but for some reason it doesn't integrate all the folders/files chosen even though they are clearly listed in the Genie window. Time to read more of the manual, I guess.
                            Mike W
                            __________________________
                            "I rebel in at least small things to express to the world that I have not completely surrendered"

                            Comment


                            • #15
                              Re: Question on Error running addin Startup 100 Register Controls

                              Mike,

                              Maybe I have less problems with runtimes because the runtime and application are in one folder. Nothing gets installed to program files. I do this with astrum installer. Astrum registers my dll's and writes all my registry stuff for a5(and now some of my own).

                              If it is a very large app on only one computer, it may even have a seperate folder for the server part of the app.

                              example:

                              c:\upsr = complete runtime including alpha5.exe
                              c:\upss = all the data

                              .
                              Dave Mason
                              [email protected]
                              Skype is dave.mason46

                              Comment

                              Working...
                              X