Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook



The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic

Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.

If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.

Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.

Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

I have tried EVERYTHING (I think)

  • Filter
  • Time
  • Show
Clear All
new posts

  • I have tried EVERYTHING (I think)

    So, I created a new FOLDER
    Created a new WORKSPACE
    Created new files - TRIPS and DESC.
    Loaded new records - 2 in each file
    Alpha then allowed me to build an INDEX over TRIPS. OK.
    I then created a SET, using TRIPS as primary file.
    And then, I selected CREATE INDEXES.
    Now there's trouble.
    System simply ignores that request.
    I then tried a file earlier this week, in a different folder, was working fine.
    Looks like any indexes that existed, are OK
    BUT, I cannot build new INDEX over any file.


  • #2
    Re: I have tried EVERYTHING (I think)


    Can you provide your sample tables?


    • #3
      Re: I have tried EVERYTHING (I think)


      Thanks for the response.
      I have extracted 11 trips (9770-9780) for your review.
      The problem still exists. I cannot build an index over the set: TRIPSET.SET
      This problem now seems to be everywhere: in all of the databases on this network.
      I'd appreciate any input and/or insight you may have.
      I also re-downloaded and re-installed A5V12 - just in case.

      I've been trying to upload a ZIP of the BACKUP - unsuccessfully. It is 9.6 MB and after the upload, I get a RED exclamation point after the file.
      Any ideas ?
      Too big ?


      • #4
        Re: I have tried EVERYTHING (I think)


        Do you know how to copy a table to another WorkSpace?

        After copy tables and delete the records except a few records.

        or create Sample WorkSpace and create the tables, -- you can copy and paste the structure ( fields).


        • #5
          Re: I have tried EVERYTHING (I think)

          The backup is of no use Larry.
          If you only have 2 tables and a few records, it should be possible quite easily to;

          From the Control Panel - Tables Tab open.
          Zip Workspace
          Upload it here.

          By doing this, we don't get all the baggage associated with a backup.

          You cannot build Indices when the table is open in a form or other application.
          Your other problem with the system assuming the Enter has already begun could be to do with the fact you edited the Form and started entering data without saving it first - ie, in Form View mode.
          That may screw up the process.
          See our Hybrid Option here;

          If at first you don't succeed; call it Version 1.0


          • #6
            Re: I have tried EVERYTHING (I think)

            Good Morning - I think

            So, I recreated a database , built a few files, and then, built a set, right clicked on the set to build an index, and - NO GO !

            If you all see what I'm doing incorrectly, please let me know.




            • #7
              Re: I have tried EVERYTHING (I think)


              Thanks for your thoughts but, I don't think I have violated any of those rules.

              I uploaded a ZIP file with the same problem. Hopefully a fresh pair of eyes will discover this mystery.



              • #8
                Re: I have tried EVERYTHING (I think)


                I created a database, zipped, and uploaded. See next msg


                • #9
                  Re: I have tried EVERYTHING (I think)


                  I just downloaded your zip and creeated an index on the set using the trip field. No probs. Can you tell us what is the index you are trying to make? Might make it easier to diagnose.


                  • #10
                    Re: I have tried EVERYTHING (I think)

                    Will be just a minute


                    • #11
                      Re: I have tried EVERYTHING (I think)


                      I restored the zip file and tried to create an index OV ER TRIPSET.SET without success




                      • #12
                        Re: I have tried EVERYTHING (I think)

                        I think you may find that CODE is not a good name for a field, nor an Index. Some words do not sit well with Alpha.
                        Like Jon, I can create an index in the Set using a simple single field.
                        When you have the full index, let us know.
                        See our Hybrid Option here;

                        If at first you don't succeed; call it Version 1.0


                        • #13
                          Re: I have tried EVERYTHING (I think)


                          I could not build an index therefor, I don't understand.

                          The problem is just that. When I right click to define indices, nothing happens, when using the set. I will change the field name but I haven't much faith that will do anything.

                          The live file in the live database, does not use CODE as a field name.



                          • #14
                            Re: I have tried EVERYTHING (I think)

                            Let me build it and send it back. See below - 1:1 and 1:Many sets.

                            See if you can create an index in these.

                            If you still cannot get at the Index, you have a more serious problem.

                            See our Hybrid Option here;

                            If at first you don't succeed; call it Version 1.0


                            • #15
                              Re: I have tried EVERYTHING (I think)


                              Revised your db