Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Where's the AUTOEXEC ???

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Re: Where's the AUTOEXEC ???

    "I then sent the database to another computer, here in my office. But I sent it via GOTOASSIST. Unpacked the database. The AUTOEXEC WAS THERE !"

    What were you using before the GoToAssist test that worked? If another remote app service was used, could it be the culprit?

    I use SimpleHelp. An early version did not overwrite existing files on the target computer. It said it did, but it did not.

    Why are you zipping just 4 small files? Try just sending the files needed without the zipping, as I suggested above.

    How about using Google drive to move the files, without zipping or remote transfer touching them?

    Ted has a good question with what zip tool are you zipping with? I can see a zip tool on one end or the other fouling a file... Never happened to me before, but maybe the zip tool is infecting memo-like files?

    Is Larry's computer infecting the zip file, which seems unlikely with such a seasoned user. I would assume he has solid AV running?

    Larry, are you and I think Ted suggesting an antivirus surgically scraped out the just autoexec script? Are there other scripts in the library after the alleged removal, with just the autoexec disappearing?? Are they still there? Did the date modified on the alx, alm, or alb files change at the point it was removed? What is in the script that might trigger a heuristic false-positive? Are you calling out to an infected file with SYS_OPEN(), SYS_SHELL(), popups messages, or something?

    The sample you provided has the autoexec by me, as Tim also confirmed. I use McAfee AV.

    I'm sticking with the idea that the file isn't getting overwritten, or my (& some of Ted's) other ideas above. (I still find a Window's update unlikely as there would be a flurry of activity on the board, and my phone would be ringing like crazy with hundreds of callers.)

    Please be sure to post your solution. This is something of a puzzle, and I find it intriguing...

    Comment


    • #17
      Re: Where's the AUTOEXEC ???

      Lar, one way to test the zip/transfer/AV issue is to send the zipped app and see if ANY scripts get taken over.
      Try renaming Autoexe to something else and see what happens.
      Might narrow it down,
      Ted Giles
      Example Consulting - UK
      .

      sigpichttp://ec12.example-software.com//
      See our site for Alpha Support, Conversion and Upgrade.

      Comment


      • #18
        Re: Where's the AUTOEXEC ???

        Larry, this may be obvious to everyone, but has not yet been confirmed in this thread.

        When you say the AUTOEXEC is missing on the remote client's machine you are saying you are not able to see it on the CODE page of the Control Panel in the client's Alpha desktop application, right?

        As I recall the AutoExec script is stored in the dictioniaries of the workspace itself, and is not a separate file on disk.

        I apologize in advance if this was already obvious. It occurred to me that later travellers who wander by this thread will be confused, so my purpose is to clarify.

        -- tom

        Comment


        • #19
          Re: Where's the AUTOEXEC ???

          SO... there's GOOD news and BAD news.

          I troubleshot this problem most of the night. Tried to put myself OUTSIDE the box. AUTOEXEC was here, on my laptop(s) and seemed to work just fine. I then ZIPPED after downloading a new PKZIP file. NO CHANGE. I zipped the app and uploaded. NO CHANGE. I then uploaded A5V12 and installed. When I ran, the AUTOEXEC file WAS THERE - on my customer's computer. I verified that the AUTOEXEC file was there - it was. Checked the Runtime once again - it was not there. So now, I have a paradox: on one computer but not the other. That's why I documented the screens in the attachment. But then - a lightbulb went off. What was that little flicker when the runtime fired up. It was the AUTOEXEC file running - on startup - just like it should. The AUTOEXEC file updates BREEDER and OWNER names - details are not important. So, I blanked out the next to the last horses Breeder and Owner names. Verified they were blank, exited the app, and restarted. The names had been updated by a startup script, AUTOEXEC, that clearly did now exists. I uninstalled the full development app and restarted the computer. Bottomline, it appears the app is OK now. I still do not understand why I could not see the AUTOEXEC startup routine.

          Lar

          LFC001.pdf

          Comment


          • #20
            Re: Where's the AUTOEXEC ???

            If this is V12 (Alpha Anywhere) the 'code' tab is not visible in the runtime. Confirmed when looking at page 4 of your PDF

            Comment


            • #21
              Re: Where's the AUTOEXEC ???

              From above:

              4) Ted's theory about shadowed files has great merit. Just for kicks, try opening the runtime directly on the workstation from program files (x86) folder and navigate the app directory. You cannot see the code tab in the runtime, but does the script run? You may need to add a message box to know. (I know you said the workstation isn't shadowed, but his theory is in play here... you have to eliminate this possibility since it's really valid and the most likely reason.)

              It appears you were comparing the contents of the code tab to the contents of the operations tab if you look at pages 3 and 4 of your pdf. Can't say I haven't done similar things from time to time....

              Nice catch, Jon.

              Comment


              • #22
                Re: Where's the AUTOEXEC ???

                I don't have V12 RT, just V11. [I do have an old free V12 though]
                The Code Tab shows fine in V11, but you cannot edit any code. I was not aware that the Code tab was hidden in V12 RT. Apologies.
                Glad you got it working.

                Now, any tips for the UK Grand National?
                Ted Giles
                Example Consulting - UK
                .

                sigpichttp://ec12.example-software.com//
                See our site for Alpha Support, Conversion and Upgrade.

                Comment


                • #23
                  Re: Where's the AUTOEXEC ???

                  Originally posted by armasoft View Post
                  If this is V12 (Alpha Anywhere) the 'code' tab is not visible in the runtime. Confirmed when looking at page 4 of your PDF
                  If you right click on the tabs, can you turn on the code tab?
                  Al Buchholz
                  Bookwood Systems, LTD
                  Weekly QReportBuilder Webinars Thursday 1 pm CST

                  Occam's Razor - KISS
                  Normalize till it hurts - De-normalize till it works.
                  Advice offered and questions asked in the spirit of learning how to fish is better than someone giving you a fish.
                  When we triage a problem it is much easier to read sample systems than to read a mind.
                  "Make it as simple as possible, but not simpler."
                  Albert Einstein

                  Comment


                  • #24
                    Re: Where's the AUTOEXEC ???

                    Originally posted by Al Buchholz View Post
                    If you right click on the tabs, can you turn on the code tab?
                    Nope

                    Comment

                    Working...
                    X