Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Can not create PDF

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Re: Can not create PDF

    I'm experiencing this same problem on the server hosting my application. No problem on my local computer.

    My error message says; "Alpha Five was not able to install printer drivers. Please log on to this computer with administrative privileges." What file should I be looking for, and where should I be looking, to manually install it? This error message just popped up after the last upgrade to V11.

    Thanks ~ Tom

    Comment


    • #32
      Re: Can not create PDF

      Tom, did you see Michael Humby's list of instructions, earlier in this same thread of messages?

      Comment


      • #33
        Re: Can not create PDF

        Hi Tom - Yes I did see Michael's response and sent it to our hosting sys administrator and he reports no success using that approach.

        Other ideas? This just started with the last update. Any idea on how I could "manually" install it?

        thanks ~ Tom

        Comment


        • #34
          Re: Can not create PDF

          No, sorry.

          It''s hard to see how a v11 update could break the PDF functionality in v10.5. Maybe something else changed on your server?

          Comment


          • #35
            Re: Can not create PDF

            Just to clarify, I'm using V11.

            Comment


            • #36
              Re: Can not create PDF

              Thanks, I confused you with the person who began this thread.

              Comment


              • #37
                Re: Can not create PDF

                Note: I tried Michal's approach. I had to restart the server afterwards before it had any effect. I'm a bit concerned about how printing directy to the print might have an effect when multiple reports from multiple users need to print at the same time.

                Comment


                • #38
                  Re: Can not create PDF

                  Perfectly supports Alpha Sports
                  Sample Forms

                  Comment


                  • #39
                    Re: Can not create PDF

                    Hi

                    I am using Alpha Five Runtime Version 10.5, unable to install the "Alphafiveprinter V4". Tried installing the printer from "AmyuniV4" sub-folder within the A5V10 Runtime folder. It installs the "Amyuni Document Converter", which is not recognised by Alpha Five Application. The problem is mainly with installations on Windows 7 (64 bit) systems. Application installation was done as administrator.

                    Question: How can I install the "Alphafiveprinter V4" from outwith Alpha Five Runtime?

                    Any help will be appreciated.

                    Raj

                    Comment


                    • #40
                      Re: Can not create PDF

                      Thanks to both of you I solved another issue just like this.

                      In my case, it only got fixed when we deleted the OneNote printer - but when we did, the AlphaFive printer automatically "took over" the nul: port.

                      By the way, there was some resistance from my user over deleting the OneNote printer but we finally did it and it worked. I don't know if this made any difference but before deleting it, he disabled OneNote in Outlook.

                      Originally posted by Michael Humby View Post
                      Barry,

                      We install anything up to 30 x V10 apps each week on various OS systems and we often get this problem of Alpha locking up when trying to create the very first PDF and load the driver, almost always with Windows 7 PCs. We have never managed to establish an exact pattern or scenario so do not know whether this is Alpha, Amyuni, Adobe Reader or Windows 7 problem. The good news is that it happens less frequently just lately. Assuming that you have already run the App as Windows Administrator and tried to print a report/letter as PDF, then this is how we fix the problem:

                      First go to Windows 7 'Start' and type 'Services' then run the Services, you should see a list, scroll down then focus on 'Print Spooler' then upper left 'Restart the service' now continue with the following:

                      1) Make sure that you are logged in as a Windows user with administrator rights.
                      2) Select Control Panel, and click Printers.
                      3) Right-click the Alpha Five Printer icon and choose 'Printer Properties'
                      4) Select the Ports tab, then click the Add Port... button.
                      5) Select Local Port and click the New Port... button.
                      6) Enter NUL: for the new port name and click OK. Close the Printer Ports window.
                      7) Ensure that the NUL: port is selected in the Ports list.
                      8) Select the Advanced tab.
                      9) Select the Spool print documents radio button to make the options below clickable.
                      10) Clear (uncheck) the box labeled Enable advanced printing features.
                      11) Select the Print directly to printer radio button again.
                      12) Click the Apply button, and then click OK.

                      Hope this helps

                      Michael
                      www.instantnurserymanager.co.uk
                      Originally posted by martinwcole View Post
                      The new MS "One Note" is an issue, regardless of OS or Alpha version. I have been removing the OneNote printer, and resetting the port for the alpha4printer - but I like Michael's remedy better

                      Comment


                      • #41
                        Re: Can not create PDF

                        Thank you Michael !

                        You have removed a thorn in my side.
                        Would you believe that every time my clients called me about the "No printer configured" or "A default printer does not exist..." error I rebooted the machine server ?
                        and even so, sometimes it did not work.

                        But Michael solution has set me free.

                        I am not sure why, on my system, every time I reboot, the default printer switches back to "AlphaFivePrinterV4p5 (redirected 2)" which does not have a NUL port.
                        Applying Michael's solution, I now make "AlphaFivePrinterV4p5" the default printer because it has a NUL port

                        Comment


                        • #42
                          Re: Can not create PDF

                          Originally posted by barry685 View Post
                          I uninstalled both v10 and V11 removed the amuni pdf drivers from the control panel. Rebooted reinstalled only V11 and still does not work. It does create a 0 byte file with a pdf extension though.
                          Check and see if these files are in your a5V11\AmyuniV4 or a5V11 Runtime\AmyuniV4 directory.

                          cdintf.dll
                          pdfcreactivex.dll
                          acpdfcrext.dll

                          The installers for the build of both the developer and runtime I have are missing these files. I had to grab them from the V10.5 directory in order to get V11 to register the files.

                          Just saw you fixed it another way.

                          Comment


                          • #43
                            Re: Can not create PDF

                            I too fixed my issue by removing the printers and then reinstalling Alpha Five App Server

                            Comment


                            • #44
                              Re: Can not create PDF

                              All of a sudden I am having similar issues to those reported above.

                              My error message is "PDF Cannot be created" but the error message only occurs when I use the XBasic:

                              :Report.SaveAs("Proforma Invoice","PDF",query.filter,query.order,my_file,.F.)

                              my_file is a variable which holds the path and filename of where the report is to be saved, this has worked perfectly since I upgraded to V11 sometime last year but has stopped working over the Christmas break?

                              I have other reports that used to be saved with similar code as shown above but they have also stopped working.

                              Another error message I have received today was: "Printer not activated Error Code -30". But this seems to have dissapeared now.

                              If I view the report then manually save it as a PDF it works??? It just seems to be the XBasic that is causing the issue, however this code hasn't changed and it used to work fine before Christmas?

                              OS is: Windows Vista Ultimate 32 bit.

                              I have tried re-installing both the AlphaFivePrinterV4p5 and Amyuni Document Converter drivers and tried the solutions above although for some reason note the printer port being used is not NUL: but LPT1: (we don't use LPT1: for any other printers - Nul: is being used by One Note)

                              cdintf.dll
                              pdfcreactivex.dll
                              acpdfcrext.dll

                              I have only the top file shown in the list above supplied by preston2 in this thread but I am not sure where to obtain these other files from (I have tried re-installing Alpha 5 V11 but this does not create the other two files?).

                              Also, I am using this software on a standalone pc not on a network, can anyone suggest anything else?

                              Thanks for any help!!!
                              Last edited by Alastair; 01-02-2014, 12:28 PM. Reason: Further info added

                              Comment


                              • #45
                                Re: Can not create PDF

                                yes - delete the one note printer - and then go to the printer properties of alpha and set to nul port
                                Cole Custom Programming - Terrell, Texas
                                972 524 8714
                                martin_w_cole@msn.com

                                ____________________
                                "A young man who is not liberal has no heart, but an old man who is not conservative has no mind." GB Shaw

                                Comment

                                Working...
                                X