Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

List View Control and Record Number Past End of Table

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • List View Control and Record Number Past End of Table

    The documentation for the List View Control action script is complete as far as creating the list view control is concerned but that's where it stops. There is nothing which indicates how to fetch the record. I tried using the Goto Record Number and used all three of the variables; the one I created for the text box , the one I created for the List View Control and the one which Alpha created, varC_result, which I believe is the one which is supposed to be used.

    If I specify a record number, i.e. 33, It will go to record 33. If I try to specify an expression, the genie gives an error message when I try to select a field: "Alpha Five cannot display field names because there is no table open in this session". If I specify a variable, the same error message, Record Number is Past End of Table, appears no matter which variable I select. There are not only over 400 records but they show in the List View Control.

    I'm wondering if there is an error in the List View action script because of the table not open error message. Is anyone else having the same problem?
    TYVM :) kenn

    Knowing what you can achieve will not become reality until you imagine and explore.

  • #2
    Re: List View Control and Record Number Past End of Table

    Are you wanting the list view to simply show a list from a table that is a child in a set? EG your text box is the main record and the list is the children
    -----------------------------------------------
    Regards
    Mark Pearson
    [email protected]
    Youtube channel
    Website

    Comment


    • #3
      Re: List View Control and Record Number Past End of Table

      Originally posted by Clunes View Post
      Are you wanting the list view to simply show a list from a table that is a child in a set? EG your text box is the main record and the list is the children
      Hi Mark,

      No, both the text box and the list view are based on the parent table. It has to be that way or there's no point in the search. The list view shows a list of names and the text box searches the list. This is a progressive search so as the name is typed, the list dwindles until the name comes into view or there's only one left standing. Listview with Progressive Lookup in the documentation details the Listview. So, if you create the listview, goto record is still needed. Create a goto record and see if you run into the same problem as I.

      Appreciate it.
      TYVM :) kenn

      Knowing what you can achieve will not become reality until you imagine and explore.

      Comment


      • #4
        Re: List View Control and Record Number Past End of Table

        Have you seen how it is done on the 'Learn xdialog demo' db that comes with alpha. I use this a lot. Basically you need to create an argument that is set based on the textbox variable. Then in the filter to the xdialog you need to base it on the argument. If I wanted to have a list view search based on one field in the the table the filter would be Field=argument. If I wanted to base the serach on more than one table field I use argument$filed1.or.argument$field2 etc
        -----------------------------------------------
        Regards
        Mark Pearson
        [email protected]
        Youtube channel
        Website

        Comment


        • #5
          Re: List View Control and Record Number Past End of Table

          There are two parts to the code. The first part is the Listview with Progressive Lookup which works great. The second part is the action script "Goto Record" which does not work. There are two forms, form1 which has the button and from2 which is opened in the Goto Record action script. Creating the Goto action script is pretty simple. In the first part, 'another' form must be chosen (Form2) and in the 2nd part there are 4 choices. In order to get the record which I searched for, the VarC_result variable, which was created by Alpha, must be chosen. When the script is run, it can't find the form (form2) which was chosen in the first part. So, Form2 is there. It's the code generated by the action script, Goto Record.

          I did look through the xdialog demos but I did not see anything connected with the Listview with Progressive Lookup which explains or shows about fetching or going to the record for which I searched. Do you use this action script or what code do you use to go to the record?
          TYVM :) kenn

          Knowing what you can achieve will not become reality until you imagine and explore.

          Comment


          • #6
            Re: List View Control and Record Number Past End of Table

            Ok, I think I know what you want. This may be a variable scope issue for the list view. I assume you have a return field. It needs to be global, so that it can move to and find the record on the next form. I do this a lot, but always convert xbasic. As you are using the progressive lookup, it does not close the table when you load the listview. You need to add a table.close().

            I rarely use the progressive as this problem is not in the other style. Progressive is needed when the table is so large, a normal lookup table will run out of memory and then hang.

            If you convert to xbasic and code to the ok button, you can put the close there. If you use action script, I dont think you can do this and you may get errors. Also if you convert you can also blank the listview variable as if it is global, you get the later problem of it being there when you reopen to search again.
            -----------------------------------------------
            Regards
            Mark Pearson
            [email protected]
            Youtube channel
            Website

            Comment


            • #7
              Re: List View Control and Record Number Past End of Table

              Kenn,

              Check this screencast.

              Later: the example uses variables dimensioned as GLOBAL. That's not necessary. The var populated by the xdialog listview control can be LOCAL and the example works just fine. I recommend using LOCAL vars where possible, and they're possible here. -- tom
              Last edited by Tom Cone Jr; 09-16-2012, 10:04 AM. Reason: supplement with new information

              Comment


              • #8
                Re: List View Control and Record Number Past End of Table

                Hi Tom,

                Thank you very much. I was using the AS Goto Record vs Find by Key although I don't see where that makes any difference. My Listview Control dialong has one extra step in that it's a progressive lookup. I followed Alpha's documentation to the "T" and it works just fine. However, when it comes to setting the index and the FbK, I get a different popup than what's in your video. Your's says 'Current Form or Browse and the box is not greyed out. Mine says 'Another form or browse and it's greyed out. I have to choose the form and I think that's why I get the error message which says the form I chose can't be found. I have the last patches so have no idea why our popups are different.

                Any thoughts on that? Thanks again.

                UPDATE:

                The Action Scripts worked as they're supposed to work so either there is a bug in the last few patches or there is a bug in my app.
                Last edited by forskare; 09-17-2012, 02:40 PM. Reason: UPDATE:
                TYVM :) kenn

                Knowing what you can achieve will not become reality until you imagine and explore.

                Comment


                • #9
                  Re: List View Control and Record Number Past End of Table

                  Ken,
                  I don't know if this will be of any help, but look at this thread HERE on List Control progressive lookup.
                  Mike W
                  __________________________
                  "I rebel in at least small things to express to the world that I have not completely surrendered"

                  Comment


                  • #10
                    Re: List View Control and Record Number Past End of Table

                    Hi Mike,

                    Thank you for the suggestion. I've been updating each time new patches are released and now the action script is behaving as it should, which is a big help. I looked at the prog-lookup you posted. It goes to show how varied A5 can be for a Prog-lookup. I will hang on to this one for future reference.

                    Thanks again for your time.
                    TYVM :) kenn

                    Knowing what you can achieve will not become reality until you imagine and explore.

                    Comment

                    Working...
                    X