Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

grand totals not working in design, but OK in report-

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • grand totals not working in design, but OK in report-

    Hi Everyone,

    We have been working all day on a report for a medical office that lists all the lab tests they do, with the amount billed and total paid on each. We then tried to total the amount billed and amount paid columns for all the tests. We could not get the calculated fields to work--in the expression builder it gave us an error that the expression was incomplete or invalid. When we tried it on a laptop that we use (with a backup from the desktop) it worked fine and accepted the calculation. We noticed that the laptop said it was Ver 11 build 3177. So, we decided to update the desktop, thinking that might be the problem. When we updated it, we got build 3044--which seemed wierd since the desktop back up was more current and the build # was lower.

    After the update, on the desktop, when we make the grand total calculated field by adding all the individual calculated fields of the charges, it still says invalid or incomplete expression(even after the first field is entered). But if we put this "bad" calculated field onto the report--it runs the calculation correctly! We copied the report from the laptop and put it on the desktop and when we go into the calculated field editor it still gives the error. The laptop accepts the equation, but does not give a correct value until the report runs( which I understand because it is based on prior calculations that need to be run first). But by accepting the calculation we knew we could try the formiula. We spent hours trying to figure out what we were doing wrong with the calculation--it was just simple addition--when we were actually doing it correctly.

    Can someone look into this?

  • #2
    Re: grand totals not working in design, but OK in report-

    Unless you send your database, there is no way anyone can help you. You're likely just lucky it ran on the report.
    Cole Custom Programming - Terrell, Texas
    972 524 8714
    [email protected]

    ____________________
    "A young man who is not liberal has no heart, but an old man who is not conservative has no mind." GB Shaw

    Comment


    • #3
      Re: grand totals not working in design, but OK in report-

      Debra, perhaps the expression builder is having trouble because you are summing calc fields which have not yet been evaluated? I suggest you restate the grand total calc value without referencing other calc values. i.e. drop your amount billed and total paid fields into the report footer (one at a time) and let Alpha build the grand total calc value expressions for you.
      Last edited by Tom Cone Jr; 01-21-2013, 08:06 AM.

      Comment


      • #4
        Re: grand totals not working in design, but OK in report-

        Hi Guys, I noticed this sometime back after upgrading to v11. Works ok in v10.
        see pic attached.
        ExpressionCalc.jpgSame expression, same calc fields v11 for some reason says "Invalid or incomplete expression" ?

        Comment


        • #5
          Re: grand totals not working in design, but OK in report-

          How did you solve this ?

          Comment


          • #6
            Re: grand totals not working in design, but OK in report-

            Harrison, I can't answer the question for them, but others have found it helpful to reduce the final calculation to its lowest terms. Try building it without referencing other CALC fields. Instead, replace each CALC field with its own expression.

            Comment


            • #7
              Re: grand totals not working in design, but OK in report-

              Tom
              I am using a calculated field to subtract the difference from next row. Then I want to show a running total beside.
              Attached Files

              Comment


              • #8
                Re: grand totals not working in design, but OK in report-

                Its not clear to me why you've selected this old thread to present your problem.

                1) Have you tried what others have found to be helpful?

                2) If not, give it a go.

                If you still have trouble refer to post #2 in this thread. OK?

                Comment

                Working...
                X