Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Layout has no pages

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Layout has no pages

    Just converted from A5V5 (yes, I know) to V11.

    Works except for some confusing issues. The main concern seems to be speed. Old one was very fast. This one is pretty sluggish.

    Anyway..major concern. SOME records when I try to print them throws and error 'Layout Has No Pages'. Record looks fine. If I go to MOST other records it prints fine. Printing a LAYOUT here. Why should SOME records give this error and MOST others don't. Very peculiar.

    Anyone have ideas?

    And, yes I did look through the rest of the submissions but I didn't find anything quite like this.

    Thanks.

  • #2
    Re: Layout has no pages

    SOME records when I try to print them throws
    Not sure what method, action script or code, you are using. In either case I suggest you redo this in V11.

    There are some differences
    There can be only one.

    Comment


    • #3
      Re: Layout has no pages

      It's a button with an action script that prints a report layout for 'this record only'. I'm confused because it works with almost ALL the records except a few. Trying to narrow it down a little and I am running V11 now. V5 served well for the time it was released until now. I think that's amazing.

      Comment


      • #4
        Re: Layout has no pages

        Recreate the action scropt and see what happens.

        V5 was doing everything I needed except run under new windows versions.
        There can be only one.

        Comment


        • #5
          Re: Layout has no pages

          Problem narrowed to indexes. I noticed that some entries did not have the associated child records. So I rebuilt all the indexes and the child records and the print problem (Layout has no pages) goes away. Makes sense. This, though has happened again! Rebuilt the indexes and viola--all is well. Now the question is why are the indexes being corrupted?

          Comment


          • #6
            Re: Layout has no pages

            Are you using filtered indexes? They've often given problems.
            There can be only one.

            Comment


            • #7
              Re: Layout has no pages

              I do have a range set for the SET but not beyond that. BTW, this only started happening after porting from V5 to V11. Maybe something to do with that. Maybe--Maybe there's someone on the network that still has a V5 running? Not sure that would do it--but possible.

              Comment


              • #8
                Re: Layout has no pages

                Possible, also recommended to have every installation patched to the same build.
                There can be only one.

                Comment


                • #9
                  Re: Layout has no pages

                  After some time under the belt for Version 11, I have a nagging problem. The indexes seem to get out of whack and I have to rebuild. This manifests itself by missing child records. Rebuilding the indexes usually takes care of the problem. But when the client looks at a record and the child database is not showing the items, the client dutifully REENTERS the items. After rebuild--BOTH entries show resulting in a doubling of the items.

                  This is very strange. Any ideas?

                  Comment


                  • #10
                    Re: Layout has no pages

                    Dennis,

                    Indexes are substantially more stable since V8. As mentioned before, filtered indexes are still problematic in a heavily used database. The advice for curing index issues these days is making sure the network is in top shape.

                    I do have a range set for the SET
                    Not a clue what that means. If it performs some sort of filtering I would suggest you try removing it and perform the filtering in any form built on the set.
                    There can be only one.

                    Comment

                    Working...
                    X