Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Xbasic autocomplete & relative addressing issues.... (autocomplete does not work)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Xbasic autocomplete & relative addressing issues.... (autocomplete does not work)

    Coding in Xbasic & autocomplete does not work when you're using relative object addressing (topparent, this, etc.) ~ So the only way to use autocomplete is to first code using the object's names, and then replace them with the relative address such as topparent, etc.....

    example:

    Code:
    topparent.fetch_first() 'the autocomplete list (that should appear to select methods) does not appear until you get to the parenthesis
    This is frustrating. ~ Any workarounds?
    Last edited by SNusa; 02-24-2013, 03:16 PM.
    Robert T. ~ "I enjoy manipulating data... just not my data."
    It's all about the "framework." (I suppose an "a5-induced" hard drive crash is now in order?)
    RELOADED: My current posting activity here merely represents a "Momentary Lapse Of Reason."

  • #2
    Re: Xbasic autocomplete & relative addressing issues.... (autocomplete does not work

    Sorry to say Robert, but it works in V10
    I checked again to make sure. I Don't use V11
    Anyone else with 11?

    My correction - as you say, with Fetch_first() in particular it doesn't work here either!
    I just checked for predictive generally, most others seem to work.
    Last edited by Ray in Capetown; 02-24-2013, 05:08 PM. Reason: My correction

    Comment


    • #3
      Re: Xbasic autocomplete & relative addressing issues.... (autocomplete does not work

      Originally posted by Ray in Capetown View Post
      Sorry to say Robert, but it works in V10
      I checked again to make sure. I Don't use V11
      Anyone else with 11?

      My correction - as you say, with Fetch_first() in particular it doesn't work here either!
      I just checked for predictive generally, most others seem to work.
      There has to be something really wrong with the way it is implemented. I had so many problems using it it was almost useless at times. One would think that the relative address would be resolved where it is being coded, and then all (most of the methods at least) would populate the bubble. This doesn't happen with any predictable regularity. ~ On many occasions, I don't get any list (or bubble) whatsoever.
      Robert T. ~ "I enjoy manipulating data... just not my data."
      It's all about the "framework." (I suppose an "a5-induced" hard drive crash is now in order?)
      RELOADED: My current posting activity here merely represents a "Momentary Lapse Of Reason."

      Comment


      • #4
        Re: Xbasic autocomplete & relative addressing issues.... (autocomplete does not work

        True
        keep help open.

        Comment


        • #5
          Re: Xbasic autocomplete & relative addressing issues.... (autocomplete does not work

          Originally posted by Ray in Capetown View Post
          True
          keep help open.
          Very frustrating. (Problems like this make it so much more difficult, unless you are at the point where you can "code with your eyes shut.") ~ And when I encounter obstacles like this, they lead me to believe Alpha has little interest in "capturing" new users. I just don't get it"..... I know how to code Xbasic, but things like this make it much more difficult than it should be. AAARRRRggghhh!
          Robert T. ~ "I enjoy manipulating data... just not my data."
          It's all about the "framework." (I suppose an "a5-induced" hard drive crash is now in order?)
          RELOADED: My current posting activity here merely represents a "Momentary Lapse Of Reason."

          Comment

          Working...
          X