Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Strange Control Browse Issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Strange Control Browse Issue

    My application has a shipping queue that shows the warehouse staff what orders need to be shipped.

    Once the Fedex tracking label is printed the user types in the shipping cost and FedEx tracking number then presses the shipped button.

    The shipped button then adds todays date, saves the record, then refreshes the filtered control browse.

    However when the list of records becomes longer and the user needs to scroll down the browse to find and update a record, after pressing "shipped" the browse selects a different record then continues with the script.

    This same issue of selecting the wrong record also occurs when the user updates the record then clicks on the row selector.

    Here is an example of the issue. I entered in a fake tracking number for Interaction 150768, then clicked on the row selector for the same row. The browse then highlighted Interaction 146537.

    Capture.PNG

    I can't seem to find any reason for this to happen.

    Any ideas?

    #2
    Re: Strange Control Browse Issue

    There have been issues with long browse data changes.
    You might be better off having a new form pop up on dblclick from the browse to manage changes.
    See our Hybrid Option here;
    https://hybridapps.example-software.com/


    We are the
    Department of Sunshine and Rainbows!

    Hope restored, faith renewed, spirits lifted!

    Comment


      #3
      Re: Strange Control Browse Issue

      I think you might be right Ted.

      Thanks for the reply.

      Comment


        #4
        Re: Strange Control Browse Issue

        Hi Melvin,
        It looks like you have enough room on the form above the browse to add a search box. For this many records it might be easier for your users to type in the number they want to find and query the records so only the one record shows for editing. Then on save release the filter with a topparent.show_all() - which is just another idea. Other than that you might check your indexes and/or let us see your script!
        Robin

        Discernment is not needed in things that differ, but in those things that appear to be the same. - Miles Sanford

        Comment


          #5
          Re: Strange Control Browse Issue

          I've noticed that this issue of selecting the wrong record also occurs while making changes to fields directly in the table default browse.

          When I go directly into a table, update a record, then try to select the record directly above it Alpha five automatically jumps to a different record.

          Could this be an Alpha Five issue?

          Comment


            #6
            Re: Strange Control Browse Issue

            This is similar to many reported user experiences with interactive browses.
            Its kind of known about (I don't mean acceptable)

            but often manageable if you have the need. Some methods I have used to tame..

            causes could be;
            Certain OnRow... activity and especially event/events if you use them.
            Table or Form wide calculated fields.
            These may scroll the underlying table and not always re-position the browse. Especially when it is a scrollable browse (ie not all rows fit in the frame)

            try some functions including
            Get_Viewport_Row()
            topparent.Resynch()
            Scroll_Current_Row(cr)

            24 May 2013 Raymond Lyons suggested in a post
            "Have you tried <OBJECT>.REFRESH_FIELDS() ? Or <OBJECT>.REFRESH_LAYOUT() with the object being the name of the form?"

            Comment


              #7
              Re: Strange Control Browse Issue

              Melvin,

              which build are you using? They did some work on the browse control in March this year.

              Comment


                #8
                Re: Strange Control Browse Issue

                Thanks Ray...I'll try some of your suggestions.

                Hi Tom...I'm using V11 Build 3381. I seem to have the latest updates installed.

                Comment


                  #9
                  Re: Strange Control Browse Issue

                  Melvin, I agree, you're using the latest.

                  Tell us about the set supporting your form.

                  Also, do you see the same behavior in the AlphaSports sample?

                  -- tom

                  Comment


                    #10
                    Re: Strange Control Browse Issue

                    Tom

                    Yeah...The issue occurs in the AlphaSports sample.

                    If I go into the product table, scroll down to Product ID PO78, change the Cost field value, then with my mouse click on the Cost field for Product ID PO77 Alpha jumps to PO51.

                    If I then scroll back down to PO78, change the Cost field value again, then with my mouse click on the Cost field for PO79 Alpha jumps to PO105.

                    The issue also occurs in the parts section of the Invoice form.

                    Comment


                      #11
                      Re: Strange Control Browse Issue

                      Thanks, Melvin,

                      I've submitted a formal bug report and will let you know what I hear.

                      -- tom

                      Comment


                        #12
                        Re: Strange Control Browse Issue

                        Thanks for your help Tom!

                        Comment


                          #13
                          Re: Strange Control Browse Issue

                          Hi Tom,

                          I am also having this problem - and it is causing my employees to make mistakes on data entry if they are not very, very careful. Have you heard anything back from Alpha on this bug?

                          Regards,
                          Gordon

                          Comment


                            #14
                            Re: Strange Control Browse Issue

                            My experience -
                            Also use the browse for editing data and encountered the same problem with build 3462.
                            Could select record to edit but after saving the cursor jumped to another record. So could not edit and save consecutive records.
                            Using the up and down arrows (instead of mouse) worked to overcome this problem.
                            Reported bug at end of April and reply was that it was corrected BUT I am using the PRE-RELEASE build since then (now 3579) and the problem has gone away.
                            Stan

                            Comment


                              #15
                              Re: Strange Control Browse Issue

                              Me too. The prerelease build seems to fix this.

                              Comment

                              Working...
                              X