Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Working Preview / Grid on Desktop broken on Windows 8.1 / IE 11

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Working Preview / Grid on Desktop broken on Windows 8.1 / IE 11

    As soon as a grid 'goes dirty' in Working Preview or on the desktop when running Windows 8.1 & IE 11 I get an 'access is denied' error from Alpha (see attached).
    Running latest version of V11 - 3381/4096
    No problems on Win 7 or Win 8 with IE 10

    Have tried:

    turning off UAC in Windows
    turning off protected mode in IE
    adding a5res://a5wobject/ to local zone with 'low' security level
    running A5 as adminstrator
    running A5 in compatibility mode

    Other posts suggest problem also occurs with AA - you have been warned!
    Attached Files

  • #2
    Re: Working Preview / Grid on Desktop broken on Windows 8.1 / IE 11

    Jon, you might want to report this as a bug.
    IE10 has caused me problems with V11 and Google Maps, so it might well be an issue with IE11 not playing nicely with Alpha.
    There will be no fixes in V11 if that's the case.
    See our Hybrid Option here;
    https://hybridapps.example-software.com/

    Comment


    • #3
      Re: Working Preview / Grid on Desktop broken on Windows 8.1 / IE 11

      Ted, not much point in reporting it if there's not going to be a fix.

      Having spent several dozen hours converting browses to grids to circumvent a problem with a 'bouncing' cursor I now find that I and my users will never be able to implement Windows 8.1/IE11 unless I spend several hundred pounds (with an ongoing monthly outlay) purchasing AA and then going through the pain of a thorough test on the new platform.

      I suppose Alpha will say that A5V11 still works on vanilla windows 8 so that's allright :-(

      Comment


      • #4
        Re: Working Preview / Grid on Desktop broken on Windows 8.1 / IE 11

        Send me a simple example if poss.
        I need a diversion having been involved with some business crapola!
        See our Hybrid Option here;
        https://hybridapps.example-software.com/

        Comment


        • #5
          Re: Working Preview / Grid on Desktop broken on Windows 8.1 / IE 11

          Ted, if you've got Windows 8.1 / IE 11 then just try updating any grid in Working Preview or in a desktop application. I suspect the problem is IE11, but as far as I know it's not out in the wild except for 8.1.

          I'm trying to download a trial of AA at present to see if it has the same problem.

          Comment


          • #6
            Re: Working Preview / Grid on Desktop broken on Windows 8.1 / IE 11

            Yep - same problem in AA with Win 8.1 and IE 11.

            Comment


            • #7
              Re: Working Preview / Grid on Desktop broken on Windows 8.1 / IE 11

              Bu66er!
              I was going to have a pop at the bouncing cursor in V11, Jon.
              NFI in Win 8 at the mo.
              Worth posting a bug report now though!
              See our Hybrid Option here;
              https://hybridapps.example-software.com/

              Comment


              • #8
                Re: Working Preview / Grid on Desktop broken on Windows 8.1 / IE 11

                I reported an issue with the absolute positioning feature that is broken by IE 11 and Selwyn found the solution was to have Alpha run the activex control in IE 8 compatibility mode. It should be in the next prerelease of Alpha Anywhere. Perhaps they will release the same patch to fix this issue in V 11 desktop and working preview. By the way the problem is not windows 8.1 but IE 11 as I had the same problem in windows 7 running the preview release of IE 11.
                Brad Weaver, President
                ComputerAid International
                Ottawa ON Canada
                Versailles KY USA
                www.compuaid.com

                Comment


                • #9
                  Re: Working Preview / Grid on Desktop broken on Windows 8.1 / IE 11

                  Brad, thanks for the update - a step closer to determining the cause. I have already instructed all my users (who are on Windows 7) to not install IE11 as I suspected it was the culprit in this instance.

                  My warning was aimed at anybody thinking of upgrading to Windows 8.1 as IE11 is the only option at that level.

                  While I'm here, I tested the Alpha Sports Web Demo app and it showed the same error.

                  Comment


                  • #10
                    Re: Working Preview / Grid on Desktop broken on Windows 8.1 / IE 11

                    I have just tested the Web Application Demo that ships with V12 on a VM with Windows 8.1 and IE 11, and the only error I ran into was an issue with tree navigator, and in this case it appears that IE 11 was better about detecting & reporting some malformed JSON data (other installations parsed what could be parsed and continued).

                    All the other web pages I ran, included row-expanders, charting and html reporting all worked in working preview.

                    I am curious if this might be a permissions issue - either during installation, or at runtime. If the issue is runtime permissions, running Alpha5 under an Administrator account would cause the problem to go away. If the issue is installation (registering a5res protocol for the first time), then re-installing Alpha5 as Administrator might address the problem.

                    Comment


                    • #11
                      Re: Working Preview / Grid on Desktop broken on Windows 8.1 / IE 11

                      Cian,

                      I'm sure this is a permission issue, but I have tried running/installing as Administrator and the problem doesn't go away. Did you actually try to modify a row in working preview?

                      Comment


                      • #12
                        Re: Working Preview / Grid on Desktop broken on Windows 8.1 / IE 11

                        Hi Jon,

                        I did go back and create a editable grid & change & entered records on the windows 8.1 box - I am running with the most recent updates, which included a patch to IE 11, so that may account for a difference in behavior.

                        I think we have a couple other developers using windows 8.1 - so I will ask about this (since I am running under a VM to test windows 8.1, it might not be an exact comparison).

                        Comment


                        • #13
                          Re: Working Preview / Grid on Desktop broken on Windows 8.1 / IE 11

                          Just ran Windows Update & installed all possible updates - same problem still. This appears to be the same/similar problem to the following 3 threads:

                          http://msgboard.alphasoftware.com/al...orking-Preview
                          http://msgboard.alphasoftware.com/al...-preview-error
                          http://msgboard.alphasoftware.com/al...ew-not-working

                          Comment


                          • #14
                            Re: Working Preview / Grid on Desktop broken on Windows 8.1 / IE 11

                            Hi Jon,

                            I am wondering if the problem is not IE, but our activex control - if you run this in the interactive window:

                            dim ce as ole::a5contexteval.contexteval.12

                            Does an ole variable get created, or do you get an error?

                            It also might be the security level (I did not modify any settings except the one to allow external debugging of javascript) - maybe I need to configure my browser to match your settings.

                            Comment


                            • #15
                              Re: Working Preview / Grid on Desktop broken on Windows 8.1 / IE 11

                              Cian, variable successfully created.

                              I've reset IE to default settings - several things changed trying to fix this problem (see post 1), but was using vanilla setting when problem first occurred.

                              Comment

                              Working...
                              X