Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

emailed pictures in report do not show

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • emailed pictures in report do not show

    This automatic email systems works very well untill I added related pictures to the report.
    The report shows the images correctly.
    The test file in the C drive shows the images correctly.
    The recipient of the report, gets the report correctly, but the picturs are not showing, just an empty box.
    The report is inside the email, not attached. As you can see in the following script.

    Is there a reason why this happens?

    code:
    Dim tbl2 as P
    tbl2 = table.open("t_emailadd")
    tbl2.fetch_first()
    dim message as C
    while .not.tbl2.fetch_eof()
    param_to = trim(tbl2.Email)
    ' param_subject = "Submission Confirmation"
    ' param_cc = ""
    ' param_bcc = "xyc@gmail.com"
    ' param_msg = msg_text
    query.filter = "customer = "+quote(tbl2.customer)
    query.order = "recno()"
    :Report.SaveAs("EmailGrpSubmission", "HTML", query.filter, query.order, "c:\test.htm", .F.)
    wait_until(.F., 5, 5)
    if file.exists("c:\test.htm") then
    message = file.to_string("c:\test.htm")
    end if
    email_send(param_to, "Submission Report",message, "", "", "", .F., "HTML")
    tbl2.fetch_next()
    end while
    tbl2.close()

  • #2
    Re: emailed pictures in report do not show

    Many emails I receive with pictures in the body, do have the picture(s) as an attachment.
    Robin

    Discernment is not needed in things that differ, but in those things that appear to be the same. - Miles Sanford

    Comment


    • #3
      Re: emailed pictures in report do not show

      When I use the Alpha aurtoemail system, it uses part of a report that matches the email in the report. the report contains data and I added to the report a corresponding picture(jpg1024x780) that image shows in each line of the report.
      The report still works well, just do not show the pictures when sended.
      I do not think the report will add the jpgs as attatchments.
      Any other suggestions?

      Comment


      • #4
        Re: emailed pictures in report do not show

        Is there a reason why this happens?
        You are using the html report option. That means the jpg references are dynamic. If you look at one of the output files you willl notice it is relatively small. The pictures in the report are merely references to the location of the image placed on the report.

        If you save as pdf rather than html then the images will be incorporated in the pdf file and saved with it.
        There can be only one.

        Comment


        • #5
          Re: emailed pictures in report do not show

          I was about to insert some thoughs along those lines.
          Stan you must be correct. I realize that the line message = file.to_string("c:\test.htm")
          must likely, only accepts text. So the images are not sent, I guess.
          In the present form text and images can not be sent.
          What about attachig the report, instead of placing the results in the body of the email?

          if file.exists("c:\test.htm") then
          attachment= file.to_string("c:\test.htm")
          email_send(param_to, "Submission Report","See Attached", "attachment", "", "", .F., "HTML")

          I did try above, but did say "file not found" . That was my simplistic concept.
          What could it be the right syntax?

          Comment


          • #6
            Re: emailed pictures in report do not show

            It has nothing to do with file.to_string("c:\test.htm").

            As suggested, look at one of your saved htm files. It should be much smaller than the image file size unless you have a very long report. Open that htm file in a browser. Right click on one of the images and choose Properties. For the address you should see something like

            file:///C:/some_directory/reportname_p0.jpg

            The html option is causing the report to create a local file reference instead of embedding the picture in the report.
            There can be only one.

            Comment


            • #7
              Re: emailed pictures in report do not show

              Correct That is what in the report for images properties -p0, p1, p2
              So is there a way to make sure those pictures get attached or shoul we send the report as an attachment?
              Which way is easier?

              Comment


              • #8
                Re: emailed pictures in report do not show

                You should send the report as a pdf.
                There can be only one.

                Comment


                • #9
                  Re: emailed pictures in report do not show

                  Thanks Stan, I did change the save to PDF and it did not send the images. Here are the lines I changed.

                  :Report.SaveAs("EmailGrpSubmission", "HTML", query.filter, query.order, "c:\test.pdf", .F.)
                  if file.exists("c:\test.pdf") then
                  message = file.to_string("c:\test.pdf")
                  By changing those lines to pdf, it does send the email and it looks good at the recipient, but no images, just the empty boxes appears, but the PDF file created, is not recognized by adobe.

                  If the suggestion is to send it as an attachment, how do I change the assigning parameter to go in the next " ", instead of embeded in the body of the email?

                  something like this?
                  attachment= file.to_string("c:\test.pdf")
                  email_send(param_to, "Submission Report","See Attached", "attachment", "", "", .F., "HTML")

                  Comment


                  • #10
                    Re: emailed pictures in report do not show

                    I send email via web interface and I am sure it is the same in desktop version.
                    normally
                    dim email as c and you will assign the value
                    dim emailMsg as p
                    emailMsg.message = <<%str%
                    please see attached
                    %str%
                    emailMsg.attachment = "c:\your_image_file_name.image_file_extension"
                    then emailsend2(.. etc)
                    it will attach the file and send it.
                    thanks for reading

                    gandhi

                    version 11 3381 - 4096
                    mysql backend
                    http://www.alphawebprogramming.blogspot.com
                    ggandhi344@gmail.com
                    Skype:ggandhi344@gmail.com
                    1 914 924 5171

                    Comment


                    • #11
                      Re: emailed pictures in report do not show

                      :Report.SaveAs("EmailGrpSubmission", "HTML", query.filter, query.order, "c:\test.pdf", .F.)
                      Really? You changed the extension for the file to be saved but didn't change the save as type!

                      :Report.SaveAs("EmailGrpSubmission", "PDF", query.filter, query.order, "c:\test.pdf", .F.)
                      There can be only one.

                      Comment


                      • #12
                        Re: emailed pictures in report do not show

                        Thanks for that correction. It did make the test.pdf recognizable by adobe, but it did not appeared in the email, when it was sent.
                        I got the in the body: %PDF-1.3%1 0 obj<</Title (

                        But I did changed the line:
                        email_send(param_to, "Submission Report","See Attached", "c:\test.pdf", "", "", .F., "HTML")

                        and I got the attachement in the email complete with images.
                        It would be great to include it the email body, but I could live with the solution of using an attachment.

                        Comment

                        Working...
                        X