Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

ui_email_settings() issue with V11

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ui_email_settings() issue with V11

    Just noticed today so I do not know how long it has been broken.

    But on my dev machine running wither the runtime or the developer I get this error when trying to run the ui_email_settings() function. Only happens on V11



    Anyone got a clue as to how to fix this? It seems to be an internal A5 problem. Could be something in the registry but it all looks good as far as I can tell.

  • #2
    Re: ui_email_settings() issue with V11

    Well, no replies so I guess no one else has ever run into this and I know Alpha will probably not enlighten me as to what is calling the script with vs_sr_email in it on line 15 or what that script is looking at as they no longer support V11.

    I have tried a total reinstall of A5V11 to no resolve so this leads me to believe it may be a registry issue or something in the users\user_name\AppData\Roaming\Alpha Software\Alpha Five Version 11 folder.

    When I get brave I may try deleting everything that has to do with A5V11 and then try to reinstall.

    Comment


    • #3
      Re: ui_email_settings() issue with V11

      Preston, what version of Windows? Have you tried running in compatibility mode?

      Comment


      • #4
        Re: ui_email_settings() issue with V11

        Windows 10 and it worked fine until a few weeks ago. Changing to compatibility mode does not resolve the issue either. Plus I have a lot of end users on Windows 10 running my app with V11 runtime not in compatibility mode and it works fine.

        If I click OK on the error message above I get this. Basically the email setup popup that is blank.

        Comment


        • #5
          Re: ui_email_settings() issue with V11

          Well, it was in the registry. I am not sure just what was messed up but I just renamed the key "email" to "email.hld" and then created a new blank key named "email".

          After that A5 V11 would open up the email settings just fine and I just re-entered all the email settings.

          It now works.

          Comment


          • #6
            Re: ui_email_settings() issue with V11

            Did you make the change directly with the Registry editor or make a new account in Alpha settings?

            Comment


            • #7
              Re: ui_email_settings() issue with V11

              Ray,

              I renamed the HKEY_CURRENT_USER/SOFTWARE/Alpha Software/Alpha Five 11.0/init/email to HKEY_CURRENT_USER/SOFTWARE/Alpha Software/Alpha Five 11.0/init/email.hld

              I then just created a new key HKEY_CURRENT_USER/SOFTWARE/Alpha Software/Alpha Five 11.0/init/email with nothing in it.

              Next I started up A5 V11 and ran the ui_email_settings() and it no longer error'ed out. The pop-up came up just fine with no email accounts in it. I then entered an email account and settings. A5 V11 then wrote that info to the new blank email registry key.

              I have not taken the time to compare the settings in the renamed email.hld key with the settings in the new email key to see if I could spot what was wrong or had gotten corrupted.

              Comment


              • #8
                Re: ui_email_settings() issue with V11

                Preston. When you reinstall Alpha, its advisable to clear out the registry.
                You have hit on good fix though.
                See our Hybrid Option here;
                https://hybridapps.example-software.com/

                Comment


                • #9
                  Re: ui_email_settings() issue with V11

                  Very clear. This will be useful to someone else sometime. Thanks for taking the time.

                  Comment


                  • #10
                    Re: ui_email_settings() issue with V11

                    Originally posted by Ted Giles View Post
                    Preston. When you reinstall Alpha, its advisable to clear out the registry.
                    Normally I would agree with you but when trying to diagnose a problem I have found it is always better to only change one thing at a time.

                    If I had deleted all registry info for V11 and then reinstalled it would have worked but I would not have known if the problem was a corrupt file or a specific registry entry.

                    As it stands now I know it was in the HKEY_CURRENT_USER/SOFTWARE/Alpha Software/Alpha Five 11.0/init/email key. When I get time I plan on tracking down just which entry under that key was the culprit.

                    Comment

                    Working...
                    X