Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Update/Index Issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Update/Index Issue

    Hi everyone

    I'm needing help on a weird issue.
    I have 9 identical tables linked as line item tables to a parent. I have a field rule for the "Unit_Price" field as follows:

    if(ITEM_NO="buyout",(PREVIOUS("Total_Price","__A5_Recor")*(QTY/100)),UNIT_PRICE)

    Where if the user picks the "buyout" item from a lookup table, it uses the "total_price" from the previous item in the table to determine the "total_price" for this line item as a percentage of the previous line item's "total_price"

    All works well in the child tables with the exception of tables 3 and 4, it leaves the "total_price" field blank.

    I also have this equation as an update operation which is on a button so if they make changes it will update the child tables, again all works well except tables 3 and 4. When the operation is run I get the error message "Error running update operation: Not an open Index"

    Again all 9 child tables are identical and the field rule and operations work fine for the other tables.

    I'm sure I'm missing something but for the life of me I can't see it.

    I would appreciate if someone could point me in the right direction

    Regards

  • #2
    Re: Update/Index Issue

    Suggestion 1.
    Copy one of the working tables over one of the non- working ones and see what happens.
    Suggestion 2.
    Check the linking is exactly the same in the set.

    Question. Why 9 linked tables all the same? Just curious.
    See our Hybrid Option here;
    https://hybridapps.example-software.com/

    Comment


    • #3
      Re: Update/Index Issue

      Hi Ted,

      The reason for the 9 identical tables is my customer uses it to do his quoting, he has 9 parts for each quote he makes. Seems a lot I know but that's how he wanted it to look.

      I've checked the set structure/linking and all is good.

      I haven't copied over the tables yet but that's my next move, thx for the suggestion.

      Strangely, table 3 seems to be working now, yet I haven't done anything to it (besides using harsh language!)

      Furthermore, when I check the expression in the field rule in table 4 it's giving me "Invalid or incomplete expression" but it's exactly the same expression in the other table's field rules.

      Comment


      • #4
        Re: Update/Index Issue

        OK so I've stepped into the Twilight Zone....

        In all the table's field rules the expression is:

        PREVIOUS("Total_Price","__A5_Recor")*(QTY/100)

        Which works except table 4

        I changed table 4 to read:

        PREVIOUS("Total_Price","__A5_Recno")*(QTY/100)

        And it works

        Can someone explain this to me?

        Regards,

        Comment


        • #5
          Re: Update/Index Issue

          If you change the expression to

          PREVIOUS("Total_Price","recno()")*(QTY/100)

          does it still work? If so I would change all to that.
          There can be only one.

          Comment


          • #6
            Re: Update/Index Issue

            You have encountered or are exploring the world of unprintable characters I suspect.
            The _ might well throw a wobbly as Stan noticed.
            See our Hybrid Option here;
            https://hybridapps.example-software.com/

            Comment


            • #7
              Re: Update/Index Issue

              Hi Guys,

              Making the changes Stan mentioned had no effect, but I checked a previous copy of the application and found tables 3 and 4 had the field rule expression:

              PREVIOUS("Total_Price","__A5_Record__")*(QTY/100)

              Now I know I'm not making these changes, nor is my customer, so the question now is how are these changes to the field rules happening?

              Also, in all of the other tables they have two indexes:
              Index name: Sales_or, Order Expression: Sales_or
              Index name: __A%_Recor, Order Expression: RECNO()

              In tables 3 and 4 the __A5_Recor index has disappeared.

              I'll admit, I'm no expert with alpha but I'm pretty sure indexes shouldn't just disappear nor should field rules change on their own so can someone explain what has happened?

              Thanks for your help

              Regards

              Keith

              Comment


              • #8
                Re: Update/Index Issue

                Could easily be an index issue.
                The rules are essentially 8 char for an index starting with a char in the name. The index names you mention are created by AS. Build your own.
                There is a finite number of indices with the same name which can be used.
                See our Hybrid Option here;
                https://hybridapps.example-software.com/

                Comment


                • #9
                  Re: Update/Index Issue

                  Possibly,
                  create your own index and do not rely on the alpha generated index. You may find life much simpler.
                  You can create an index with any name and base it on record number.
                  The one created by alpha is for their own internal use as I understand it.
                  Dave Mason
                  [email protected]
                  Skype is dave.mason46

                  Comment


                  • #10
                    Re: Update/Index Issue

                    Indexes generally disappear when the expression indexed and/or filter cannot be evaluated. Not sure what you mean by making the change I suggested had no effect. Did it work with that expression or not? If not create your own index with the expression recno(), name it, and use that in the lookup().

                    Some time in the past Alpha introduced a generically named index that replaced <record_number_order> which was the default. You are experiencing some issue related to that.
                    There can be only one.

                    Comment


                    • #11
                      Re: Update/Index Issue

                      Hi guys,

                      Thanks for the input from everyone, I was relying on alpha generating the record number indexes, when they disappeared on tables 3&4, everything went south. My bad for doing that. Proof again, I'm not the smartest person in the room...

                      Cheers

                      Comment


                      • #12
                        Re: Update/Index Issue

                        Looking at the documentation for previous() it would seem that you don't need to name the index in your implementation. You should only need to use that parameter if the current primary index has been set to something other than record number order for some reason. It is generally safer to include the index name parameter, of course, but optional.
                        There can be only one.

                        Comment


                        • #13
                          Re: Update/Index Issue

                          Hi Stan,

                          Thx for the input, I tried getting previous() to work without naming the index but it didn't work, probably because I'm using it on a child table in a set (?).

                          But of course I've come to more difficulties with this issue:

                          I deleted the alpha generated indexes __A5_RECOR, __A5_RECNO, and __A5_RECORD in all the tables and I created an index RecNum set to RECNO() as the expression, changed the field rules and the operations set to that index. All works great with the exception of table 4. For whatever reason table 4 did not have any of the alpha created indexes and would not allow me to create the RecNum index. I compacted the workspace a dozen times to no avail. Finally i copied the records from table 4 to a temp table, wiped table 4 clean compacted the workspace, created the RecNum index then moved all the records back into table 4 from the temp table. That finally worked. Whew!

                          Question is why would table 4 display such odd behavior being that all the tables are identical.

                          Again, thx for your help

                          Regards,

                          Comment


                          • #14
                            Re: Update/Index Issue

                            Generally garbage data would cause that. Maybe something from a copy-paste into a field that didn't get recreated with the empty and append.
                            There can be only one.

                            Comment

                            Working...
                            X