Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook



The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic

Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.

If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.

Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.

Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Users cannot see newly created tables.

  • Filter
  • Time
  • Show
Clear All
new posts

    Users cannot see newly created tables.

    I am totally confused. I have created a new table and a form to go with it. Confusingly, the other users cannot access the new form or even see the new table from the control panel on their PC's.

    My data is help on a server, with four PC's on the network. The users can see the new .dbf file on the server from their machines, but the table doesn't appear in their CP's - though it appear list in the CP on the PC I use, which is also where my Developer is.

    If I amend an existing form they see that amendment; they just don't see any new tables I create, or any new forms that utilize those new tables.

    I have tried using and then not using a shadow - to no avail.

    I have been creating/changing forms etc for years, so am I doing something stupid in my old age....

    Re: Users cannot see newly created tables.

    I had the issue, but was due to the shadows not up to date. Re-shadow took care of my issues.
    Does not sound like your case.
    Dave Mason
    [email protected]
    Skype is dave.mason46


      Re: Users cannot see newly created tables.

      1) Verify workstations are connecting directly to the database / workspace, over the LAN, without using shadow copies on their local machines.

      2) Verify new table lives in a folder on the server that's shared with the workstations. They will need read / write access to the new table. In the typical arrangement you'd create the new table in the same shared folder as your database, but I"ve seen cases where folks create tables in subfolders or even external folders.


        Re: Users cannot see newly created tables.

        I was coming back. Tom beat me to it.

        on the server add the table to the cp, if you see it is there, remove it first and then add it back. It may for some reason be seeing your local table for you because it is pathed to your machine?
        Dave Mason
        [email protected]
        Skype is dave.mason46


          Re: Users cannot see newly created tables.

          Thanks for the help. I can confirm that we stopped using shadows a few months ago. I can also confirm that the new dbf is in a folder along with all my other Alpha files - to which the workstations do have direct access. The users certainly have access to that folder and can see the new dbf file. However, I'm not sure if that means they read/write access to the new file. I will check.

          With regard to Dave's suggestion of removing then adding back the new file, I will do this at the office tomorrow - I am currently working remotely. In the meantime, many thanks for the help.


            Re: Users cannot see newly created tables.


            When a new table is "created" or "copied" to a database folder. The runtime users can't see it in the application until you "Add" it to the list of tables in your database. Has this been done ?

            What's the table name? Maybe you've chosen an illegal name ?


              Re: Users cannot see newly created tables.

              Hi Tom,

              The table was created from the CP. It's called 'menu_rep'. It only has one field and no records. I created it so that I could then add a new form with buttons on it, as a navigation form/menu form, if that makes sense


                Re: Users cannot see newly created tables.

                That's about the only way a table can be created. Doesn't tell you where the table was saved.

                Are you familiar with the detail view in the control panel? Switch to that and examine the full path.
                There can be only one.


                  Re: Users cannot see newly created tables.

                  Hi Stan,

                  Yes, my CP is always set to detail view, and I can confirm the new table is in the correct location and I can clearly see it in the Control Panel from my PC, either from Developer or Run time. However, the other three work stations cannot see the new table in their CP, although they can see the new dbf via Windows Explorer. Maybe it is an unexpected access issue as opposed to an Alpha issue - I shall explore this today.


                    Re: Users cannot see newly created tables.

                    We have now checked read/write access to files, and all users have access to the relevant files.

                    For the record, historically I have kept a copy of my Alpha data files in a sub folder to the current data folder. I also had a further sub folder to the copy, so that I have three sets. Each time I plan to make changes to my application, I copy the files down one level. However, I have just noted that my work stations appear to be seeing the older files - and dbf's - in the subfolder, EVEN THOUGH THE CP DETAIL POINTS TOWARDS THE CURRENT DATA.

                    I have therefore moved the sub folders to another location. On re-checking the work stations, their CP's are still listing dbf's I have recently deleted and they are not seeing dbf's I recently created. I also note that the dbf table icon has a query on it in the case of the deleted dbf's. Meanwhile, from my own PC, I see everything exactly as you would expect: the correct dbf's and no queries on the table icons.

                    I am slowly drawing the conclusion that I have been doing something wrong with Alpha/my network for ten years! However, I do think that the additional anomalies outlined above will surely point towards my error....


                      Re: Users cannot see newly created tables.

                      Could Alpha Run Times on my work stations be somehow looking at cache versions? I don't know how else it can see the db's which are no longer present, and not see the new ones.


                        Re: Users cannot see newly created tables.


                        there's a very easy way to quickly determine which database the runtimes are using.

                        Go to the control panel. Choose tables / sets tab. Right click open space in the cp. Choose View, then choose Details off the dropdown list. Check the Full Name column - it will show the physical path to the tables being used by the workstation. The physical path should match the path to your live database on the server, and I'm thinking it does not.


                          Re: Users cannot see newly created tables.

                          I think we may have overcome the problem - though not sure how. I moved the Alpha files to a new folder on the server. I then opened the application in the new folder and... it all worked perfectly on all of the work stations.

                          So I went back to the original folder, and six of the files had 're-appeared' including the .adb

                          I deleted the six files and then copied my full set of files back to this original folder, and all appears to be working fine.

                          There are definitely strange things happening since I upgraded my SBS six months or so ago. I cannot begin to explain why different PC's see different sets of files whilst looking at the same folder. But I am convinced that the six mysterious files had something to do with it, i.e. somehow I was running/referring to two different Alpha sessions.

                          Additionally, on re-installing the work station Run Times, they did NOT ask for a licence key. This could be as a result of upgrading the work stations to Win 7 a few months ago - I just don't know.

                          In conclusion, I am OK for now, and very grateful for the help and suggestions.

                          Kind regards,



                            Re: Users cannot see newly created tables.

                            Now that the dust has settled, I thought it might help to further summarise, as whilst we have found the problem, we definitely have not found the cause.

                            I can confirm 100% that all four workstation control panels were/are pointed at the same server folder, with the correct paths clearly stated in the control panel, but with tables missing on three workstations, i.e. my own PC, which also has my developer on it, has the full and correct table list, from Developer and from the Run Time. The other three workstations had tables missing - the newly created tables. (Though as I said earlier, they can all see the same data in explorer).

                            There are some supportive anomalies, i.e. about six months ago I deleted the desktop security groups and therefore I no longer had to login on startup. However, the other three workstations have still had to login ever since - even with the security deleted and their shadows updated; I force the shadow updates. Suddenly, this anomaly fits in...

                            A second example: if I added a button to a form and created a button push event to open a new form based on a new table, all users could see the new button, but on push they got "Form not found" - unless you used my PC Run Time in which case the button worked.

                            A further anomaly: when I moved all of the app files to a new directory yesterday, with Ctrl+a then Ctrl+x then Ctrl+v, they all pasted OK. However, on returning to the old folder, six files had copied back - I say 'copied' because those six files were definitely present in the new directory. This was not "a problem somewhere between the keyboard and the chair", as there was a witness to the entire action. The six files were the adb and five others of the same name but different extensions.

                            Finally, I have now moved the files back to where they came from, but have removed the two backup child folders - as this is the only thing I can think of as to why my app was definitely using different 'ages' of my app.

                            But the mystery remains...