Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Error Locking

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error Locking

    Having a problem with the error locking error popping up. I've tried packing, but get an error message that says it's "being used by another process", etc. There are no $$ files in my data file directory. I've tried copying backup files and using them, but to no avail. I've never had this problem reoccurring like this before. I copied the 3 files from the Code Archive that clean the indexes, the tables and the Registry and placed them into 3 separate functions I can run from the Control Panel. When I try running them, it looks like absolutely nothing is happening. No error messages or anything. Can't really tell if they are doing anything or not.

    My problem is that my people cannot enter any new records because of the error locking error. I checked some of the other posts but have found nothing useful that works as of yet. The worse thing is I have no idea what triggered this. It started yesterday. I currently have 8 people accessing the db across the network. No shadowing. Up until now, it has not been a problem. Any ideas are welcomed as to where to look and how to solve this problem. Going home now but will be back later tomorrow morning.

    Thanks for reading the post....

    Scott

  • #2
    Re: Error Locking

    . When I try running them, it looks like absolutely nothing is happening.
    They clean the windows registry of certain entries. Nothing would be visible in Alpha. If you want to see if they worked, look in the registry.
    There can be only one.

    Comment


    • #3
      Re: Error Locking

      Scott,
      Sounds like files have been left open?
      Suggest a complete restart on all computers and the server. Something looks like it did not get closed properly and this may reset it.
      Turn OFF all computers first
      restart the server unit
      restart the other computers.

      Need to find out what was left open, but this may get you going quicker.
      Dave Mason
      dave@aldadesktop.com
      Skype is dave.mason46

      Comment


      • #4
        Re: Error Locking

        Thanks Dave and Stan. Will try the restart of all computers and the server. When this happens, I do go to each computer and make sure that within the task manager, that there are no A5 processes running. Have come across that every once in a while. Thanks for the info Stan and the suggestion Dave.

        Comment


        • #5
          Re: Error Locking

          So I tried your suggestion Dave. No luck. I've tried restoring a backup from a week ago. It still will not let me pack the main table. The main table is very large, 101,000 records and about 125 fields in each record. When I try and pack the table, it goes through the complete process until the very end and then tells me "Cannot open table". If I try and open the table after that I get an error message letting me know it's in use by another process. All other computers are offline and there is nothing accessing the table as far as I can tell, but Alpha sure thinks there is. I checked in the file directory, and there are no temporary ($$) files. I'm thinking what I may have to do is append all records to a duplicate table and then rename it to the original. Wondering if that will work. Any input?

          Comment


          • #6
            Re: Error Locking

            The main table is very large
            There is a two gigabyte file size limit for dbf's. Doesn't sound like you would have hit that but you might check. Depends on the field definition widths.
            Last edited by Stan Mathews; 08-19-2016, 03:26 PM.
            There can be only one.

            Comment


            • #7
              Re: Error Locking

              I tried appending all records to a new table but it did not work. I then tried copying the records only to a new table and got the same result. The error message states: "An attempt was made to move the file pointer before the beginning of the file". I've never seen this error before. Any of the "masters" ever seen this before? Could my A5 developer possibly be corrupt and need to be reinstalled? Something is definitely corrupt somewhere.

              Comment


              • #8
                Re: Error Locking

                See above post.
                There can be only one.

                Comment


                • #9
                  Re: Error Locking

                  You know what Stan, it is just over that. Perhaps I should move some of the files to a new archive table and see if that works.

                  Comment


                  • #10
                    Re: Error Locking

                    Move some of the records, yes.

                    125 fields in one table would indicate to me that you have a lot of wide character fields and/or need to normalize the data and not keep everything in one table.
                    There can be only one.

                    Comment


                    • #11
                      Re: Error Locking

                      I moved some of the records and now it's down to just a little over a gig or so. I wonder if being over 2 gigs was the problem in the first place. I did not know about the size limit. As for wide fields, we do have just a few, probably 98% are less than 15 characters in length. This app has been in development for 19 years, since A5v4.5. Everything is actually not in one table. There are approximately 10 or 12 other tables linked to this one. We work in the legal industry and there is just a ton of info we have to input and track., plus it is also doing our billing. It's been a labor of love, and hate....lol. I have never liked any of the software available to our industry and many times our clients will request custom reports that could never be run from predetermined software, if you catch my drift. Thanks for the help. There was one file I noticed that I've never seen before. it had a $$M suffix. I know it's a temp file created, but do you know what from?

                      Comment


                      • #12
                        Re: Error Locking

                        Duplicate the table to a new name. Choose all options including records.

                        Also control panel, tables sets tab, right click the table name and look at the last tab for size.

                        From Windows, look at the size of all the files for the table.

                        Post images of those to this thread.
                        Al Buchholz
                        Bookwood Systems, LTD
                        Weekly QReportBuilder Webinars Thursday 1 pm CST

                        Occam's Razor - KISS
                        Normalize till it hurts - De-normalize till it works.
                        Advice offered and questions asked in the spirit of learning how to fish is better than someone giving you a fish.
                        When we triage a problem it is much easier to read sample systems than to read a mind.
                        "Make it as simple as possible, but not simpler."
                        Albert Einstein

                        http://www.iadn.com/images/media/iadn_member.png

                        Comment


                        • #13
                          Re: Error Locking

                          Originally posted by draxx2755 View Post
                          There was one file I noticed that I've never seen before. it had a $$M suffix. I know it's a temp file created, but do you know what from?
                          If I am not mistaken those are created when a query is run.

                          Attached is a function I got from Cal that you can call from your autoexe script and it will delete those so they do not keep piling up.
                          Attached Files

                          Comment


                          • #14
                            Re: Error Locking

                            Thanks Preston, I'll check it out. There is definitely some kind of problem because the table will not pack. I think I'll append the records only to a new table. Recreate all the indexes, then recreate the field rules. Then rename the old table and rename the new table to the old name and see if that clears things up. Our field rules are not complex or equations. The field rules are only simple lists to act as a drop down for my people to choose one of. Just a shortcut to aid in inputting data. Any thoughts on trying this?

                            Comment


                            • #15
                              Re: Error Locking

                              Originally posted by draxx2755 View Post
                              Thanks Preston, I'll check it out. There is definitely some kind of problem because the table will not pack.
                              Have you tried "Compacting the Workspace" instead of "Packing" the tables?

                              Comment

                              Working...
                              X