Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Object "nudge" Micro-Movement not working in v9?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Object "nudge" Micro-Movement not working in v9?

    In v8, I can select an object on a form and "nudge" it into place using the Micro-Movement key combination of control-arrow (up, down, left, right).

    This doesn't seem to work in v9. If anything, the object seems to move only "coarsely."

    Any others seeing this?

    Or can someone confirm that it does in fact work as expected?
    Last edited by fsi; 04-07-2008, 11:05 AM.

  • #2
    Re: Object "nudge" Micro-Movement not working in v9?

    try shift key

    Comment


    • #3
      Re: Object "nudge" Micro-Movement not working in v9?

      Damn. That's what I meant to say... SHIFT-arrow.

      And I was looking right at my SHIFT key when I typed the post!!!


      So, let me clarify.... can anyone confirm that the SHIFT-arrow method of nudging objects does work?

      geez.... why can't my brain and fingers just learn to get along?

      Comment


      • #4
        Re: Object "nudge" Micro-Movement not working in v9?

        Originally posted by fsi View Post
        Damn. That's what I meant to say... SHIFT-arrow.

        And I was looking right at my SHIFT key when I typed the post!!!


        So, let me clarify.... can anyone confirm that the SHIFT-arrow method of nudging objects does work?

        geez.... why can't my brain and fingers just learn to get along?
        works fine for me in v9

        http://screencast.com/t/OqOP4W0kTja

        Comment


        • #5
          Re: Object "nudge" Micro-Movement not working in v9?

          Thank you, Selwyn. When I try it, the hand icon appears and moves as expected (very small steps). But the object doesn't move - that is, until around five presses of the arrow key - at which point the object moves/jumps by a full (coarse) step.

          Is it possible I may have unknowingly turned off Micro-Movement someplace?

          Comment


          • #6
            Re: Object "nudge" Micro-Movement not working in v9?

            Originally posted by fsi View Post
            Thank you, Selwyn. When I try it, the hand icon appears and moves as expected (very small steps). But the object doesn't move - that is, until around five presses of the arrow key - at which point the object moves/jumps by a full (coarse) step.

            Is it possible I may have unknowingly turned off Micro-Movement someplace?
            I don't think so. there is no 'turn off' feature for micro movements

            What happens if you turn off 'snap to grid'?
            (Form/Grid menu)

            Comment


            • #7
              Re: Object "nudge" Micro-Movement not working in v9?

              No change in behavior after turning off snap-to-grid. Mouse icon changes to hand, hand moves in small steps with each arrow press, object remains stationary until around press #4-5, then jumps full increment.

              I guess if no one else has this problem, it's something I'll live with.

              Comment


              • #8
                Re: Object "nudge" Micro-Movement not working in v9?

                jon,

                I know this will happen when an object is not entirely or at least not mostly within view on a form and you try to reduce the object's size with control+left arrow. To make this work you have to move the object completely on the form. This may also happen with the shift-move you are having difficulty with.

                Is your object/field completely on the form? Even if so I have had similar cases that you have described. Usually all that is necessary is to unselect the object entirely (select another or...) then go back and select the wanted object again and try to move it...but also don't try to move it too far all at once--I usually try to move in 5 up to 10 increments or so--release and then move more if needed.
                Mike
                __________________________________________
                It is only when we forget all our learning that we begin to know.
                It's not what you look at that matters, it's what you see.
                Henry David Thoreau
                __________________________________________



                Comment


                • #9
                  Re: Object "nudge" Micro-Movement not working in v9?

                  Boy I too am having a hard time with the nudge feature in version 9. I checked to make sure that the snap to grid is turned off. I also noticed the hand moves in micro movements but looking at the grid, my actual fields seem to only move as if the snap to grid was turned on. I am selecting the field and the label. I am trying to move fields closer together vertically, the demo you referance is moving horizontal. Although it doesn't seem to really matter horizontal or verticle. It is also not consistant, sometimes I hold the shift key and then press the right arrow key, 2 key presses will get movement, another time it might be 5 key presses.

                  Sorry I'm lost, I had a sample form I was going to post, unfortunately the nudge works fine in this sample, maybe because my "trouble" form was originally designed in version 8. I don't know I'm at a loss.
                  Last edited by popellis; 04-28-2008, 08:58 PM. Reason: Clarify

                  Comment


                  • #10
                    Re: Object "nudge" Micro-Movement not working in v9?

                    That describes the behavior I've seen - perfectly. I've not found any sequence that corrects this.

                    Here's another thing that I've noticed (but maybe this was the case in v8 as well)...

                    When setting snap-to ACTIVE/ON, the snaps are not consistent. Sometimes the object will snap to the next grid dot; sometimes in between grid dots (thus skipping the dot altogether). I allow for the possibility that it's just a monitor resolution & snap calculation issue. But the combination of micro failure and snap inconsistency makes perfection of alignment a real bear.

                    Comment


                    • #11
                      Re: Object "nudge" Micro-Movement not working in v9?

                      But the combination of micro failure and snap inconsistency makes perfection of alignment a real bear.
                      Are the alignment tools not working either? Are they being used? They're on the Arrange menu.

                      Comment


                      • #12
                        Re: Object "nudge" Micro-Movement not working in v9?

                        It seems to be related to the new dynamic guidelines. These can be turned off or there sensitivity adjusted. You will find the settings under the form menu just below the grid item. I turned the guidelines off and the symptoms went away. I turned them back on and depending on the value I used for the sensitivity I could make the delay in the micromovement increase or decrease.
                        Tim Kiebert
                        Eagle Creek Citrus
                        A complex system that does not work is invariably found to have evolved from a simpler system that worked just fine.

                        Comment


                        • #13
                          Re: Object "nudge" Micro-Movement not working in v9?

                          That did it!

                          Form > Dynamic Guidelines > Use dynamic guidelines

                          After unchecking this, nudge seems to work as expected.


                          Many thanks to you, Tim.


                          P.S. Tom, alignment tools worked, but left much work for objects that were meant to be just slightly offset. And thanks to you too, Tom, as I was not aware of the feature.

                          Comment


                          • #14
                            Re: Object "nudge" Micro-Movement not working in v9?

                            Tim, that did the job!!!!

                            The dynamic was created mostly to work when using the mouse to move the objects I bet.

                            Might be better if they could somehow have an auto-off for the dynamic when using the shift and arrow keys to move the object??

                            Comment


                            • #15
                              Re: Object "nudge" Micro-Movement not working in v9?

                              Originally posted by gschepp View Post
                              Tim, that did the job!!!!

                              The dynamic was created mostly to work when using the mouse to move the objects I bet.

                              Might be better if they could somehow have an auto-off for the dynamic when using the shift and arrow keys to move the object??
                              this is fixed now. will be in next update.

                              Comment

                              Working...
                              X