Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Email_send question

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Email_send question

    I have a script as follows:

    :Report.SaveAs("Money_Rep1","PDF",query.filter,query.order,"Money_Bal.PDF",.f.)

    EMAIL_SEND("[email protected],[email protected]","Money Balnaces","","C:\Alpha5V9\brians\Money_Bal.PDF","","",.F.,"","","afakhoury",.F.)

    The script works except it doesn't send to the CC E-mail address.
    I sent the report manually, it goes thru fine, but from the script it doesn't.

    Any ideas?

  • #2
    Re: Email_send question

    You don't have a CC email address specified, you have two primary email addresses. I don't see anything wrong with the way you have specified them.

    To experiment with a CC email address you could try.

    Code:
    EMAIL_SEND("[email protected]","Money Balnaces","","C:\Alpha5V9\brians\Money_Bal.PDF","[email protected]","",.F.,"","","afakhoury",.F.)

    I just did a test in the interactive window.

    rslt = EMAIL_SEND("[email protected],[email protected]","Empty file for test","","C:\test.txt","","",.F.,"","","default",.F.)
    Error sending message
    550 5.7.1 Unable to relay for [email protected]

    And another with no error.

    rslt = EMAIL_SEND("[email protected],[email protected]","Empty file for test","","C:\test.txt","","",.F.,"","","default",.F.)
    Issue seems to lie with your gmail address.
    Last edited by Stan Mathews; 10-01-2008, 04:23 PM.
    There can be only one.

    Comment


    • #3
      Re: Email_send question

      I'm sorry Stan, the code I posted after I wanted to try to send to more than one address, but the code you sent is exactly what I have before and I changed the e-mail address but it didn't work.

      It shows on the first E-mail that a CC was sent, but it actually didn't go thru.
      I know it's not the email address because manually I could send it.

      Also the second email doesn't go thru if I have it as you saw, with a comma between the 2 addresses, I receive it only on the first email.

      Comment


      • #4
        Re: Email_send question

        Also the second email doesn't go thru if I have it as you saw, with a comma between the 2 addresses, I receive it only on the first email.
        Evidently you are not using alpha as your email client.

        You could try it with a semicolon, or try:
        EMAIL_SMTP_OPEN()
        and
        EMAIL_SMTP_SEND()
        instead of email_send()

        Comment


        • #5
          Re: Email_send question

          I'm not, I'm using default, Exchange server

          Comment


          • #6
            Re: Email_send question

            Stan;

            If I use the genie to do the same thing, the report gets delivered fine to the GMAIL address. It only doesn't work if it's called from a script.

            That really isn't a GMAIL issue.

            Comment


            • #7
              Re: Email_send question

              I don't know about gmail, but some email clients use semicolon instead of a colon between the addresses. As I suggested in the previous post, you might consider the other functions instead.

              Comment


              • #8
                Re: Email_send question

                Actually the semi colon works in MS exchange but not in A5, you get an error.
                I will test the way you suggested and see if that works.

                Thanks

                Comment


                • #9
                  Re: Email_send question

                  Gabriel;

                  I tried the EMAIL_SMTP_SEND

                  same thing, it doesn't like GMAIL addresses, neither COMCAST.NET addresses.

                  Comment

                  Working...
                  X