Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

alpha hangs, no obvious reason

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • alpha hangs, no obvious reason

    before posting, i have read all of the posts on 'hanging' and looked to see if these could be the cause.

    the problem - users opens a form to add a child record. the collection of data is based over 2 seperate forms. form 1 completed, then if all data collected, presses a button to go to form 2, when in form2, users clicks dropdown of first field, this is where alpha freezes.

    the form2 only has combos and data entry fields, there is no code on the combos.

    both forms are based upon a table and not a set.

    there is a lot of code on the button to send the user from form1 to form2, but mainly validating the fields in form1 and setting some values in the fields in form1.

    form 2 has no onactivate or oninitiate events other than maximise the screen.

    when alpha freezes, the user has no option but to end task. the user then goes directly back to the client, follows the same events and it works fine.

    it is obviously something i have done. the program is run over a network in to a server with server2003. all machines are xp pro. this is the only place in the entire program that this happens.

    any advice welcome. hope i have provided enough info.

    thanks

    richard

  • #2
    Re: alpha hangs, no obvious reason

    Could you upload an example?

    Comment


    • #3
      Re: alpha hangs, no obvious reason

      Richard,

      It is hard to give you a solid answer with out seeing an example, however, here are some things to look for.

      If you open form2 with out going through form1, does it hang when you use the combo? If the answer is yes, then your problem is most likely on form2.

      If form2 works fine by itself then start looking at the button code that opens form2. Remove(comment out) all the code on the button except for the lines that actually open form2 and see if it hangs. If all is good on form2, start adding your button code back a little at a time until it hangs again. This will narrow it down to where the problem starts.

      I noticed that you said you were "setting some values in the fields in form1", are you saving the record after these values are set and before form2 opens?

      Sorry I can not give you a more solid answer, but this should help you get a better idea of what might be happening.

      Scott

      Comment


      • #4
        Re: alpha hangs, no obvious reason

        Hi Scott / Rui,

        just preparing a demo now, taking me ages to update the live records to test data.

        i will try your idea scott of going to form 2 but not form form 1 and see how that goes.

        problem is, it doesnt happen every time.

        demo in about 30 mins.

        Comment


        • #5
          Re: alpha hangs, no obvious reason

          demo attached

          trying other options now, will report back.

          user - richard harris
          password - direct

          go to contact, open first client nicholas test.

          click case overview

          click fact find

          click recommendations (left hand side)

          select 3rd product, mortgage / halifax plc.

          click edit prods (pencil, top right of browse)

          this takes you to the first of the two forms.

          click on create ros, takes you to form 2.

          if the error does not duplicate, close and save and then on the recommendations form, add a new product, which must be a mortgage.

          Comment


          • #6
            Re: alpha hangs, no obvious reason

            Richard,

            No demo attached.

            Jeff
            Jeff Ryder

            Comment


            • #7
              Re: alpha hangs, no obvious reason

              now attached, took me ages to get this below 5mb limit.

              Comment


              • #8
                Re: alpha hangs, no obvious reason

                Richard,
                You gave very good instructions, but........I cannot get the error to occur .....and when creating a new Mortgage, I get to the page to "Create ROS" and a msg_box comes up telling me that not all fields are filled in (and ALL are) and so cannot proceed.

                In addition, I do not know exactly what forms I am on and so cannot readily find the forms in the control panel. What is easiest is when actually on the form to be able to go directly into design mode....at least easiest for me to try and see if something is obviously a cause of a problem.

                Hopefully someone else can come to your rescue as I have had no luck!! :)
                Mike
                __________________________________________
                It is only when we forget all our learning that we begin to know.
                It's not what you look at that matters, it's what you see.
                Henry David Thoreau
                __________________________________________



                Comment


                • #9
                  Re: alpha hangs, no obvious reason

                  I recently investigated a similar situation with one of my databases.

                  when in form2, users clicks dropdown of first field, this is where alpha freezes.
                  In my situation Machine 1 (really a terminal session) would have an Alpha5 lock up. But it was being caused by another Machine (really a terminal session)

                  What I discovered was that the index for the drop down was being corrupted. The session that was causing the corrupted index was because of a terminal session timeout issue. The Terminal Server session timeouts where too strict and they where terminating idle sessions while people had the database open and in use.

                  While it may be true in your case that your environment does not totally mimic mine. I however would advise you to research the possibility of index's being part of the problem. Identify where the lookup field index is being used and if other people are using the index at the same time as the lookup being clicked.

                  While I can offer some guidance, I am afraid that I can not offer a true resolution. For time being we relaxed our Terminal Server rules to allow more idle time at the session. Since doing so we haven't had any phone calls, but only time will tell.
                  Andrew

                  Comment


                  • #10
                    Re: alpha hangs, no obvious reason

                    mike,

                    sorry, i think the missing field would be interest rates, as they need to be more than 0.0%

                    in design mode the form is fmortprod or fprodmort, cant remember. this has the button with all of the code to take you to form2.

                    aws,

                    there is no index on the combo's, we do run a terminal services and have a few users, but they have not reported the problem. the issues reported are from the local machines which are in the same office as the main server.

                    Comment

                    Working...
                    X