Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Opening a Form or Browse from a comboBox

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ZaphodBBB
    replied
    Re: Opening a Form or Browse from a comboBox

    Hi Tom

    Althopugh I had the issue with AlphaSports where it said "Missing or invalid keyword", when I tried to create a new form in AlphaSports and doing exactly what I did on my own database ie the same dropdown combobox and the same Open Browse action, it worked fine. So I ended up shutting Alpha down as it kept on bringing up the 'create X-Basic code window every time I selected use the Action Genie. After I rebooted my form worked fine.. That's on a pc running Windows Vista.

    Yes my version is out of data as read on here that there had been issues with some builds recently so decided to leave it until sorted.

    Cheers and Thanks
    Mike

    Leave a comment:


  • Tom Cone Jr
    replied
    Re: Opening a Form or Browse from a comboBox

    This shouldn't be hard to unscramble. Zip the database and attach it to a reply here, using the "Go Advanced" editor and the "Manage Attachments" option that the advanced editor offers. If there are more than one form or browse leave a trail of breadcrumbs so we can find the issue you're seeing.

    I also note that your build is a bit out of date. You might consider updating.

    Leave a comment:


  • ZaphodBBB
    started a topic Opening a Form or Browse from a comboBox

    Opening a Form or Browse from a comboBox

    Hi

    This is really my first experiment with A5.
    I imported some data from another database ...went fine.

    I created a form, called frmJobs_review.

    Onto that form I dropped a ComboBox and made it so it displays a list of Job Numbers. on its

    I then created an action called :Open Default Form or Browse
    On "Layout Name" I chose Browse.
    On 'Advanced' tab I accepted the default Pointer called varP_frmJobs_review.


    Then I selected:
    'Records that match the value in a control on the current Form or Report'

    and under Filter: I selected..
    Value in field = 'Job Number'
    and under 'matches the value in the control': Dropdown 1 (the combobox on the form).

    I figured that when I selct a job number from the combobox a browse would pop up , showing all the fields from that particular job, instead I keep on getting a messagebox popping up saying "No records in query". Yet there have to be records as there would not be a Serial number in the jobs table unless it has had a job on it.

    Also whenever I go to the combobox properties it keeps saying under the Field Description, Field..."Missing or invalid Keyword" yet A5 has generated every bit of writing in the properties box?

    Editing as I just noticed the same thing occuring when I open the AlphaSports database and right click and look at the properties for any control on the form in design mode. I'm using 1772:3208.

    Thanks for any assistance
    Mike
Working...
X