Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Browse hidden on open Design mode....

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Browse hidden on open Design mode....

    This just started to make an appearance. Using Build 3238 with new browse, so went back to 3216 and got same results. Anybody else experience this? Have restarted, compacted, rebooted to no avail. Shows and works fine on running. This is just in Design mode.
    Attachments:
    Open Design.jpg - On initial opening of form in design mode
    After Click.jpg - Clicking once where browse is to select
    After DblClick.jpg - After double clicking

    Ernie

  • #2
    Re: Browse hidden on open Design mode....

    No. [ Tested with AlphaSports using the Invoice form. ]

    Comment


    • #3
      Re: Browse hidden on open Design mode....

      Might your browse be hidden behind something ? I can't tell, but maybe you've got a frame or something with a solid background colour, sitting on top of the browse.

      You could check this by clicking the browse once (so that its outline appears), then select "Arrange ... To front" from the menu.

      Comment


      • #4
        Re: Browse hidden on open Design mode....

        There was a frame around it but hadn't changed anything. Ended up having to delete the browse and recreate it.
        Ernie

        Comment


        • #5
          Re: Browse hidden on open Design mode....

          Well, this showed up on another form now. Made no changes to it. Just opened to see what reports I was calling from it.
          In the attached app I have 2 forms:
          expense_wksheet
          income_wksheet
          Double click on income_wksheet to view. All looks Ok. Go into design mode and browse1 and browse2 will not be showing. At least that is what I am experiencing. The expense_wksheet is designed the exact same way, just using different child tables.
          Again, this only shows up in design mode. If you click (in design mode) where the browse should be, you get the outline of it. If you double click where the browse should be, it appears. When you click anywhere else on the form, it disappears.
          I changed NO settings on the browse, so don't know what causes this. Would appreciate any help, and I will submit a bug report if necessary. I was using build 3238 and went back to 3216 with same results.
          Thanks for taking a look.
          Ernie

          Comment


          • #6
            Re: Browse hidden on open Design mode....

            Ernie,

            It appears that the 2 browses are behind the frame. If you click on where the browse should be, and bring it to the front, all seems fine again.

            Bill
            Bill Griffin
            Parkell, Inc

            Comment


            • #7
              Re: Browse hidden on open Design mode....

              Problem seems to be with the "Gradient Fill" style you've chosen for the frame. Suggest you submit formal bug report with copy of database and instructions for them to follow to see the issue. Mention the problem goes away if the "fill style" for the frame object is changed to Solid (Translucent 40%).

              Comment


              • #8
                Re: Browse hidden on open Design mode....

                Bill,
                That doesn't seem to work for me. Disappears when I click away from the browse.
                Tom,
                THanks for figuring that out. Strange. I'll submit a bug report.
                Ernie

                Comment


                • #9
                  Re: Browse hidden on open Design mode....

                  Hmm,

                  Strange. Try this copy. I am curious as to why it is working fine for me...

                  Bill
                  Bill Griffin
                  Parkell, Inc

                  Comment


                  • #10
                    Re: Browse hidden on open Design mode....

                    Bill,
                    That does work. Did you change anything?


                    LATER::::
                    Here is yours and mine set with the Frame object set at Solid and 40% Translucent.
                    Last edited by enstorms; 01-07-2009, 05:11 PM.

                    Comment


                    • #11
                      Re: Browse hidden on open Design mode....

                      Ernie,

                      Just what I said I did. I don't have time tonite, but tomorrow I will redownload your app and make a video of what I did.

                      Bill
                      Bill Griffin
                      Parkell, Inc

                      Comment


                      • #12
                        Re: Browse hidden on open Design mode....

                        Ernie,

                        Attached is a video of what I did, I have no mic so here are the steps:

                        Open Form in desigh mode
                        Right click on areas where the browse should be
                        select order--to front for each browse and save the form.

                        Not sure why they got pushed behind the frame unless you had the browses placed prior to adding the frame.



                        Bill
                        Bill Griffin
                        Parkell, Inc

                        Comment


                        • #13
                          Re: Browse hidden on open Design mode....

                          Bill,
                          THanks. That solves that puzzle. I had gone into Properties and checked the "Always on top", but that didn't help.
                          Just another piece to the knowledge puzzle of a5.
                          Thanks again.
                          Ernie

                          Comment


                          • #14
                            Re: Browse hidden on open Design mode....

                            Your welcome...
                            Bill Griffin
                            Parkell, Inc

                            Comment


                            • #15
                              Re: Browse hidden on open Design mode....

                              Me, too. Thought "Always on Top" meant what it said. Glad to know about "To Front".

                              Comment

                              Working...
                              X