Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Problem with simple query

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Tbaker
    replied
    Re: Problem with simple query

    As a follow-up just received a reply from Selwyn on the bug report based on this thread

    Selwyn said

    thanks very much.

    this is now fixed in v10
    Tom Baker

    Leave a comment:


  • Tbaker
    replied
    Re: Problem with simple query

    Tom

    Thanks for you reply. I was converting a very large application to Version 9 (acutally it will be Version 10) when I ran across this problem. I say problem very loosely since, I do not do it that way any more, I use xdailogs and drop downs to select the invoices and then wrote xbasic code to enter them into the receivable record - it cleaner. But since I liked the way Quickbooks handles checks received, I went back to that old way and that is when I found the problem. I have reported it as a bug in Version 9 but as you say the new browse is going to be auto refresh and yes the browse was reacting to my original query but I concluded that Alpha should know.

    Again thanks for you response, it is always good hearing from you.

    Gaby

    Thanks for your workaround, I will try that just to see how that works. As I said above I use xdaialogs and drop downs to select the invoice that are being paid and only have to enter the check number and the received date only once. Then I use code to enter those into the receivable. It seems to be cleaner and there is no confusion.

    Also thanks for taking the time to preview my zip file - I am a stickler for being able to use things the way they were meant to be and thought that the way they were in Version 7 through 9 old browse was the way. But I did know that Alpha was rewriting the code for the browse for version 10 and that some things were going to change so as Tom said the new browse is doing exactly what it is supposed to do.

    What would we do without this forum and its members.

    Thanks again

    Tom Baker

    Leave a comment:


  • gaby_h
    replied
    Re: Problem with simple query

    FWIW: I am using the following workaround to force the records to stay put when I enter payment date: add 2 additional scripts to the original query script:
    1- Mark records (currently selected records)
    2- New query to look for marked records only.
    This way the second query takes over the 1st query and you can enter your payment date without the record disappearing from view.
    You also need another script/button to unmark records once you have finished your data entry. HTH

    Leave a comment:


  • Tom Cone Jr
    replied
    Re: Problem with simple query

    Tom, I took a look at your example. Thanks for making it so clear and easy to follow. Here's what I think is happening.

    a) when the date_paid and check number are entered the edits have not yet been saved. you could push F9 and commit the changes. At that point the browse display is refreshed. Since the record that was just saved no longer meets the query criteria it does not appear any longer.

    b) Embedded browses have always saved pending edits when focus is shifted outside the browse object, or when focus is shifted to a different row in the browse object itself. This is the same as pressing F9. So, the results you get when you arrow down to the next row are the same as (a), above.

    I think the new browse is refreshing its display when perhaps it did not do so in earlier versions. Although the sequence you want to achieve no longer works the same way I do not think this is a bug. For years people have been struggling with work arounds and custom code to force embedded browses to refresh their displays. Endless posts on this same subject, in all prior versions. I suspect the new browse has been designed to auto-refresh more reliably, and more often. I, for one, would not go back to the old days just on this account. Your form is doing what you want. It's displaying records that match the search criteria. When you change the contents of the record so that the record no longer matches the search criteria the record is not shown. Alpha is doing what you have instructed it to do.

    -- tom

    Leave a comment:


  • Tbaker
    replied
    Re: Problem with simple query

    Gaby

    Thanks for confirming the problem. I have not used the new browse because of this.

    I have already submitted the bug report for Verion 9. I have not submitted the bug report for Version 10 since the released issue will have the completely rewritten browse code - In my v9 bug report I did let them know that the bug was in V10beta but in another post Selwyn advised that the V10Beta did not have the newly coded browse.

    Again, thanks for confirming.

    Tom Baker

    Leave a comment:


  • gaby_h
    replied
    Re: Problem with simple query

    Hi Tom:
    Yes I can confirm this behavior an had similar experience. I think (this is by no means an expert opinion) the query is still in effect, so as soon as you enter the date and move to another record the record no longer meets the criteria (Unit = the value and date is empty) because date is no longer empty. If you start by entering the check# first (instead of starting with date) leaving date empty and move to next record, the 1st record will still be there, enter a date and it disappears from the list.
    Same with sorting. When you sort a browse and enter a new record in the last row, as soon as you move to another record the new record disappears from the bottom of the list and jumps to its sorted order. Not sure if this is a bug, probably intended to work that way. In some cases it's annoying. An Alpha guru can clarify this for us.

    Leave a comment:


  • Tbaker
    started a topic Problem with simple query

    Problem with simple query

    Would appreciate someone looking at the attached sample application. The app contains one table and one form. It is a sample of my accounts receivable check receipt form.

    The form as attached will show a browse with open receivables. To enter checks received you would push the find unit button and enter a unit abbreviation. The query would then show only those records that match the unti abbreviation and the date paid is blank "{}". You would then enter the date paid and the check number for an invoice and then go to another invoice and enter the date paid and the check number. This works in version 7,8 and 9 old browse. In version 9 new browse as soon as you enter the date and the check number and then cursor down to another invoice, the record that you just placed the date paid and the check number will disappear from the browse. (the query is still holding and since the date paid has a date, the query no longer shows that record. In those version that it works, the records stay until you click the find unit button on exit the form.

    Open the form, there is a text box that describes what to do.

    In version 10, the record not only disappears but the cursor jumps all around the place (this was brought up in another post also).

    The problem seems to be the query holding. I have tried qry.drop but as soon as you enter the first check the entire browse reverts to record number order.

    Would appreciate someone looking and confirming, I will then send a bug report in for both version 9 and 10.

    Tom Baker
Working...
X