Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Help with print/preview

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Help with print/preview

    I converted my a5 v.4 database to v.9

    When I open an invoice and try to print from the "print" button, it used to show me the invoice and then I would be able to print it.

    Now when it opens a new window (preview), it is blank.

    I went in to form properties and made sure the correct printer is selected.

    Why won't it show me the current invoice?

    CB

  • #2
    Re: Help with print/preview

    Usually a blank preview indicates that no records were selected. Check your filtering for the report.

    Tom
    Last edited by Tom Henkel; 11-06-2009, 02:23 PM. Reason: can't type

    Comment


    • #3
      Re: Help with print/preview

      are you printing a form or a report?

      does it print anything if you print it? Not preview??
      Dave Mason
      dave@aldadesktop.com
      Skype is dave.mason46

      Comment


      • #4
        Re: Help with print/preview

        a form - and it should show the present form I'm on and should then print, just like it did in my previous version.



        Originally posted by DaveM View Post
        are you printing a form or a report?

        does it print anything if you print it? Not preview??

        Comment


        • #5
          Re: Help with print/preview

          Carol,

          One little thing I learned was to be sure and save the reord first. you are probably doing that though.

          2nd thing was to print reports to get info out and put it in on forms. that said,

          can you let us know what your button does exactly either with the code or with some pictures(screen shots)?

          I just tried a form print and it worked perfectly for both preview and print from the default print button on the menu. when trying it with an unsave record, it came up blank.

          .
          Dave Mason
          dave@aldadesktop.com
          Skype is dave.mason46

          Comment


          • #6
            Re: Help with print/preview

            I did try saving it and it still does not print.


            If I try to print from the default print button on the menu, it says "no printer configured."

            I have 2 buttons on the form to print. One if they paid by credit card and one if it's 30-days.

            Both buttons (to print) worked in my earlier version.

            When I click on "events" for the button (OnPush) shows this:

            preview:
            current_record = alltrim(str(recno(),10,0))
            :Report.preview("Invoice (Credit Card)","BETWEEN(RECNO(),"+ current_record+ "," + current_record+")")
            goto cleanup
            cleanup:
            end





            <<One little thing I learned was to be sure and save the reord first. you are probably doing that though.

            2nd thing was to print reports to get info out and put it in on forms. that said,

            can you let us know what your button does exactly either with the code or with some pictures(screen shots)?

            I just tried a form print and it worked perfectly for both preview and print from the default print button on the menu. when trying it with an unsave record, it came up blank.

            .[/QUOTE]

            Comment


            • #7
              Re: Help with print/preview

              Carol,

              Remake that button using the action scripting. I think it might work better and then convert it to xbasic if you wish.

              What you have looks like version 4.


              after wards, you code may look kind of like this:

              Code:
              'Check to see if you are running the script from within a Form
              dim flag_error as l
              flag_error = .f.
              if is_object(topparent.this) then 
               p = topparent.this
               if p.class() = "Form" then 
                DELETE Parameter1 
                'Set the Parameter variable to the object's .value property
                Parameter1 = eval("P:Acct.value")
               else    'Not in a Form. This is an error condition.
                flag_error = .t.
               end if 
              else
               flag_error = .t.
              end if 
              if flag_error then 
               ui_msg_box("Error","You can only run this script from within a Form",UI_STOP_SYMBOL)
               end 
              end if 
              
              filter = "Acct = [varN->parameter1]"
              query.filter = replace_parameters(filter,local_variables())
              query.order = ""
               
              
              :Report.Print("PayBirdDogTo",query.filter,query.order)
              I did not include one for preview, but you have the choice of preview, print or give a choice of the 2.

              also be sure you have a printer designated as default and check your report to be sure it is not set for a specific printer that no longer exists?


              Hope this solves it.
              Dave Mason
              dave@aldadesktop.com
              Skype is dave.mason46

              Comment


              • #8
                Re: Help with print/preview

                I tried that but get this error message:

                Script:OnPush line:13
                Parameter1 = eval("P:Acct.value")
                Not found
                P:Acct.no found.

                Carol

                Comment


                • #9
                  Re: Help with print/preview

                  This is getting more strange.

                  I went back into the database and the invoice form. When I click on the Print button from some of the earlier invoices, it shows the invoice in the preview window and then I can print. But most of the later invoices, when I click on the print button, the preview window is blank.

                  How can this be happening using the exact same form and the same button?

                  Carol

                  Comment


                  • #10
                    Re: Help with print/preview

                    Carol,

                    I have seen things like this happen when the underlying data isn't correct....either the linking fields for those invoices that are not previewing properly are "out of whack" or perhaps a corrupt index. Go take a look at your underlying data for both the parent and child for the invoice that will not print properly and make sure there is indeed a good "data connection" between the two (i.e. the parent link number exists and is also present in the child table).

                    Regards,

                    Jeff

                    Comment


                    • #11
                      Re: Help with print/preview

                      I've checked all that, rebuilt my indexes, etc.

                      Strange.


                      Carol

                      Originally posted by jkletrovets View Post
                      Carol,

                      I have seen things like this happen when the underlying data isn't correct....either the linking fields for those invoices that are not previewing properly are "out of whack" or perhaps a corrupt index. Go take a look at your underlying data for both the parent and child for the invoice that will not print properly and make sure there is indeed a good "data connection" between the two (i.e. the parent link number exists and is also present in the child table).

                      Regards,

                      Jeff

                      Comment

                      Working...
                      X