Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

JPEGS on a Form Mystery

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • JPEGS on a Form Mystery

    For whatever reason, despite all of the years I’ve used A5, I never used jpegs on a form [not an individual file] and I was surprised by what happened when I finally tried it earlier this week. I was also surprised by something else that happened when I utilized a work around.

    I placed two .jpg files [photos], that were stored in a completely different folder on my hard drive, on a form. I saved the form, opened it, and everything was perfect. I closed the database, opened it, and I could still see both photos correctly displayed on the form so I thought I was finished.

    However, after I exited from Alpha Five, started A5 back up, and then opened my form, I received two messages stating A5 cannot find the bitmaps. I tried this in three different databases with different jpeg files and the results were identical.

    Why did placing a link to the photo files on my hard drive work initially? A5 had no trouble finding the files and displaying them on the form, even after I closed the application. What effect did exiting from A5, as opposed to just closing the application, have on A5's inability to subsequently find those same jpegs?

    Work Around
    ------------
    I imported the image files into the Code Tab of the database. I then edited the form, placing the jpeg files on the form, but this time they came from the library instead of an external folder on my hard drive. That worked even after I exited from A5. However, I noticed that it took an unusually long time to save each form when I used jpeg files stored in the database library.

    I’m sure there’s a logical explanation for all of the above, but I’m baffled.
    Last edited by rtbtat; 02-18-2010, 11:51 AM.

  • #2
    Re: JPEGS on a Form Mystery

    Hi Robert,

    I have always placed Picture files(if there are only a handfull), inside the application folder. That way Alpha has an easy time of looking for them.

    When I first started using Alpha5, the JPEG's were left like you state in their origional folders on a drive.

    But when I went to multiuser applications, the problems started, with the drive mapping.

    Can't explain exactly what happened in your case, but is it a mapping problem?

    Regards

    Ed

    Comment


    • #3
      Re: JPEGS on a Form Mystery

      I love this forum!

      Ed Barley, thank you so much. It looks as if your suggestion was right on the money. I moved the jpegs from an external folder on my hard drive into the application folder. I then added the jpegs to my main form, exited from Alpha Five, opened it again, and voila, the photos were still displayed on the form.

      I don't know why A5 could initially find those jpegs in external folders, even after the application was closed, but then lost them after I exited from Alpha Five. Somehow, shutting down A5 broke the link to the external folders. But whatever the reason for the failure, this appears to be a simple but nifty solution. I don't want to get excited until I know it's still working tomorrow and two weeks from now.
      Last edited by rtbtat; 02-18-2010, 04:21 PM.

      Comment


      • #4
        Re: JPEGS on a Form Mystery

        Hi Robert,

        I remember you helping me a bunch of years back. So hopefully I can repay just a little bit.

        When I made one of my apps with V5.5, I had put Icon, company logo bmp., etc into V5.5 directory, and hardcoded a few reports to the BMP file.

        All the way through V9, I use the same V5.5 folder for the images, for that particular application,so I know it works, using a different folder to hold them.

        Anyway, glad the workaround got you going.

        Regards

        Ed

        Comment


        • #5
          Re: JPEGS on a Form Mystery

          Ed, I was so glad that you remembered my assistance from years ago, that's always appreciated. I usually refer people in need to my close buddy Steve Workings, but it's nice to know that I can occasionally provide help.

          This issue is one of those experiences that does not involve anything major, but it raises my level of frustration to the point that I place too much emphasis upon the unknown cause.

          1. Placing jpegs from an external folder on a form worked.
          2. I could still see the photos after I closed the application several times.
          3. But the link to the photos failed to work after I exited from Alpha Five and subsequently restarted A5. Why?

          I always blame myself for doing something wrong, but maybe there's another logical explanation. Even though the issue is resolved, number 3 above is still puzzling me. I know I should let it go because in the overall scheme of things, it's pretty trivial.

          Comment

          Working...
          X